aboutsummaryrefslogtreecommitdiff
path: root/games/gnubg/Makefile
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2014-02-01 21:37:07 +0000
committerCarlo Strub <cs@FreeBSD.org>2014-02-01 21:37:07 +0000
commite4227f73c6b452414b1d71188bdb94813e346364 (patch)
tree86d5934bf3e7fada60e757e4b3803c4bb10c3937 /games/gnubg/Makefile
parente5166e09fc4f838b3bf9dc0836a964833b9dda12 (diff)
downloadports-e4227f73c6b452414b1d71188bdb94813e346364.tar.gz
ports-e4227f73c6b452414b1d71188bdb94813e346364.zip
- Fix dependencies
- Jobs safe - license
Notes
Notes: svn path=/head/; revision=342213
Diffstat (limited to 'games/gnubg/Makefile')
-rw-r--r--games/gnubg/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/games/gnubg/Makefile b/games/gnubg/Makefile
index ae86a4f9e68c..5d815966926c 100644
--- a/games/gnubg/Makefile
+++ b/games/gnubg/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gnubg
PORTVERSION= 1.02.000
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.c-s.li/ports/ \
http://files.gnubg.org/media/sources/
@@ -11,27 +12,27 @@ DISTFILES= gnubg-release-${PORTVERSION}-sources.tar.gz
MAINTAINER= cs@FreeBSD.org
COMMENT= GNU Backgammon
+LICENSE= GPLv3
+
BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison
-LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp \
- gdbm:${PORTSDIR}/databases/gdbm \
- png15:${PORTSDIR}/graphics/png \
+RUN_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
gtkextra-x11-2.0.1:${PORTSDIR}/x11-toolkits/gtkextra2 \
gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
OPTIONS_DEFINE= ESOUND NLS
OPTIONS_DEFAULT=ESOUND NLS
-CONFIGURE_ARGS= --with-board3d
+CONFIGURE_ARGS= --with-board3d --with-sqlite --with-python
CONFIGURE_ENV= ac_cv_path_ARTSC_CONFIG=no ac_cv_path_LIBART_CONFIG=no
INSTALLS_ICONS= yes
USE_GNOME= libxml2
USES= gmake pathfix shebangfix
-USE_PYTHON= 2.0+
+USE_PYTHON= yes
USE_AUTOTOOLS= libtool automake
GNU_CONFIGURE= yes
-MAKE_JOBS_UNSAFE= yes
.include <bsd.port.options.mk>
@@ -50,18 +51,11 @@ PLIST_SUB+= NLS="@comment "
CONFIGURE_ARGS+= --disable-nls
.endif
-.if ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-CONFIGURE_ARGS+= --disable-sse
-.endif
-
INFO= gnubg
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-post-patch:
- @${REINPLACE_CMD} -e 's|bin\/bash|${PREFIX}bin\/bash|g' ${WRKSRC}/scripts/query_player.sh
-
pre-configure:
cd ${WRKSRC} && ./autogen.sh