aboutsummaryrefslogtreecommitdiff
path: root/games/gnurobbo
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-03-06 01:36:35 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-03-06 01:36:35 +0000
commitcc4c91d4de5cc0d63b7a994ffccc054c76494cc1 (patch)
treed9c1053b50f6b852465a7ce861c95f5da91631f4 /games/gnurobbo
parent86ec42a418ba9e44962dd237a1766177d6c90b5d (diff)
downloadports-cc4c91d4de5cc0d63b7a994ffccc054c76494cc1.tar.gz
ports-cc4c91d4de5cc0d63b7a994ffccc054c76494cc1.zip
GNU Robbo is a free open source reimplementation of LK Avalon's
Robbo for the Atari XE/XL from the late 1980s. The gameplay of the original is faithfully reproduced with a few modifications :- * Lives has been removed and suicide replaced with level restart * Scoring has been removed: goal is level advancement * Bear logic has been enhanced: fixed endlessly spinning bears WWW: http://gnurobbo.sourceforge.net/
Notes
Notes: svn path=/head/; revision=229539
Diffstat (limited to 'games/gnurobbo')
-rw-r--r--games/gnurobbo/Makefile29
-rw-r--r--games/gnurobbo/distinfo3
-rw-r--r--games/gnurobbo/files/patch-Makefile31
-rw-r--r--games/gnurobbo/pkg-descr9
-rw-r--r--games/gnurobbo/pkg-plist35
5 files changed, 107 insertions, 0 deletions
diff --git a/games/gnurobbo/Makefile b/games/gnurobbo/Makefile
new file mode 100644
index 000000000000..211c99282e9f
--- /dev/null
+++ b/games/gnurobbo/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gnurobbo
+# Date created: 05 Mar 2009
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnurobbo
+PORTVERSION= 0.61
+CATEGORIES= games
+MASTER_SITES= SF
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Reimplementation of LK Avalon's Robbo for the Atari XE/XL
+
+USE_GMAKE= yes
+USE_SDL= sdl ttf
+
+MAKE_ENV= DATADIR="${DATADIR}" DOCSDIR="${DOCSDIR}"
+
+PORTDOCS= *
+
+post-patch:
+ @${REINPLACE_CMD} -e '/define DEBUG_DUMP_VM_USAGE/ d' ${WRKSRC}/game.c
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/DOCDIR/ d' ${WRKSRC}/Makefile
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/gnurobbo/distinfo b/games/gnurobbo/distinfo
new file mode 100644
index 000000000000..831de0d3bf93
--- /dev/null
+++ b/games/gnurobbo/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnurobbo-0.61.tar.gz) = 587534e6d67ed37bac698aabcf8944ff
+SHA256 (gnurobbo-0.61.tar.gz) = 0c8b2052e572551991906b70e9c3e72afa29e2591e750975384278f27e453733
+SIZE (gnurobbo-0.61.tar.gz) = 746351
diff --git a/games/gnurobbo/files/patch-Makefile b/games/gnurobbo/files/patch-Makefile
new file mode 100644
index 000000000000..f23c1506b41d
--- /dev/null
+++ b/games/gnurobbo/files/patch-Makefile
@@ -0,0 +1,31 @@
+--- Makefile.orig 2009-03-02 21:56:14.000000000 +0300
++++ Makefile 2009-03-05 17:58:17.000000000 +0300
+@@ -8,9 +8,9 @@
+ #BINDIR=$(HOME)/Games/$(TARGET)/
+ #DOCDIR=$(HOME)/Games/$(TARGET)/
+ # The current folder:
+-PACKAGE_DATA_DIR=./data/
+-BINDIR=./
+-DOCDIR=./
++PACKAGE_DATA_DIR=${DATADIR}
++BINDIR=${PREFIX}/bin
++DOCDIR=${DOCSDIR}
+
+ #You won't need to alter these
+ TARGET=gnurobbo
+@@ -19,11 +19,10 @@
+ VERSION=`cat VERSION`
+
+ #These should be ok for most
+-CC=gcc
+-CFLAGS=-O3 -pipe -Wall -fomit-frame-pointer -I/usr/include `sdl-config --cflags` -DPLATFORM_PC -DVERSION=\"$(VERSION)\" -DPACKAGE_DATA_DIR=\"$(PACKAGE_DATA_DIR)/\"
+-LINK=gcc
+-LDFLAGS=-L/usr/lib
+-LIBS=`sdl-config --libs` -lSDL_ttf
++CFLAGS+=-Wall `$(SDL_CONFIG) --cflags` -DPLATFORM_PC -DVERSION=\"$(VERSION)\" -DPACKAGE_DATA_DIR=\"$(PACKAGE_DATA_DIR)/\"
++LINK=$(CC)
++LDFLAGS=
++LIBS=`$(SDL_CONFIG) --libs` -lSDL_ttf
+
+ #You won't need to alter anything below
+ all: $(SOURCES) $(TARGET)
diff --git a/games/gnurobbo/pkg-descr b/games/gnurobbo/pkg-descr
new file mode 100644
index 000000000000..a59787afc362
--- /dev/null
+++ b/games/gnurobbo/pkg-descr
@@ -0,0 +1,9 @@
+GNU Robbo is a free open source reimplementation of LK Avalon's
+Robbo for the Atari XE/XL from the late 1980s. The gameplay of the
+original is faithfully reproduced with a few modifications :-
+
+ * Lives has been removed and suicide replaced with level restart
+ * Scoring has been removed: goal is level advancement
+ * Bear logic has been enhanced: fixed endlessly spinning bears
+
+WWW: http://gnurobbo.sourceforge.net/
diff --git a/games/gnurobbo/pkg-plist b/games/gnurobbo/pkg-plist
new file mode 100644
index 000000000000..efdbc64fd816
--- /dev/null
+++ b/games/gnurobbo/pkg-plist
@@ -0,0 +1,35 @@
+bin/gnurobbo
+%%DATADIR%%/levels/original.dat
+%%DATADIR%%/levels/robboix.dat
+%%DATADIR%%/levels/robbovii.dat
+%%DATADIR%%/levels/robboviii.dat
+%%DATADIR%%/locales/en_GB/localerc
+%%DATADIR%%/locales/en_GB/text
+%%DATADIR%%/locales/pl_PL/localerc
+%%DATADIR%%/locales/pl_PL/text
+%%DATADIR%%/skins/original/LICENSE-font
+%%DATADIR%%/skins/original/alpha16.bmp
+%%DATADIR%%/skins/original/alpha32.bmp
+%%DATADIR%%/skins/original/ciphers16.bmp
+%%DATADIR%%/skins/original/ciphers32.bmp
+%%DATADIR%%/skins/original/icons16.bmp
+%%DATADIR%%/skins/original/icons32.bmp
+%%DATADIR%%/skins/original/robbo.ttf
+%%DATADIR%%/skins/original/skinrc
+%%DATADIR%%/skins/tronic/LICENSE-font
+%%DATADIR%%/skins/tronic/alpha16.bmp
+%%DATADIR%%/skins/tronic/alpha32.bmp
+%%DATADIR%%/skins/tronic/ciphers16.bmp
+%%DATADIR%%/skins/tronic/ciphers32.bmp
+%%DATADIR%%/skins/tronic/icons16.bmp
+%%DATADIR%%/skins/tronic/icons32.bmp
+%%DATADIR%%/skins/tronic/robbo.ttf
+%%DATADIR%%/skins/tronic/skinrc
+@dirrm %%DATADIR%%/skins/tronic
+@dirrm %%DATADIR%%/skins/original
+@dirrm %%DATADIR%%/skins
+@dirrm %%DATADIR%%/locales/pl_PL
+@dirrm %%DATADIR%%/locales/en_GB
+@dirrm %%DATADIR%%/locales
+@dirrm %%DATADIR%%/levels
+@dirrm %%DATADIR%%