aboutsummaryrefslogtreecommitdiff
path: root/games/gnushogi
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2001-04-30 04:44:02 +0000
committerKris Kennaway <kris@FreeBSD.org>2001-04-30 04:44:02 +0000
commitea0c71f8ae283cc6f9355a86d8eb86f663ee5bed (patch)
treea91bbadc6e02374a0bae4fd499515b4fdc82d8b2 /games/gnushogi
parente946206995b3fc8739e0ef30547ebe10e0a84b54 (diff)
downloadports-ea0c71f8ae283cc6f9355a86d8eb86f663ee5bed.tar.gz
ports-ea0c71f8ae283cc6f9355a86d8eb86f663ee5bed.zip
Respect CC and CFLAGS, don't hard-code -O2
Notes
Notes: svn path=/head/; revision=42062
Diffstat (limited to 'games/gnushogi')
-rw-r--r--games/gnushogi/files/patch-aa13
1 files changed, 11 insertions, 2 deletions
diff --git a/games/gnushogi/files/patch-aa b/games/gnushogi/files/patch-aa
index 3bef78685438..bfcd7cf359d3 100644
--- a/games/gnushogi/files/patch-aa
+++ b/games/gnushogi/files/patch-aa
@@ -1,5 +1,5 @@
--- src/Makefile.orig Wed May 24 07:05:26 1995
-+++ src/Makefile Fri Jan 3 02:57:59 1997
++++ src/Makefile Sun Apr 29 21:39:00 2001
@@ -41,22 +41,22 @@
DIST= ../README-$(VERS) ../doc ../misc ../src
@@ -27,13 +27,22 @@
# Programs being distributed
PROGS=gnushogi-$(VERS)
+@@ -76,7 +76,7 @@
+ #CC= c89 $(OPT) $(GENOPT)
+ # Use this if you are lucky enough to have GNU CC.
+ #CC= /usr/pub/bin/gcc -fsigned-char $(OPT) $(GENOPT)
+-CC= gcc -W -fsigned-char $(OPT) $(GENOPT)
++CC+= -W -fsigned-char $(OPT) $(GENOPT)
+ #CC= cc $(OPT) $(GENOPT)
+
+ # Miscellaneous CFLAGS. Uncomment the one you need and comment the other
@@ -96,7 +96,8 @@
#CFLAGS= -O2 -funroll-loops -traditional-cpp -DNO_STRING_INCLUDE -DNOFIONREAD # gnu cc 2.00 (hawk)
#CFLAGS= -O2 -funroll-loops -DSEVENBIT # djgpp
#CFLAGS= -g -funroll-loops # gnu cc 2.00 on SunOS with debug
-CFLAGS= -O2 -funroll-loops # gnu cc 2.00 on SunOS
+#CFLAGS= -O2 -funroll-loops # gnu cc 2.00 on SunOS
-+CFLAGS= -O2 -pipe -fno-strength-reduce
++CFLAGS+=-fno-strength-reduce
# flags for DJGPP package
#COFF2EXE= coff2exe $(GNUSHOGI)