aboutsummaryrefslogtreecommitdiff
path: root/games/gottet/Makefile
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-02-04 13:57:54 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-02-04 13:57:54 +0000
commitdd21e450888dc4dc85f8250cb0d4730c49e703a3 (patch)
tree5707eb517050c0cb883dd4cd4925c5589456cd7d /games/gottet/Makefile
parent4874eef2c3229903f417d8c07078873175a3a7dc (diff)
downloadports-dd21e450888dc4dc85f8250cb0d4730c49e703a3.tar.gz
ports-dd21e450888dc4dc85f8250cb0d4730c49e703a3.zip
- Add NLS Option and REINPLACE
- Add OPTIONS_SUB - Strip executable - Recreate pkg-plist with make makeplist
Notes
Notes: svn path=/head/; revision=342532
Diffstat (limited to 'games/gottet/Makefile')
-rw-r--r--games/gottet/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/games/gottet/Makefile b/games/gottet/Makefile
index e89f333d032d..4395e952f768 100644
--- a/games/gottet/Makefile
+++ b/games/gottet/Makefile
@@ -20,9 +20,20 @@ INSTALLS_ICONS= yes
PORTDOCS= CREDITS ChangeLog
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+
+.include <bsd.port.options.mk>
+
+post-patch:
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -i '' '/qm.files/,/qm.path/s/^/#/' \
+ ${WRKSRC}/${PORTNAME}.pro
+.endif
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/