aboutsummaryrefslogtreecommitdiff
path: root/games/gtkradiant/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-05-10 18:35:19 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-05-10 18:35:19 +0000
commit8862378f7938a00071db2f0913ed3f8ea8c497b6 (patch)
tree85a0cda76bb34b0e5bb16db5dfccd5b9954e6350 /games/gtkradiant/Makefile
parentb0ff733782af41a24547aeb0f0da5b26234d0f4e (diff)
downloadports-8862378f7938a00071db2f0913ed3f8ea8c497b6.tar.gz
ports-8862378f7938a00071db2f0913ed3f8ea8c497b6.zip
GtkRadiant is a level design program developed by id Software and Loki
Software. It is used to create maps for a number of computer games. GtkRadiant originated as Q3Radiant, the Quake III Arena level design tool, which was a Windows-only application. Two major things are different in GtkRadiant: it is based on the GTK+ toolkit, so it also works in Linux and Mac OS X, and it's also game engine-independent, with functionality for new games added as game packs. GtkRadiant is an Open Source application. Source code is publicly available from id Software's Subversion repository and new additions to the code are covered under open source licenses. The core Q3Radiant code, however, was originally under id Software's proprietary license. The license for both the editor and toolset (notably Q3Map2, the BSP compiler) was changed in February 2006, and publicly released under the GPL on February 17. WWW: http://www.qeradiant.com/ PR: ports/93668 Submitted by: Alejandro Pulver <alejandro@varnet.biz> Approved by: garga (mentor)
Notes
Notes: svn path=/head/; revision=161973
Diffstat (limited to 'games/gtkradiant/Makefile')
-rw-r--r--games/gtkradiant/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/games/gtkradiant/Makefile b/games/gtkradiant/Makefile
new file mode 100644
index 000000000000..c458b278c578
--- /dev/null
+++ b/games/gtkradiant/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: gtkradiant
+# Date created: 9 May 2006
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtkradiant
+PORTVERSION= 1.5.0
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_IDSOFTWARE:S|$|source/:id|} \
+ http://www.bsd-geek.de/FreeBSD/distfiles/:fb
+DISTNAME= GtkRadiant-GPL
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:id \
+ ${PORTNAME}_gamepacks${EXTRACT_SUFX}:fb
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Level design program developed by id Software and Loki Software
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/libsvn/__init__.py:${PORTSDIR}/devel/subversion-python \
+ scons:${PORTSDIR}/devel/scons
+LIB_DEPENDS= gtkglext-x11-1.0.2:${PORTSDIR}/x11-toolkits/gtkglext \
+ mhash.2:${PORTSDIR}/security/mhash \
+ png.5:${PORTSDIR}/graphics/png
+
+WRKSRC= ${WRKDIR}/GPL/GtkRadiant
+
+USE_ZIP= yes
+USE_GCC= 3.4+
+USE_GNOME= gtk20 libxml2
+USE_PYTHON_BUILD= yes
+
+SUB_FILES= ${PORTNAME}
+
+DATADIR= ${PREFIX}/lib/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-libs__bytestreamutils.h \
+ ${FILESDIR}/extra-patch-libs__math__vector.h
+.endif
+
+post-patch:
+.for f in CC CXX CFLAGS LOCALBASE PTHREAD_CFLAGS PTHREAD_LIBS X11BASE
+ @${REINPLACE_CMD} -i '' -e 's|%%${f}%%|${${f}}|g' ${WRKSRC}/SConstruct
+.endfor
+ @${REINPLACE_CMD} -e 's/-ldl//' ${WRKSRC}/SConscript
+ @${GREP} -Rl 'defined[[:blank:]]*([[:blank:]]*__linux__[[:blank:]]*) || defined[[:blank:]]*([[:blank:]]*__APPLE__[[:blank:]]*)' ${WRKSRC} | \
+ ${XARGS} ${REINPLACE_CMD} -e \
+ 's/\(defined[[:blank:]]*([[:blank:]]*__linux__[[:blank:]]*) || defined[[:blank:]]*([[:blank:]]*__APPLE__[[:blank:]]*)\)/\1 || defined (__FreeBSD__)/'
+
+do-build:
+ cd ${WRKSRC} && scons && ${PYTHON_CMD} install.py
+ ${CP} -R ${WRKDIR}/${PORTNAME}_gamepacks/* ${WRKSRC}/install
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${CP} -R ${WRKSRC}/install/* ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.post.mk>