aboutsummaryrefslogtreecommitdiff
path: root/games/gturing/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-21 01:22:23 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-21 01:22:23 +0000
commit555a4e2a70fb482f34c4931f73292a9d6ccec19f (patch)
tree0c82fef6a9933e5c538d283a72170acb930f08de /games/gturing/Makefile
parent9e8b88f9f16a093f2d6d3a95228c71685dbc6b47 (diff)
downloadports-555a4e2a70fb482f34c4931f73292a9d6ccec19f.tar.gz
ports-555a4e2a70fb482f34c4931f73292a9d6ccec19f.zip
New port: games/gturing - A simple Turing machine for gnome2
Gturing is a simple turing machine simulator with graphical interface. A Turing machine is the simplest possible computing device which can only perform very simple operations. However, almost everything in programming languages can be written as a program for the Turing machine. It's a nice complement for students who likes to practice with theory and a nice toy to play with. PR: ports/40368 Submitted by: Juan Salaverria <rael@vectorstar.net>
Notes
Notes: svn path=/head/; revision=73694
Diffstat (limited to 'games/gturing/Makefile')
-rw-r--r--games/gturing/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/games/gturing/Makefile b/games/gturing/Makefile
new file mode 100644
index 000000000000..2d3b1770b3cb
--- /dev/null
+++ b/games/gturing/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: games/gturing
+# Date created: 08 Jul 2002
+# Whom: Juan Salaverria <rael@vectorstar.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gturing
+PORTVERSION= 0.1.1
+CATEGORIES= games gnome
+MASTER_SITES= ftp://ftp.gnome.org/pub/gnome/sources/gturing/0.1/
+
+MAINTAINER= rael@vectorstar.net
+
+LIB_DEPENDS= gnomeui-2.0:${PORTSDIR}/x11-toolkits/libgnomeui \
+ gnomeprintui-2.0:${PORTSDIR}/x11-toolkits/libgnomeprintui
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+DOCS= AUTHORS COPYING NEWS ChangeLog TODO README INSTALL
+
+EXAMPLEDIR= ${PREFIX}/share/examples/gturing
+
+EXAMPLES= 3ones2zeroes.tur add.tur bb3.tur dashnumbers.tur addbin.tur \
+ bb5.tur dec2bin.tur dec2bin_shift.tur bb2.tur bin2dec.tur \
+ bin2dec_shift.tur sort.tur subst.tur
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
+ 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
+ s|[(]datadir[)]/locale|(prefix)/share/locale|g'
+
+post-install:
+ ${INSTALL} -d -o root -g wheel -m 0755 ${EXAMPLEDIR}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/tapes/${f} ${EXAMPLEDIR}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>