aboutsummaryrefslogtreecommitdiff
path: root/games/gturing
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-07-02 22:05:04 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-07-02 22:05:04 +0000
commita1cc73a0c02ca2d4c70264f90cd7b7ce8f71f04c (patch)
tree91d5b50a3c6861d5bc23eab307c9aeb631dd198b /games/gturing
parent17d603d4b652d1b5e5c60fe1b93dd4c7f6eb9db1 (diff)
downloadports-a1cc73a0c02ca2d4c70264f90cd7b7ce8f71f04c.tar.gz
ports-a1cc73a0c02ca2d4c70264f90cd7b7ce8f71f04c.zip
- Stagify
- Pass maintainership to games@ - Switch to USES=libtool
Notes
Notes: svn path=/head/; revision=360284
Diffstat (limited to 'games/gturing')
-rw-r--r--games/gturing/Makefile31
1 files changed, 15 insertions, 16 deletions
diff --git a/games/gturing/Makefile b/games/gturing/Makefile
index c75d378adaa5..4abf48c16aac 100644
--- a/games/gturing/Makefile
+++ b/games/gturing/Makefile
@@ -3,38 +3,37 @@
PORTNAME= gturing
PORTVERSION= 0.1.1
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= games gnome
MASTER_SITES= ftp://ftp.gnome.org/pub/gnome/sources/gturing/0.1/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= games@FreeBSD.org
COMMENT= Simple Turing machine simulator for GNOME 2
-USE_GNOME= gnomeprefix gnomehack libgnomeui
-USES= gettext gmake pkgconfig
-USE_AUTOTOOLS= libtool
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GNOME= gnomeprefix libgnomeui
+USES= gettext gmake libtool pathfix pkgconfig
+GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
INSTALLS_OMF= yes
-PORTDOCS= AUTHORS COPYING NEWS ChangeLog TODO README INSTALL
+PORTDOCS= AUTHORS NEWS ChangeLog TODO README
PORTEXAMPLES= *
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-patch:
@${REINPLACE_CMD} -e 's|-D.*_DISABLE_DEPRECATED||g' \
${WRKSRC}/configure
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for docs in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${docs} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
-
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/tapes/* ${EXAMPLESDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/tapes/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>