aboutsummaryrefslogtreecommitdiff
path: root/games/gturing
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-10-29 22:19:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-10-29 22:19:55 +0000
commitfeda3474b1380b854614784d63e98d49202bcd1e (patch)
treeec79029f0551cd594be9e2a8b9d2cfa8cdadca8b /games/gturing
parentc00ced85cc086ffdc60d97f0e2325aa7176ccdf4 (diff)
downloadports-feda3474b1380b854614784d63e98d49202bcd1e.tar.gz
ports-feda3474b1380b854614784d63e98d49202bcd1e.zip
- Respect NOPORT*
PR: 139618 Submitted by: sylvio@
Notes
Notes: svn path=/head/; revision=243491
Diffstat (limited to 'games/gturing')
-rw-r--r--games/gturing/Makefile28
-rw-r--r--games/gturing/pkg-plist22
2 files changed, 12 insertions, 38 deletions
diff --git a/games/gturing/Makefile b/games/gturing/Makefile
index 96062958cbec..726815088e28 100644
--- a/games/gturing/Makefile
+++ b/games/gturing/Makefile
@@ -11,38 +11,34 @@ PORTREVISION= 14
CATEGORIES= games gnome
MASTER_SITES= ftp://ftp.gnome.org/pub/gnome/sources/gturing/0.1/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= scjamorim@bsd.com.br
COMMENT= A simple turing machine simulator for GNOME 2
USE_GNOME= gnomeprefix gnomehack libgnomeui
USE_GMAKE= yes
+USE_GETTEXT= yes
USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
INSTALLS_OMF= yes
-DOCS= AUTHORS COPYING NEWS ChangeLog TODO README INSTALL
-
-EXAMPLEDIR= ${PREFIX}/share/examples/gturing
-
-EXAMPLES= 3ones2zeroes.tur add.tur bb3.tur dashnumbers.tur addbin.tur \
- bb5.tur dec2bin.tur dec2bin_shift.tur bb2.tur bin2dec.tur \
- bin2dec_shift.tur sort.tur subst.tur
+PORTDOCS= AUTHORS COPYING NEWS ChangeLog TODO README INSTALL
+PORTEXAMPLES= *
post-patch:
@${REINPLACE_CMD} -e 's|-D.*_DISABLE_DEPRECATED||g' \
${WRKSRC}/configure
-
post-install:
- ${INSTALL} -d -o root -g wheel -m 0755 ${EXAMPLEDIR}
-.for f in ${EXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/tapes/${f} ${EXAMPLEDIR}
-.endfor
.if !defined(NOPORTDOCS)
- ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}
+.for docs in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
.endfor
.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/tapes/* ${EXAMPLESDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/games/gturing/pkg-plist b/games/gturing/pkg-plist
index 22fab6acd585..6e38e2c6f2c9 100644
--- a/games/gturing/pkg-plist
+++ b/games/gturing/pkg-plist
@@ -1,24 +1,4 @@
bin/gturing
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%EXAMPLESDIR%%/3ones2zeroes.tur
-%%EXAMPLESDIR%%/add.tur
-%%EXAMPLESDIR%%/addbin.tur
-%%EXAMPLESDIR%%/bb2.tur
-%%EXAMPLESDIR%%/bb3.tur
-%%EXAMPLESDIR%%/bb5.tur
-%%EXAMPLESDIR%%/bin2dec.tur
-%%EXAMPLESDIR%%/bin2dec_shift.tur
-%%EXAMPLESDIR%%/dashnumbers.tur
-%%EXAMPLESDIR%%/dec2bin.tur
-%%EXAMPLESDIR%%/dec2bin_shift.tur
-%%EXAMPLESDIR%%/sort.tur
-%%EXAMPLESDIR%%/subst.tur
share/applications/gturing.desktop
share/gnome/help/gturing/C/figures/mainwin.png
share/gnome/help/gturing/C/gturing.xml
@@ -65,6 +45,4 @@ share/locale/zh_TW/LC_MESSAGES/gturing-2.0.mo
@dirrm share/gnome/help/gturing/C/figures
@dirrm share/gnome/help/gturing/C
@dirrm share/gnome/help/gturing
-@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry share/applications