aboutsummaryrefslogtreecommitdiff
path: root/games/gzdoom
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-05-11 14:14:01 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-05-11 14:14:01 +0000
commitd4111913efcc7957f68edb60e87efa9202ac0ca1 (patch)
treed5a5ca11e66282915d29377c9715672813b3737c /games/gzdoom
parent75055f8a7f540517d9f2d762238516fd44103eca (diff)
downloadports-d4111913efcc7957f68edb60e87efa9202ac0ca1.tar.gz
ports-d4111913efcc7957f68edb60e87efa9202ac0ca1.zip
games/gzdoom: update to 4.1.1
Commit the whole patch this time. Approved by: mat (mentor), kevans (maintainer)
Notes
Notes: svn path=/head/; revision=501260
Diffstat (limited to 'games/gzdoom')
-rw-r--r--games/gzdoom/Makefile6
-rw-r--r--games/gzdoom/distinfo6
-rw-r--r--games/gzdoom/files/patch-src_gamedata_fonts_font.cpp10
-rw-r--r--games/gzdoom/files/patch-src_rendering_vulkan_thirdparty_vk__mem__alloc_vk__mem__alloc.h11
4 files changed, 27 insertions, 6 deletions
diff --git a/games/gzdoom/Makefile b/games/gzdoom/Makefile
index ef2002799fe3..f4c2cc1d2247 100644
--- a/games/gzdoom/Makefile
+++ b/games/gzdoom/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= gzdoom
-PORTVERSION= 3.7.2
-PORTREVISION= 1
+PORTVERSION= 4.1.1
DISTVERSIONPREFIX= g
CATEGORIES= games
@@ -22,7 +21,8 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfluidsynth.so:audio/fluidsynth \
libgme.so:audio/libgme
-USES= cmake gettext jpeg openal pkgconfig
+USES= cmake compiler:c++11-lang gettext gl gnome jpeg openal \
+ pkgconfig sdl
DATADIR= ${DMDIR}/${PORTNAME}
diff --git a/games/gzdoom/distinfo b/games/gzdoom/distinfo
index d31c165b4578..4c6afb691a03 100644
--- a/games/gzdoom/distinfo
+++ b/games/gzdoom/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1549010707
-SHA256 (coelckers-gzdoom-g3.7.2_GH0.tar.gz) = 5fb57c83b733d77688b5809b3bd64ab87f0976f4e81d3bbac0ea0785a24646cc
-SIZE (coelckers-gzdoom-g3.7.2_GH0.tar.gz) = 10512467
+TIMESTAMP = 1557581862
+SHA256 (coelckers-gzdoom-g4.1.1_GH0.tar.gz) = 50ce34b48518fb8715d6e346ff3ac8d08fd24b34e764be88335810fa592fb84a
+SIZE (coelckers-gzdoom-g4.1.1_GH0.tar.gz) = 13008847
diff --git a/games/gzdoom/files/patch-src_gamedata_fonts_font.cpp b/games/gzdoom/files/patch-src_gamedata_fonts_font.cpp
new file mode 100644
index 000000000000..7c1ffffda357
--- /dev/null
+++ b/games/gzdoom/files/patch-src_gamedata_fonts_font.cpp
@@ -0,0 +1,10 @@
+--- src/gamedata/fonts/font.cpp.orig 2019-05-03 16:07:35 UTC
++++ src/gamedata/fonts/font.cpp
+@@ -35,6 +35,7 @@
+
+ // HEADER FILES ------------------------------------------------------------
+
++#include <cwctype>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <math.h>
diff --git a/games/gzdoom/files/patch-src_rendering_vulkan_thirdparty_vk__mem__alloc_vk__mem__alloc.h b/games/gzdoom/files/patch-src_rendering_vulkan_thirdparty_vk__mem__alloc_vk__mem__alloc.h
new file mode 100644
index 000000000000..fdcf35ad700a
--- /dev/null
+++ b/games/gzdoom/files/patch-src_rendering_vulkan_thirdparty_vk__mem__alloc_vk__mem__alloc.h
@@ -0,0 +1,11 @@
+--- src/rendering/vulkan/thirdparty/vk_mem_alloc/vk_mem_alloc.h.orig 2019-05-03 15:59:56 UTC
++++ src/rendering/vulkan/thirdparty/vk_mem_alloc/vk_mem_alloc.h
+@@ -2229,7 +2229,7 @@ remove them if not needed.
+ #include <mutex> // for std::mutex
+ #include <atomic> // for std::atomic
+
+-#if !defined(_WIN32) && !defined(__APPLE__)
++#if !defined(_WIN32) && !defined(__APPLE__) && !defined(__FreeBSD__)
+ #include <malloc.h> // for aligned_alloc()
+ #endif
+