aboutsummaryrefslogtreecommitdiff
path: root/games/hllib
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2013-02-14 22:04:06 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2013-02-14 22:04:06 +0000
commit13f09390a9da3044847a2f99e45c335dfa39fb5b (patch)
treeec601524b7075d3905c7658877e23ce5402bbad0 /games/hllib
parenta5f49b820e951d9b51223f451b25fbf1f21d80e7 (diff)
downloadports-13f09390a9da3044847a2f99e45c335dfa39fb5b.tar.gz
ports-13f09390a9da3044847a2f99e45c335dfa39fb5b.zip
- Update to 2.4.4
- Pass maintainership to submitter - Make CLANG happy PR: ports/176040 Submitted by: Danilo Egea Gondolfo <danilogondolfo@gmail.com>
Notes
Notes: svn path=/head/; revision=312244
Diffstat (limited to 'games/hllib')
-rw-r--r--games/hllib/Makefile12
-rw-r--r--games/hllib/distinfo4
-rw-r--r--games/hllib/files/patch-HLLib-BSPFile.cpp19
-rw-r--r--games/hllib/files/patch-HLLib-DirectoryFolder.cpp58
-rw-r--r--games/hllib/files/patch-HLLib-Error.cpp12
-rw-r--r--games/hllib/files/patch-HLLib-FileStream.cpp13
-rw-r--r--games/hllib/files/patch-HLLib-GCFFile.cpp27
-rw-r--r--games/hllib/files/patch-HLLib-HLLib.cpp31
-rw-r--r--games/hllib/files/patch-HLLib-NCFFile.cpp27
-rw-r--r--games/hllib/files/patch-HLLib-SGAFile.cpp34
-rw-r--r--games/hllib/files/patch-HLLib-SGAFile.h14
-rw-r--r--games/hllib/files/patch-HLLib-VBSPFile.cpp38
-rw-r--r--games/hllib/files/patch-HLLib-VPKFile.cpp18
-rw-r--r--games/hllib/files/patch-HLLib-WADFile.cpp18
-rw-r--r--games/hllib/files/patch-HLLib-XZPFile.cpp27
-rw-r--r--games/hllib/files/patch-HLLib-ZIPFile.cpp24
16 files changed, 370 insertions, 6 deletions
diff --git a/games/hllib/Makefile b/games/hllib/Makefile
index 8b538fea9a3a..34af692f054e 100644
--- a/games/hllib/Makefile
+++ b/games/hllib/Makefile
@@ -2,23 +2,25 @@
# $FreeBSD$
PORTNAME= hllib
-PORTVERSION= 2.4.3
+PORTVERSION= 2.4.4
CATEGORIES= games devel
MASTER_SITES= http://nemesis.thewavelength.net/files/files/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danilogondolfo@gmail.com
COMMENT= Library to work with various Half-Life file formats
LICENSE= LGPL21
USE_ZIP= yes
-USE_DOS2UNIX= Makefile # required by make(1)
+USE_DOS2UNIX= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/HLLib
CFLAGS+= -fpic -DUSE_ZLIB
-HLLIB_VERS= 2.3.0
+PATCH_WRKSRC= ${WRKDIR}
+
+HLLIB_VERS= 2.4.4
PLIST_FILES= include/hl.h lib/libhl.so.${HLLIB_VERS} \
lib/libhl.so.2 lib/libhl.so
@@ -33,5 +35,7 @@ post-patch:
@${REINPLACE_CMD} -e '/friend CSGADirectory/d' ${WRKSRC}/SGAFile.h
# Add missing -lz
@${REINPLACE_CMD} -e '/$$(LDFLAGS)/s,$$, -lz,' ${WRKSRC}/Makefile
+# Fix library version
+ @${REINPLACE_CMD} -e 's/2\.3\.0/2\.4\.4/' ${WRKSRC}/Makefile
.include <bsd.port.mk>
diff --git a/games/hllib/distinfo b/games/hllib/distinfo
index f855201d7d04..2aec4971ab18 100644
--- a/games/hllib/distinfo
+++ b/games/hllib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hllib243.zip) = 2eafa706ab4cccea0c9966f45e5eabf4bad27b5b4b224cc6592ba68debd54ae0
-SIZE (hllib243.zip) = 591480
+SHA256 (hllib244.zip) = cb94da1c32e9577dce1aa2bbb77f283212684afcd7814d42228c9ffff71d3699
+SIZE (hllib244.zip) = 593745
diff --git a/games/hllib/files/patch-HLLib-BSPFile.cpp b/games/hllib/files/patch-HLLib-BSPFile.cpp
new file mode 100644
index 000000000000..1319946358d2
--- /dev/null
+++ b/games/hllib/files/patch-HLLib-BSPFile.cpp
@@ -0,0 +1,19 @@
+--- ../orig/HLLib/BSPFile.cpp 2010-10-31 22:48:46.000000000 -0200
++++ ./HLLib/BSPFile.cpp 2013-02-11 17:56:51.271215107 -0200
+@@ -203,10 +203,14 @@
+ hlAttributeSetUnsignedInteger(&Attribute, this->lpItemAttributeNames[eAttribute], uiPaletteSize, hlFalse);
+ return hlTrue;
+ }
++ default:
++ ;
+ }
+ }
+ break;
+ }
++ default:
++ ;
+ }
+
+ return hlFalse;
+Only in ./HLLib: BSPFile.cpp.orig
+diff -ru ../orig/HLLib/DirectoryFolder.cpp ./HLLib/DirectoryFolder.cpp
diff --git a/games/hllib/files/patch-HLLib-DirectoryFolder.cpp b/games/hllib/files/patch-HLLib-DirectoryFolder.cpp
new file mode 100644
index 000000000000..d30230ad81d5
--- /dev/null
+++ b/games/hllib/files/patch-HLLib-DirectoryFolder.cpp
@@ -0,0 +1,58 @@
+--- ../orig/HLLib/DirectoryFolder.cpp 2012-09-17 20:16:52.000000000 -0300
++++ ./HLLib/DirectoryFolder.cpp 2013-02-11 17:56:51.275211034 -0200
+@@ -517,6 +517,8 @@
+ case HL_ITEM_FILE:
+ uiSize += static_cast<const CDirectoryFile *>(pItem)->GetSize();
+ break;
++ default:
++ ;
+ }
+ }
+
+@@ -541,6 +543,8 @@
+ case HL_ITEM_FILE:
+ uiSize += static_cast<hlULongLong>(static_cast<const CDirectoryFile *>(pItem)->GetSize());
+ break;
++ default:
++ ;
+ }
+ }
+
+@@ -565,6 +569,8 @@
+ case HL_ITEM_FILE:
+ uiSize += static_cast<const CDirectoryFile *>(pItem)->GetSizeOnDisk();
+ break;
++ default:
++ ;
+ }
+ }
+
+@@ -589,6 +595,8 @@
+ case HL_ITEM_FILE:
+ uiSize += static_cast<hlULongLong>(static_cast<const CDirectoryFile *>(pItem)->GetSizeOnDisk());
+ break;
++ default:
++ ;
+ }
+ }
+
+@@ -611,6 +619,8 @@
+ uiCount += static_cast<const CDirectoryFolder *>(pItem)->GetFolderCount(bRecurse);
+ }
+ break;
++ default:
++ ;
+ }
+ }
+
+@@ -635,6 +645,8 @@
+ case HL_ITEM_FILE:
+ uiCount++;
+ break;
++ default:
++ ;
+ }
+ }
+
+Only in ./HLLib: DirectoryFolder.cpp.orig
+diff -ru ../orig/HLLib/Error.cpp ./HLLib/Error.cpp
diff --git a/games/hllib/files/patch-HLLib-Error.cpp b/games/hllib/files/patch-HLLib-Error.cpp
new file mode 100644
index 000000000000..eb7803eca274
--- /dev/null
+++ b/games/hllib/files/patch-HLLib-Error.cpp
@@ -0,0 +1,12 @@
+--- ../orig/HLLib/Error.cpp 2010-04-17 13:48:52.000000000 -0300
++++ ./HLLib/Error.cpp 2013-02-11 18:00:09.931600402 -0200
+@@ -139,7 +139,7 @@
+
+ hlUInt uiLength = (hlUInt)strlen(this->lpSystemError);
+
+- while(uiLength >= 0 && isspace(this->lpSystemError[uiLength - 1]))
++ while(isspace(this->lpSystemError[uiLength - 1]))
+ {
+ uiLength--;
+ }
+diff -ru ../orig/HLLib/FileStream.cpp ./HLLib/FileStream.cpp
diff --git a/games/hllib/files/patch-HLLib-FileStream.cpp b/games/hllib/files/patch-HLLib-FileStream.cpp
new file mode 100644
index 000000000000..93726d2bab45
--- /dev/null
+++ b/games/hllib/files/patch-HLLib-FileStream.cpp
@@ -0,0 +1,13 @@
+--- ../orig/HLLib/FileStream.cpp 2010-10-28 20:41:26.000000000 -0200
++++ ./HLLib/FileStream.cpp 2013-02-11 17:56:51.278212203 -0200
+@@ -216,6 +216,8 @@
+ case HL_SEEK_END:
+ iMode = SEEK_END;
+ break;
++ default:
++ ;
+ }
+
+ return (hlUInt)lseek(this->iFile, iOffset, iMode);
+Only in ./HLLib: FileStream.cpp.orig
+diff -ru ../orig/HLLib/GCFFile.cpp ./HLLib/GCFFile.cpp
diff --git a/games/hllib/files/patch-HLLib-GCFFile.cpp b/games/hllib/files/patch-HLLib-GCFFile.cpp
new file mode 100644
index 000000000000..e0fd2cddfccf
--- /dev/null
+++ b/games/hllib/files/patch-HLLib-GCFFile.cpp
@@ -0,0 +1,27 @@
+--- ../orig/HLLib/GCFFile.cpp 2010-11-01 20:56:16.000000000 -0200
++++ ./HLLib/GCFFile.cpp 2013-02-11 17:56:51.281214140 -0200
+@@ -789,6 +789,8 @@
+ }
+ return hlTrue;
+ }
++ default:
++ ;
+ }
+ break;
+ }
+@@ -819,9 +821,13 @@
+ }
+ return hlTrue;
+ }
++ default:
++ ;
+ }
+ break;
+ }
++ default:
++ ;
+ }
+
+ return hlFalse;
+Only in ./HLLib: GCFFile.cpp.orig
+diff -ru ../orig/HLLib/HLLib.cpp ./HLLib/HLLib.cpp
diff --git a/games/hllib/files/patch-HLLib-HLLib.cpp b/games/hllib/files/patch-HLLib-HLLib.cpp
new file mode 100644
index 000000000000..baa8a8daeceb
--- /dev/null
+++ b/games/hllib/files/patch-HLLib-HLLib.cpp
@@ -0,0 +1,31 @@
+--- ../orig/HLLib/HLLib.cpp 2010-11-01 19:45:14.000000000 -0200
++++ ./HLLib/HLLib.cpp 2013-02-11 17:56:51.284213443 -0200
+@@ -153,6 +153,8 @@
+ case HL_PACKAGE_BOUND:
+ *pValue = pPackage != 0;
+ return hlTrue;
++ default:
++ ;
+ }
+
+ return hlFalse;
+@@ -171,6 +173,8 @@
+ case HL_FORCE_DEFRAGMENT:
+ bForceDefragment = bValue;
+ break;
++ default:
++ ;
+ }
+ }
+
+@@ -533,6 +537,8 @@
+ case HL_PROC_DEFRAGMENT_PROGRESS_EX:
+ pDefragmentProgressExProc = (PDefragmentProgressExProc)pValue;
+ break;
++ default:
++ ;
+ }
+ }
+
+Only in ./HLLib: HLLib.cpp.orig
+diff -ru ../orig/HLLib/Makefile ./HLLib/Makefile
diff --git a/games/hllib/files/patch-HLLib-NCFFile.cpp b/games/hllib/files/patch-HLLib-NCFFile.cpp
new file mode 100644
index 000000000000..4ee859b435dd
--- /dev/null
+++ b/games/hllib/files/patch-HLLib-NCFFile.cpp
@@ -0,0 +1,27 @@
+--- ../orig/HLLib/NCFFile.cpp 2010-10-31 22:48:26.000000000 -0200
++++ ./HLLib/NCFFile.cpp 2013-02-11 17:56:51.287210992 -0200
+@@ -347,6 +347,8 @@
+ hlAttributeSetUnsignedInteger(&Attribute, this->lpItemAttributeNames[eAttribute], this->lpDirectoryEntries[pFile->GetID()].uiDirectoryFlags, hlTrue);
+ return hlTrue;
+ }
++ default:
++ ;
+ }
+ break;
+ }
+@@ -360,9 +362,13 @@
+ hlAttributeSetUnsignedInteger(&Attribute, this->lpItemAttributeNames[eAttribute], this->lpDirectoryEntries[pFolder->GetID()].uiDirectoryFlags, hlTrue);
+ return hlTrue;
+ }
++ default:
++ ;
+ }
+ break;
+ }
++ default:
++ ;
+ }
+
+ return hlFalse;
+Only in ./HLLib: NCFFile.cpp.orig
+diff -ru ../orig/HLLib/SGAFile.cpp ./HLLib/SGAFile.cpp
diff --git a/games/hllib/files/patch-HLLib-SGAFile.cpp b/games/hllib/files/patch-HLLib-SGAFile.cpp
new file mode 100644
index 000000000000..61a8bd920106
--- /dev/null
+++ b/games/hllib/files/patch-HLLib-SGAFile.cpp
@@ -0,0 +1,34 @@
+--- ../orig/HLLib/SGAFile.cpp 2012-11-20 20:17:10.000000000 -0200
++++ ./HLLib/SGAFile.cpp 2013-02-11 17:56:51.289212795 -0200
+@@ -387,6 +387,8 @@
+ }
+ return hlFalse;
+ }
++ default:
++ ;
+ }
+ break;
+ }
+@@ -448,9 +450,13 @@
+ }
+ return hlFalse;
+ }
++ default:
++ ;
+ }
+ break;
+ }
++ default:
++ ;
+ }
+ }
+ return hlFalse;
+@@ -624,4 +630,4 @@
+ {
+ delete []static_cast<const hlByte *>(static_cast<Streams::CMemoryStream &>(Stream).GetBuffer());
+ }
+-}
+\ No newline at end of file
++}
+Only in ./HLLib: SGAFile.cpp.orig
+diff -ru ../orig/HLLib/SGAFile.h ./HLLib/SGAFile.h
diff --git a/games/hllib/files/patch-HLLib-SGAFile.h b/games/hllib/files/patch-HLLib-SGAFile.h
new file mode 100644
index 000000000000..3876b7ea7b53
--- /dev/null
+++ b/games/hllib/files/patch-HLLib-SGAFile.h
@@ -0,0 +1,14 @@
+--- ../orig/HLLib/SGAFile.h 2012-09-17 20:16:38.000000000 -0300
++++ ./HLLib/SGAFile.h 2013-02-11 17:56:51.311213431 -0200
+@@ -160,8 +160,6 @@
+ typedef CSGADirectory<SGADirectoryHeader4, SGASection4, SGAFolder4, SGAFile, SGAFileHeader> CSGADirectory4;
+ typedef CSGADirectory<SGADirectoryHeader5, SGASection5, SGAFolder5, SGAFile, SGAFileHeader> CSGADirectory5;
+
+- friend CSGADirectory4;
+- friend CSGADirectory5;
+
+ private:
+ static const char *lpAttributeNames[];
+Only in ./HLLib: SGAFile.h.bak
+Only in ./HLLib: SGAFile.h.orig
+diff -ru ../orig/HLLib/VBSPFile.cpp ./HLLib/VBSPFile.cpp
diff --git a/games/hllib/files/patch-HLLib-VBSPFile.cpp b/games/hllib/files/patch-HLLib-VBSPFile.cpp
new file mode 100644
index 000000000000..362103bfd905
--- /dev/null
+++ b/games/hllib/files/patch-HLLib-VBSPFile.cpp
@@ -0,0 +1,38 @@
+--- ../orig/HLLib/VBSPFile.cpp 2011-05-22 07:53:42.000000000 -0300
++++ ./HLLib/VBSPFile.cpp 2013-02-11 17:56:51.294217852 -0200
+@@ -422,6 +422,8 @@
+ delete []lpComment;
+ return hlTrue;
+ }
++ default:
++ ;
+ }
+ }
+ else
+@@ -444,6 +446,8 @@
+ hlAttributeSetUnsignedInteger(&Attribute, this->lpItemAttributeNames[eAttribute], *(hlUInt *)this->pHeader->lpLumps[uiID].lpFourCC, hlTrue);
+ return hlTrue;
+ }
++ default:
++ ;
+ }
+
+ if(this->pEndOfCentralDirectoryRecord != 0 && pItem->GetID() == HL_VBSP_LUMP_PAKFILE)
+@@ -466,11 +470,15 @@
+ delete []lpComment;
+ return hlTrue;
+ }
++ default:
++ ;
+ }
+ }
+ }
+ break;
+ }
++ default:
++ ;
+ }
+
+ return hlFalse;
+Only in ./HLLib: VBSPFile.cpp.orig
+diff -ru ../orig/HLLib/VPKFile.cpp ./HLLib/VPKFile.cpp
diff --git a/games/hllib/files/patch-HLLib-VPKFile.cpp b/games/hllib/files/patch-HLLib-VPKFile.cpp
new file mode 100644
index 000000000000..3995ecf6fdeb
--- /dev/null
+++ b/games/hllib/files/patch-HLLib-VPKFile.cpp
@@ -0,0 +1,18 @@
+--- ../orig/HLLib/VPKFile.cpp 2013-01-27 14:13:28.000000000 -0200
++++ ./HLLib/VPKFile.cpp 2013-02-11 17:56:51.297217265 -0200
+@@ -415,9 +415,13 @@
+ hlAttributeSetUnsignedInteger(&Attribute, this->lpItemAttributeNames[eAttribute], pDirectoryItem->pDirectoryEntry->uiCRC, hlTrue);
+ return hlTrue;
+ }
++ default:
++ ;
+ }
+ break;
+ }
++ default:
++ ;
+ }
+
+ return hlFalse;
+Only in ./HLLib: VPKFile.cpp.orig
+diff -ru ../orig/HLLib/WADFile.cpp ./HLLib/WADFile.cpp
diff --git a/games/hllib/files/patch-HLLib-WADFile.cpp b/games/hllib/files/patch-HLLib-WADFile.cpp
new file mode 100644
index 000000000000..415c11c737a1
--- /dev/null
+++ b/games/hllib/files/patch-HLLib-WADFile.cpp
@@ -0,0 +1,18 @@
+--- ../orig/HLLib/WADFile.cpp 2010-10-31 22:56:14.000000000 -0200
++++ ./HLLib/WADFile.cpp 2013-02-11 17:56:51.300216459 -0200
+@@ -200,9 +200,13 @@
+ hlAttributeSetUnsignedInteger(&Attribute, this->lpItemAttributeNames[eAttribute], (hlUInt)pLump->iType, hlTrue);
+ return hlTrue;
+ }
++ default:
++ ;
+ }
+ break;
+ }
++ default:
++ ;
+ }
+
+ return hlFalse;
+Only in ./HLLib: WADFile.cpp.orig
+diff -ru ../orig/HLLib/XZPFile.cpp ./HLLib/XZPFile.cpp
diff --git a/games/hllib/files/patch-HLLib-XZPFile.cpp b/games/hllib/files/patch-HLLib-XZPFile.cpp
new file mode 100644
index 000000000000..4219d93d9b0d
--- /dev/null
+++ b/games/hllib/files/patch-HLLib-XZPFile.cpp
@@ -0,0 +1,27 @@
+--- ../orig/HLLib/XZPFile.cpp 2010-10-31 22:49:18.000000000 -0200
++++ ./HLLib/XZPFile.cpp 2013-02-11 17:56:51.302217604 -0200
+@@ -197,7 +197,7 @@
+ for(hlUInt i = 0; i < this->pHeader->uiDirectoryEntryCount; i++)
+ {
+ hlChar lpTemp[16] = "";
+- hlChar *lpLookup[] = { "0", "1", "2", "3", "4", "5", "6", "7", "8", "9", "a", "b", "c", "d", "e", "f" };
++ const hlChar *lpLookup[] = { "0", "1", "2", "3", "4", "5", "6", "7", "8", "9", "a", "b", "c", "d", "e", "f" };
+ for(hlByte *lpCRC = (hlByte *)&this->lpDirectoryEntries[i].uiFileNameCRC; lpCRC < (hlByte *)&this->lpDirectoryEntries[i].uiFileNameCRC + sizeof(hlUInt); lpCRC++)
+ {
+ strcat(lpTemp, lpLookup[(hlByte)(*lpCRC >> 4)]);
+@@ -299,9 +299,13 @@
+ hlAttributeSetUnsignedInteger(&Attribute, this->lpItemAttributeNames[eAttribute], uiSize, hlFalse);
+ return hlTrue;
+ }
++ default:
++ ;
+ }
+ break;
+ }
++ default:
++ ;
+ }
+
+ return hlFalse;
+Only in ./HLLib: XZPFile.cpp.orig
+diff -ru ../orig/HLLib/ZIPFile.cpp ./HLLib/ZIPFile.cpp
diff --git a/games/hllib/files/patch-HLLib-ZIPFile.cpp b/games/hllib/files/patch-HLLib-ZIPFile.cpp
new file mode 100644
index 000000000000..a2c23064d955
--- /dev/null
+++ b/games/hllib/files/patch-HLLib-ZIPFile.cpp
@@ -0,0 +1,24 @@
+--- ../orig/HLLib/ZIPFile.cpp 2012-09-18 19:51:30.000000000 -0300
++++ ./HLLib/ZIPFile.cpp 2013-02-11 17:56:51.305211203 -0200
+@@ -393,9 +393,13 @@
+ delete []lpComment;
+ return hlTrue;
+ }
++ default:
++ ;
+ }
+ break;
+ }
++ default:
++ ;
+ }
+
+ return hlFalse;
+@@ -598,4 +602,4 @@
+ {
+ delete []static_cast<const hlByte *>(static_cast<Streams::CMemoryStream &>(Stream).GetBuffer());
+ }
+-}
+\ No newline at end of file
++}
+Only in ./HLLib: ZIPFile.cpp.orig