aboutsummaryrefslogtreecommitdiff
path: root/games/hlstatsx/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-14 02:32:10 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-14 02:32:10 +0000
commit4659bd12dc57a859a0c8151aae99ef546102deaa (patch)
tree25ab2ccc1e7bd3faa2c4e16f33a161deb2a08c3b /games/hlstatsx/Makefile
parentae077a8dfeecf15a07f89ff7a5f546a4e9cf31e6 (diff)
downloadports-4659bd12dc57a859a0c8151aae99ef546102deaa.tar.gz
ports-4659bd12dc57a859a0c8151aae99ef546102deaa.zip
Adding port games/hlstatsx, Real-time player and clan rankings and
statistics for HL2 and mods. PR: ports/98859 Submitted by: Babak Farrokhi <babak@farrokhi.net> Reviewed by: aaron Approved by: tobez
Notes
Notes: svn path=/head/; revision=165353
Diffstat (limited to 'games/hlstatsx/Makefile')
-rw-r--r--games/hlstatsx/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/games/hlstatsx/Makefile b/games/hlstatsx/Makefile
new file mode 100644
index 000000000000..cf0cb3314c8d
--- /dev/null
+++ b/games/hlstatsx/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: hlstatsx
+# Date created: 2006-06-12
+# Whom: Babak Farrokhi <babak@farrokhi.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hlstatsx
+PORTVERSION= 1.01
+CATEGORIES= games www
+MASTER_SITES= http://www.hlstatsx.com/downloads/
+DISTNAME= HLstatsX_V${PORTVERSION}
+
+MAINTAINER= babak@farrokhi.net
+COMMENT= Real-time player and clan rankings and statistics for HL2 and mods
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+
+NO_BUILD= yes
+USE_APACHE= yes
+USE_PHP= gd mysql
+USE_PERL5_RUN= yes
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+HLSTATSX?= www/${PORTNAME}
+PLIST_SUB+= HLSTATSX=${HLSTATSX}
+EXTRACT_AFTER_ARGS= -d ${WRKSRC}
+
+do-install:
+ @ ${MKDIR} ${PREFIX}/${HLSTATSX}
+ @ ${CP} -R ${WRKSRC}/* ${PREFIX}/${HLSTATSX}
+ @ ${ECHO_MSG} "*"
+ @ ${ECHO_MSG} "* Files have been installed in"
+ @ ${ECHO_MSG} "* ${PREFIX}/${HLSTATSX}"
+ @ ${ECHO_MSG} "*"
+ @ ${ECHO_MSG} "* Visit http://www.hlstatsx.com/installation/ for instructions on getting it running."
+ @ ${ECHO_MSG} "*"
+
+.include <bsd.port.mk>