aboutsummaryrefslogtreecommitdiff
path: root/games/jigzo/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /games/jigzo/Makefile
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'games/jigzo/Makefile')
-rw-r--r--games/jigzo/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/jigzo/Makefile b/games/jigzo/Makefile
index da193d0766c0..aaac10f37cb0 100644
--- a/games/jigzo/Makefile
+++ b/games/jigzo/Makefile
@@ -20,12 +20,12 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
USE_SDL= sdl mixer
-USE_GL= yes
+USE_GL= gl
USE_GMAKE= yes
MAKE_ENV= CXX="${CXX}" \
- CPPFLAGS="`${SDL_CONFIG} --cflags` -I${X11BASE}/include" \
- LDFLAGS="`${SDL_CONFIG} --libs` -L${X11BASE}/lib"
+ CPPFLAGS="`${SDL_CONFIG} --cflags` -I${LOCALBASE}/include" \
+ LDFLAGS="`${SDL_CONFIG} --libs` -L${LOCALBASE}/lib"
post-patch:
.for i in font image puzzles sound