aboutsummaryrefslogtreecommitdiff
path: root/games/libretro-xrick
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2020-12-18 12:16:23 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2020-12-18 12:16:23 +0000
commita33b20469b6541c2f5eafd18243d98c2773ab46d (patch)
tree820021dfc0d483d14239dc24bdcde0d30826771b /games/libretro-xrick
parent4557210d3fe5379ca26781e3bc54768b8053aca9 (diff)
downloadports-a33b20469b6541c2f5eafd18243d98c2773ab46d.tar.gz
ports-a33b20469b6541c2f5eafd18243d98c2773ab46d.zip
Add new port games/libretro-xrick:
Libretro implementation of "Rick Dangerous". https://github.com/libretro/xrick-libretro PR: 246795 Submitted by: Daniel Menelkir
Notes
Notes: svn path=/head/; revision=558369
Diffstat (limited to 'games/libretro-xrick')
-rw-r--r--games/libretro-xrick/Makefile29
-rw-r--r--games/libretro-xrick/distinfo3
-rw-r--r--games/libretro-xrick/files/patch-Makefile.libretro11
-rw-r--r--games/libretro-xrick/pkg-descr3
4 files changed, 46 insertions, 0 deletions
diff --git a/games/libretro-xrick/Makefile b/games/libretro-xrick/Makefile
new file mode 100644
index 000000000000..32d3ace7d902
--- /dev/null
+++ b/games/libretro-xrick/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= libretro-xrick
+PORTVERSION= 0.20201218
+CATEGORIES= games
+
+MAINTAINER= menelkir@itroll.org
+COMMENT= Libretro implementation of "Rick Dangerous"
+
+LICENSE= GPLv2
+
+USES= gmake localbase sdl dos2unix
+USE_SDL= sdl
+
+USE_GITHUB= yes
+GH_ACCOUNT= libretro
+GH_PROJECT= xrick-libretro
+GH_TAGNAME= 0aad6c6
+
+MAKEFILE= Makefile.libretro
+DOS2UNIX_FILES= ${MAKEFILE}
+
+PLIST_FILES= lib/libretro/xrick_libretro.so
+
+do-install:
+ ${MKDIR} ${STAGEDIR}/${PREFIX}/lib/libretro
+ ${INSTALL_LIB} ${WRKSRC}/xrick_libretro.so ${STAGEDIR}/${PREFIX}/lib/libretro
+
+.include <bsd.port.mk>
diff --git a/games/libretro-xrick/distinfo b/games/libretro-xrick/distinfo
new file mode 100644
index 000000000000..15f124e045d2
--- /dev/null
+++ b/games/libretro-xrick/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608288977
+SHA256 (libretro-xrick-libretro-0.20201218-0aad6c6_GH0.tar.gz) = 7697696c0f4bf42f8564f6cfa19d5d680cba1c11f7e585b3c952a579622c2e06
+SIZE (libretro-xrick-libretro-0.20201218-0aad6c6_GH0.tar.gz) = 1821992
diff --git a/games/libretro-xrick/files/patch-Makefile.libretro b/games/libretro-xrick/files/patch-Makefile.libretro
new file mode 100644
index 000000000000..57601b18ecc2
--- /dev/null
+++ b/games/libretro-xrick/files/patch-Makefile.libretro
@@ -0,0 +1,11 @@
+--- Makefile.libretro.orig 2020-10-07 22:50:55 UTC
++++ Makefile.libretro
+@@ -39,7 +39,7 @@ ifeq ($(platform), android)
+ SHARED := -Wl,--fix-cortex-a8 -llog --shared -Wl,--version-script=$(CORE_DIR)/libretro/core/link.T -Wl,--no-undefined
+
+ else ifeq ($(platform), unix)
+- CC = gcc
++ CC?= gcc
+ TARGET := $(TARGET_NAME)_libretro.so
+ fpic := -fPIC
+ ifneq ($(findstring SunOS,$(shell uname -a)),)
diff --git a/games/libretro-xrick/pkg-descr b/games/libretro-xrick/pkg-descr
new file mode 100644
index 000000000000..4b82c7034b6a
--- /dev/null
+++ b/games/libretro-xrick/pkg-descr
@@ -0,0 +1,3 @@
+Libretro implementation of "Rick Dangerous".
+
+WWW: https://github.com/libretro/xrick-libretro