aboutsummaryrefslogtreecommitdiff
path: root/games/linux-candycruncher-demo
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2009-02-07 01:30:05 +0000
committerBeech Rintoul <beech@FreeBSD.org>2009-02-07 01:30:05 +0000
commitafa11322a547bc10d3fdb7b04a0d069cf3c530ea (patch)
tree5c9cde0966b973ba43d6d3c2d16785bbda67fa1c /games/linux-candycruncher-demo
parent9ffc0270c40e07a7820ee4a6eb104ba3d5978c41 (diff)
downloadports-afa11322a547bc10d3fdb7b04a0d069cf3c530ea.tar.gz
ports-afa11322a547bc10d3fdb7b04a0d069cf3c530ea.zip
Candy Cruncher is a fast puzzle game with a lot of candy inside. Move candies
around the board to complete rows and columns, so they crunch away and do not exceed the time limit! WWW: http://www.linuxgamepublishing.com/info.php?id=10 PR: ports/131191 Submitted by: Marcus von Appen <mva at sysfault.org>
Notes
Notes: svn path=/head/; revision=227745
Diffstat (limited to 'games/linux-candycruncher-demo')
-rw-r--r--games/linux-candycruncher-demo/Makefile59
-rw-r--r--games/linux-candycruncher-demo/distinfo3
-rw-r--r--games/linux-candycruncher-demo/files/candycruncher.in4
-rw-r--r--games/linux-candycruncher-demo/pkg-descr5
-rw-r--r--games/linux-candycruncher-demo/pkg-plist8
5 files changed, 79 insertions, 0 deletions
diff --git a/games/linux-candycruncher-demo/Makefile b/games/linux-candycruncher-demo/Makefile
new file mode 100644
index 000000000000..3620d1619fc1
--- /dev/null
+++ b/games/linux-candycruncher-demo/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: linux-candycruncher-demo
+# Date created: 2009-01-30
+# Whom: Marcus von Appen <mva@sysfault.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= candycruncher-demo
+PORTVERSION= 1.53
+CATEGORIES= games linux
+MASTER_SITES= http://demofiles.linuxgamepublishing.com/candycruncher/
+PKGNAMEPREFIX= linux-
+DISTNAME= candycruncher_demo
+EXTRACT_SUFX= .run
+
+MAINTAINER= mva@sysfault.org
+COMMENT= Candy Cruncher Demo - a fast puzzle game with lots of candies
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12 \
+ ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg \
+ ${LINUXBASE}/usr/lib/libSDL_mixer-1.2.so.0:${PORTSDIR}/audio/linux-sdl_mixer \
+ ${LINUXBASE}/usr/lib/libmikmod.so.2:${PORTSDIR}/audio/linux-mikmod \
+ ${LINUXBASE}/usr/lib/libogg.so.0:${PORTSDIR}/audio/linux-libogg \
+ ${LINUXBASE}/usr/lib/libvorbis.so.0:${PORTSDIR}/audio/linux-libvorbis \
+ ${LINUXBASE}/lib/libasound.so.2:${PORTSDIR}/audio/linux-alsa-lib
+
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_XLIB= yes
+NO_CDROM= Redistribution is limited, see license
+NO_BUILD= yes
+
+DATADIR= ${PREFIX}/lib/${PKGNAMEPREFIX}${PORTNAME}
+SUB_FILES= candycruncher
+PORTDOCS= README README.licenses README.unixthanks license.txt
+
+.include <bsd.port.pre.mk>
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @cd ${WRKSRC} && ${TAIL} +377 ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | \
+ ${TAR} jxf -
+
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/bin/Linux/x86/Bin/candycruncher_demo
+ ${BRANDELF} -t Linux ${WRKSRC}/bin/Linux/x86/Bin/candycruncher_demo.dynamic
+
+do-install:
+ @${MKDIR} ${DATADIR}/Bin
+ @cd ${WRKSRC}/bin/Linux/x86/Bin && \
+ ${INSTALL_PROGRAM} candycruncher_demo candycruncher_demo.dynamic ${DATADIR}/Bin
+ @${INSTALL_PROGRAM} ${WRKDIR}/candycruncher ${PREFIX}/bin/${PKGNAMEPREFIX}candycruncher
+ @${CP} -R ${WRKSRC}/Resources ${DATADIR}
+.if !defined (NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/linux-candycruncher-demo/distinfo b/games/linux-candycruncher-demo/distinfo
new file mode 100644
index 000000000000..4501a7dfe146
--- /dev/null
+++ b/games/linux-candycruncher-demo/distinfo
@@ -0,0 +1,3 @@
+MD5 (candycruncher_demo.run) = 0682dd0d67710e2ad7ba001973e57d9b
+SHA256 (candycruncher_demo.run) = dc138ea0ad7e6be8fbb6e33c7de8bf40c60c27ce3209b82576d038a0996a5ccc
+SIZE (candycruncher_demo.run) = 5593297
diff --git a/games/linux-candycruncher-demo/files/candycruncher.in b/games/linux-candycruncher-demo/files/candycruncher.in
new file mode 100644
index 000000000000..45c976465f55
--- /dev/null
+++ b/games/linux-candycruncher-demo/files/candycruncher.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd %%DATADIR%% || exit 1
+exec ./Bin/candycruncher_demo "$@"
diff --git a/games/linux-candycruncher-demo/pkg-descr b/games/linux-candycruncher-demo/pkg-descr
new file mode 100644
index 000000000000..f7e784f24fa9
--- /dev/null
+++ b/games/linux-candycruncher-demo/pkg-descr
@@ -0,0 +1,5 @@
+Candy Cruncher is a fast puzzle game with a lot of candy inside. Move candies
+around the board to complete rows and columns, so they crunch away and do
+not exceed the time limit!
+
+WWW: http://www.linuxgamepublishing.com/info.php?id=10
diff --git a/games/linux-candycruncher-demo/pkg-plist b/games/linux-candycruncher-demo/pkg-plist
new file mode 100644
index 000000000000..7daf680ada8a
--- /dev/null
+++ b/games/linux-candycruncher-demo/pkg-plist
@@ -0,0 +1,8 @@
+bin/linux-candycruncher
+%%DATADIR%%/Bin/candycruncher_demo
+%%DATADIR%%/Bin/candycruncher_demo.dynamic
+%%DATADIR%%/Resources/cruncher.pyz
+%%DATADIR%%/Resources/pyrogon.ttf
+@dirrm %%DATADIR%%/Bin
+@dirrm %%DATADIR%%/Resources
+@dirrm %%DATADIR%%