aboutsummaryrefslogtreecommitdiff
path: root/games/linux-nwnclient
diff options
context:
space:
mode:
authorSean Farley <scf@FreeBSD.org>2010-09-27 18:32:05 +0000
committerSean Farley <scf@FreeBSD.org>2010-09-27 18:32:05 +0000
commitb4508067f15cd1ea38e3b005cbd329235427c5fe (patch)
treee5db9856c23a5707e729ab72dcca4b0d8f0ab286 /games/linux-nwnclient
parente81744cb8c2aee4ca83f3aa0eb1cb4651cfbc50c (diff)
downloadports-b4508067f15cd1ea38e3b005cbd329235427c5fe.tar.gz
ports-b4508067f15cd1ea38e3b005cbd329235427c5fe.zip
Update client to v1.69 which is the final release from BioWare.
Remove ARCH requirement for i386; let the install of the Linux base determine if the port is allowed or not. Detect if the original or Diamond game files were installed in games/nwndata to install the appropriate client. Add an option to install the NWMovies/BinkPlayer patch to play in-game movies for the Diamond client. This includes a rewritten script (from Perl to shell) to remove the need for Linux Perl to run it. The script includes a method to skip movies, especially the intro movies, as noted in pkg-message. Default to off. In the nwn script, remove dead links in and rebuild ${HOME}/.nwn. This allows moving between the original and Diamond editions without confusing (resulting in segmentation faults) the client. Set SDL_AUDIODRIVER to dsp by default to remove warnings from SDL concerning audio setup. Disallow core files as these are commonly seen when the game exits. Fortunately, the segmentation fault does not affect play nor the configuration files. Approved by: wxs
Notes
Notes: svn path=/head/; revision=261967
Diffstat (limited to 'games/linux-nwnclient')
-rw-r--r--games/linux-nwnclient/Makefile69
-rw-r--r--games/linux-nwnclient/distinfo21
-rw-r--r--games/linux-nwnclient/files/nwmovies.pl76
-rw-r--r--games/linux-nwnclient/files/nwn.sh70
-rw-r--r--games/linux-nwnclient/pkg-message21
-rw-r--r--games/linux-nwnclient/pkg-plist71
6 files changed, 282 insertions, 46 deletions
diff --git a/games/linux-nwnclient/Makefile b/games/linux-nwnclient/Makefile
index 143ee0b5d663..08edd1b720d8 100644
--- a/games/linux-nwnclient/Makefile
+++ b/games/linux-nwnclient/Makefile
@@ -6,21 +6,24 @@
#
PORTNAME= nwnclient
-PORTVERSION= 1.68
+PORTVERSION= 1.69
CATEGORIES= games linux
-MASTER_SITES= http://bioware.vo.llnwd.net/o1/neverwinternights/updates/linux/${PORTVERSION:S/.//}/ \
- http://nwdownloads.bioware.com/neverwinternights/linux/129/
+MASTER_SITES= http://na.llnet.bioware.cdn.ea.com/u/f/eagames/bioware/neverwinternights/updates/linux/${PORTVERSION:S/.//}/:CLIENT \
+ http://nwdownloads.bioware.com/neverwinternights/linux/129/:ORIG \
+ http://nwdownloads.bioware.com/neverwinternights/linux/gold/:GOLD \
+ http://nwdownloads.bioware.com/neverwinternights/linux/161/:HOTU \
+ http://home.roadrunner.com/~nwmovies/nwmovies/:NWMOVIES \
+ http://www.radgametools.com/down/Bink/:BINK
PKGNAMEPREFIX= linux-
-DISTFILES= nwclient129.tar.gz \
- English_linuxclient${PORTVERSION:S/.//}_orig.tar.gz
+DISTFILES= ${CLIENT_FILES} \
+ ${CLIENT_NWMOVIES}
-MAINTAINER= sean-freebsd@farley.org
+MAINTAINER= scf@FreeBSD.org
COMMENT= Neverwinter Nights Linux (x86) Client
-RUN_DEPENDS= ${LOCALBASE}/share/nwndata/NWNv129.txt:${PORTSDIR}/games/nwndata
+RUN_DEPENDS= ${LOCALBASE}/share/nwndata/docs/readme.txt:${PORTSDIR}/games/nwndata
NO_BUILD= yes
-ONLY_FOR_ARCHS= i386
USE_LINUX= yes
USE_LINUX_APPS= sdl12 xorglibs
NWNDATADIR= ${LOCALBASE}/share/nwndata
@@ -32,15 +35,48 @@ USE_LINUX_APPS+=libglu
USE_LINUX_APPS+=dri
.endif
-PLIST_SUB+= NWNVERSION="${PORTVERSION:S/.//}"
+OPTIONS= NWMOVIES "Install support for movies using BinkPlayer" off
+
+.include <bsd.port.pre.mk>
+
+# Client detection. Currently, detects only original and Diamond editions.
+.if exists(${LOCALBASE}/share/nwndata/xp2.key)
+CLIENT_FILES= nwclientgold.tar.gz:GOLD \
+ nwclienthotu.tar.gz:HOTU \
+ English_linuxclient169_xp2.tar.gz:CLIENT
+.if !defined(WITHOUT_NWMOVIES)
+NWMOVIESFILE= nwmovies-v4-public.20090223.080954.tar.gz
+BINKPLAYERFILE= BinkLinuxPlayer.zip
+CLIENT_NWMOVIES=${NWMOVIESFILE}:NWMOVIES \
+ ${BINKPLAYERFILE}:BINK
+USE_LINUX_APPS+=sdlmixer
+PLIST_SUB+= NWMOVIES=""
+.else
+PLIST_SUB+= NWMOVIES="@comment"
+.endif
+PLIST_SUB+= DIAMOND="" ORIGINAL="@comment "
+.else
+CLIENT_FILES= nwclient129.tar.gz:ORIG \
+ English_linuxclient${PORTVERSION:S/.//}_orig.tar.gz:CLIENT
+PLIST_SUB+= NWMOVIES="@comment" DIAMOND="@comment " ORIGINAL=""
+.endif
do-extract:
${MKDIR} ${WRKSRC}
-.for _distfile in ${DISTFILES}
+.for _distfile in ${CLIENT_FILES:C/:.*$//g} ${BINKPLAYERFILE}
(cd ${WRKSRC} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
${DISTDIR}/${_distfile} ${EXTRACT_AFTER_ARGS})
.endfor
- ${RM} ${WRKSRC}/lib/libSDL* ${WRKSRC}/fixinstall ${WRKSRC}/nwn
+.if !defined(WITHOUT_NWMOVIES)
+ (cd ${WRKSRC} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
+ ${DISTDIR}/${NWMOVIESFILE} ${EXTRACT_AFTER_ARGS} \
+ nwmovies/binklib.so nwmovies/libdis/libdisasm.so \
+ nwmovies/nwmovies.so)
+ (cd ${WRKSRC} && ${MV} BinkPlayer nwmovies)
+.endif
+ ${RM} ${WRKSRC}/lib/libSDL* ${WRKSRC}/SDL-1.2.5/* ${WRKSRC}/fixinstall \
+ ${WRKSRC}/nwn
+ ${RMDIR} ${WRKSRC}/SDL-1.2.5
do-configure:
${SED} -e 's|%%NWNDATADIR%%|${NWNDATADIR}|' \
@@ -50,12 +86,15 @@ do-configure:
do-install:
${MKDIR} ${DATADIR}
(cd ${WRKSRC} && ${FIND} . -print | \
- ${CPIO} -pdmuv -R${SHAREOWN}:${SHAREGRP} ${DATADIR})
- ${LN} -s ${LINUXBASE}/usr/lib/libstdc++-2-libc6.1-1-2.9.0.so \
- ${DATADIR}/lib/libstdc++-libc6.1-2.so.3
+ ${CPIO} -pdmuv -R${SHAREOWN}:${SHAREGRP} ${DATADIR})
${FIND} ${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 0755
${FIND} ${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 0644
(cd ${DATADIR} && ${CHMOD} 0755 dmclient nwmain nwserver)
+.if !defined(WITHOUT_NWMOVIES)
+ (cd ${DATADIR} && ${CHMOD} 0755 nwmovies/BinkPlayer)
+ (cd ${DATADIR}/nwmovies && ${LN} -s /compat/linux/usr/lib/libX11.so.6 libX11.so)
+ ${INSTALL_SCRIPT} ${FILESDIR}/nwmovies.pl ${DATADIR}
+.endif
${INSTALL_SCRIPT} ${WRKDIR}/nwn ${PREFIX}/bin/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/linux-nwnclient/distinfo b/games/linux-nwnclient/distinfo
index 2098bf12f671..f694a59eb6ae 100644
--- a/games/linux-nwnclient/distinfo
+++ b/games/linux-nwnclient/distinfo
@@ -1,6 +1,21 @@
+MD5 (English_linuxclient169_orig.tar.gz) = 1a8ea3a8bc03c1b33e1207e574f95023
+SHA256 (English_linuxclient169_orig.tar.gz) = 50932f9647ea7968dbb8f7ab1fc6478035fff0826379a45762c1de8e46d1d2b0
+SIZE (English_linuxclient169_orig.tar.gz) = 473297170
+MD5 (English_linuxclient169_xp2.tar.gz) = b021f0da3b3e00848521926716fdf487
+SHA256 (English_linuxclient169_xp2.tar.gz) = 09715e2b95c025ef7f00d218deec1b1edce501530d8cba51d61097c69699763f
+SIZE (English_linuxclient169_xp2.tar.gz) = 506025948
MD5 (nwclient129.tar.gz) = 73c6515fd6aa5f860802098a55000ae8
SHA256 (nwclient129.tar.gz) = 3d75e07f4d44fde789481240d02c07a7a7e0599bc2300d8a73f98f4c752da80e
SIZE (nwclient129.tar.gz) = 5504342
-MD5 (English_linuxclient168_orig.tar.gz) = 73f4304a5c2afd016d656baa0e1f4d12
-SHA256 (English_linuxclient168_orig.tar.gz) = 03687bff0469cb08a7e5a14316e076a6bfe698121ccee4e2116f0bf119988092
-SIZE (English_linuxclient168_orig.tar.gz) = 130569338
+MD5 (nwclientgold.tar.gz) = 0a059d55225fc32f905e86191d88a11f
+SHA256 (nwclientgold.tar.gz) = 6aea73cee2f6c9733ef4a121888cb3451d8a31b968a02e1ec897242df53395f3
+SIZE (nwclientgold.tar.gz) = 7559227
+MD5 (nwclienthotu.tar.gz) = 376cdece07106ea058d42b531f3146bb
+SHA256 (nwclienthotu.tar.gz) = 0a4ace1aacd69fb166d09bd249ce5ae98dd28f580765f52e0147bb85f7dfcfd7
+SIZE (nwclienthotu.tar.gz) = 39611339
+MD5 (nwmovies-v4-public.20090223.080954.tar.gz) = 1698a83bce2050174670e30c42b9d673
+SHA256 (nwmovies-v4-public.20090223.080954.tar.gz) = 4ce60791183a0623d09b37c9f00ba42a2f7e7d953eba35b090a96cc891254f14
+SIZE (nwmovies-v4-public.20090223.080954.tar.gz) = 137697
+MD5 (BinkLinuxPlayer.zip) = 574af4d6c63f0d61fbe7b3fa76665f9c
+SHA256 (BinkLinuxPlayer.zip) = ba3102eb70627f7a97c82f3a9efaacbccef64d1f48dda2b4338b0f27d5f50418
+SIZE (BinkLinuxPlayer.zip) = 85507
diff --git a/games/linux-nwnclient/files/nwmovies.pl b/games/linux-nwnclient/files/nwmovies.pl
new file mode 100644
index 000000000000..6c4b5d2a78eb
--- /dev/null
+++ b/games/linux-nwnclient/files/nwmovies.pl
@@ -0,0 +1,76 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# There is a Perl script that accompanies the NWMovies distfile, however, it
+# would require Linux Perl to be installed when a simple shell script will
+# suffice. Since the name of the Perl script is hardcoded into the binary, this
+# file has a .pl extension even though it is Bourne shell.
+
+# Initialization.
+NWNUSERDIR="${HOME}/.nwn"
+NWNSKIPFILE=${NWNUSERDIR}/nwmovies.skip
+NWNMOVIEDIR=${NWNUSERDIR}/movies
+NWNMOVIES=${NWNUSERDIR}/nwmovies
+NWNINI=${NWNUSERDIR}/nwn.ini
+
+# Print arguments in lowercase
+tolower() {
+ set -e
+ echo "$@" | tr '[:upper:]' '[:lower:]'
+}
+
+# Determine case-insensitive movie name to play prior to setting LD_PRELOAD.
+reqmovie="$(tolower ${NWNMOVIEDIR}/${1}).bik"
+for m in ${NWNMOVIEDIR}/*
+do
+ if [ ${reqmovie} = $(tolower ${m}) ]
+ then
+ movie="${m}"
+ break
+ fi
+done
+if [ -z "${movie}" ]
+then
+ echo "${reqmovie} not found"
+ exit 1
+fi
+
+# Skip movies request by user.
+if [ -e ${NWNSKIPFILE} ]
+then
+ reqmovie="$(tolower ${1})"
+ for m in `cat ${NWNSKIPFILE}`
+ do
+ if [ ${reqmovie} = $(tolower ${m}) ]
+ then
+ echo "Skipping ${1} as requested"
+ exit 0
+ fi
+ done
+fi
+
+# Prevent core files from BinkPlayer.
+ulimit -c 0
+
+# Configure movie display (default to 800x600 if not in .ini file).
+BINK_WIDTH=`grep -i width ${NWNINI} | cut -f 2 -d '='` 2> /dev/null
+export BINK_WIDTH=${BINK_WIDTH:-800}
+BINK_HEIGHT=`grep -i height ${NWNINI} | cut -f 2 -d '='` 2> /dev/null
+export BINK_HEIGHT=${BINK_HEIGHT:-600}
+export BINK_FULLSCREEN=1
+
+# Silence warnings from SDL.
+export SDL_AUDIODRIVER=${SDL_AUDIODRIVER:-"dsp"}
+
+# Configure for needed libraries (some are only needed if running standalone).
+if [ ! -e ${NWNMOVIES}/libX11.so ]
+then
+ ln -sf /compat/linux/usr/lib/libX11.so.6 ${NWNMOVIES}/libX11.so
+fi
+export LD_LIBRARY_PATH=${NWNUSERDIR}/nwmovies:${LD_LIBRARY_PATH}
+export LD_PRELOAD=./nwmovies/binklib.so
+
+# Play movie.
+./nwmovies/BinkPlayer ${movie}
diff --git a/games/linux-nwnclient/files/nwn.sh b/games/linux-nwnclient/files/nwn.sh
index 8f6cb855d646..1459b4f0549a 100644
--- a/games/linux-nwnclient/files/nwn.sh
+++ b/games/linux-nwnclient/files/nwn.sh
@@ -10,6 +10,20 @@ LCDIRS="ambient data dmvault hak localvault music override portraits"
set -e
+# Print arguments in lowercase
+tolower() {
+ set -e
+ echo "$@" | tr '[:upper:]' '[:lower:]'
+}
+
+# Rename all files in a directory to lowercase
+lowerdir() {
+ set -e
+ find "$@" -name '*[A-Z]*' | while read name ; do
+ mv -v "${name}" "$(tolower ${name})"
+ done
+}
+
# Copy a directory structure and symlink its contents
copydir() {
set -e
@@ -23,23 +37,25 @@ copydir() {
cp -R "${file}" "${NWNUSERDIR}/${file}"
done
find . -type f | cut -c 3- | while read file ; do
- [ -e "${NWNUSERDIR}/${file}" ] ||
+ [ -e "${NWNUSERDIR}/${file}" -o \
+ -e "$(tolower ${NWNUSERDIR}/${file})" ] ||
ln -s "${1}/${file}" "${NWNUSERDIR}/${file}"
done
}
-# Print arguments in lowercase
-tolower() {
- set -e
- echo "$@" | tr '[:upper:]' '[:lower:]'
-}
+# Create user directory. Will also update a user directory if anything is
+# different due to running NWN with different versions of the game.
+rebuilduserdir() {
+ # Copy ${NWNCLIENTDIR} first since it may contain files which
+ # override parts of ${NWNDATADIR}
+ copydir "${NWNCLIENTDIR}"
+ copydir "${NWNDATADIR}"
-# Rename all files in a directory to lowercase
-lowerdir() {
- set -e
- find "$@" -name '*[A-Z]*' | while read name ; do
- mv -v "${name}" "$(tolower ${name})"
- done
+ # Some files need to have their names converted to lowercase. Create
+ # the directories if missing due to differences between versions of NWN.
+ cd "${NWNUSERDIR}"
+ mkdir -p ${LCDIRS}
+ lowerdir ${LCDIRS}
}
if [ ! -d "${NWNUSERDIR}" ] ; then
@@ -54,30 +70,42 @@ if [ ! -d "${NWNUSERDIR}" ] ; then
# initally empty or missing
echo '[CDKEY]' >"${NWNUSERDIR}/nwncdkey.ini"
- # Copy ${NWNCLIENTDIR} first since it may contain files which
- # override parts of ${NWNDATADIR}
- copydir "${NWNCLIENTDIR}"
- copydir "${NWNDATADIR}"
-
- # Some files need to have their names converted to lowercase
- cd "${NWNUSERDIR}"
- lowerdir ${LCDIRS}
+ rebuilduserdir
echo "Your Neverwinter Nights directory (~/.nwn) has now been"
echo "created and populated. Press ENTER to start the game."
read dummy
+else
+ # Remove dead links from different versions (e.g., original versus
+ # Diamond Edition) of NWN as they could confuse the game.
+ find -L ${NWNUSERDIR} -type l -exec rm -- {} +
+
+ rebuilduserdir
fi
echo "Saved games will be stored in ${NWNUSERDIR}/saves/"
cd "${NWNUSERDIR}"
+# Remove old movie log file.
+rm -f ${NWNUSERDIR}/nwmovies.log
+
+# Prevent flickering at beginning and ending of playing a movie.
+export NWMOVIES_GRAB_HACK=1
+
# SDL settings
export SDL_MOUSE_RELATIVE=0
export SDL_VIDEO_X11_DGAMOUSE=0
+export SDL_AUDIODRIVER=${SDL_AUDIODRIVER:-"dsp"}
# Library locations
export LD_LIBRARY_PATH="${NWNUSERDIR}/lib:${NWNUSERDIR}/miles"
+# Prevent core files from NWN.
+ulimit -c 0
+
echo "Starting Neverwinter Nights..."
-exec ./nwmain
+if [ -e ./nwmovies/nwmovies.so ] ; then
+ export LD_PRELOAD=./nwmovies/nwmovies.so
+fi
+./nwmain "${@}"
diff --git a/games/linux-nwnclient/pkg-message b/games/linux-nwnclient/pkg-message
new file mode 100644
index 000000000000..4cea49c59cfd
--- /dev/null
+++ b/games/linux-nwnclient/pkg-message
@@ -0,0 +1,21 @@
+======================================================================
+
+If the game is installed with movie support (NWMovies), there is a way
+to skip various movies, especially the five introduction movies at the
+start of the game: create a skip file ($HOME/.nwn/nwmovies.skip) and
+list the movies (case-insensitive) you wish to skip. The following
+are the introduction movies, at least in the Diamond edition:
+AtariLogo
+BiowareLogo
+WotcLogo
+fge_logo_black
+NWNIntro
+
+There is a known issue due to the use of NWMovies. As written in
+the NWMovies README file:
+
+ The main menu music does not work after starting NWN w/ NWMovies.
+ Entering the game, and backing out to the main menu, the music
+ works. Known issue, no known cause, nor resolution.
+
+======================================================================
diff --git a/games/linux-nwnclient/pkg-plist b/games/linux-nwnclient/pkg-plist
index 27e3117985be..77d2b9abf766 100644
--- a/games/linux-nwnclient/pkg-plist
+++ b/games/linux-nwnclient/pkg-plist
@@ -1,22 +1,49 @@
bin/nwn
-%%DATADIR%%/EULA.txt
-%%DATADIR%%/NWNv%%NWNVERSION%%.txt
-%%DATADIR%%/data/patch.bif
+%%ORIGINAL%%%%DATADIR%%/EULA.txt
+%%DATADIR%%/NWNv169.txt
+%%DIAMOND%%%%DATADIR%%/ambient/al_fanfare_horn.wav
+%%DIAMOND%%%%DATADIR%%/ambient/al_fanfare_trump.wav
+%%DIAMOND%%%%DATADIR%%/ambient/al_na_seawaves.wav
+%%DIAMOND%%%%DATADIR%%/ambient/al_na_seawaves2.wav
+%%DIAMOND%%%%DATADIR%%/ambient/al_wt_windcrows.wav
+%%DIAMOND%%%%DATADIR%%/ambient/al_wt_windcrows2.wav
+%%DIAMOND%%%%DATADIR%%/ambient/al_wt_windowls.wav
+%%DIAMOND%%%%DATADIR%%/ambient/al_wt_windowls2.wav
+%%ORIGINAL%%%%DATADIR%%/data/patch.bif
+%%DIAMOND%%%%DATADIR%%/data/xp2patch.bif
+%%DIAMOND%%%%DATADIR%%/data/xp3.bif
%%DATADIR%%/dialog.tlk
%%DATADIR%%/dmclient
-%%DATADIR%%/lib/libstdc++-libc6.1-2.so.3
+%%ORIGINAL%%%%DATADIR%%/lib/libstdc++-libc6.1-2.so.3
%%DATADIR%%/miles/libmss.so
%%DATADIR%%/miles/libmss.so.6
%%DATADIR%%/miles/libmss.so.6.5.2
%%DATADIR%%/miles/mssdsp.flt
%%DATADIR%%/miles/mssmp3.asi
%%DATADIR%%/miles/msssoft.m3d
+%%DIAMOND%%%%DATADIR%%/movies-HotU.txt
%%DATADIR%%/movies-OC.txt
+%%DIAMOND%%%%DATADIR%%/movies-SoU.txt
+%%DIAMOND%%%%DATADIR%%/music/mus_bat_wcbattle.bmu
+%%DIAMOND%%%%DATADIR%%/music/mus_bat_wcchase.bmu
+%%DIAMOND%%%%DATADIR%%/music/mus_dd_infdun.bmu
%%DATADIR%%/music/mus_dd_islands.bmu
%%DATADIR%%/music/mus_dd_kingmaker.bmu
%%DATADIR%%/music/mus_dd_pirates.bmu
%%DATADIR%%/music/mus_dd_shadowgua.bmu
%%DATADIR%%/music/mus_dd_witchwake.bmu
+%%DIAMOND%%%%DATADIR%%/music/mus_wc_armchair.bmu
+%%DIAMOND%%%%DATADIR%%/music/mus_wc_knighted.bmu
+%%DIAMOND%%%%DATADIR%%/music/mus_wc_morfen.bmu
+%%DIAMOND%%%%DATADIR%%/music/mus_wc_ogma.bmu
+%%DIAMOND%%%%DATADIR%%/music/mus_wc_opening.bmu
+%%DIAMOND%%%%DATADIR%%/music/mus_wc_openroad.bmu
+%%DIAMOND%%%%DATADIR%%/music/mus_wc_rural.bmu
+%%DIAMOND%%%%DATADIR%%/music/mus_wc_ruralg.bmu
+%%DIAMOND%%%%DATADIR%%/music/mus_wc_smokeash.bmu
+%%DIAMOND%%%%DATADIR%%/music/mus_wc_solace.bmu
+%%DIAMOND%%%%DATADIR%%/music/mus_wc_tears.bmu
+%%DIAMOND%%%%DATADIR%%/music/mus_wc_theme.bmu
%%DATADIR%%/nwm/Chapter1.nwm
%%DATADIR%%/nwm/Chapter1E.nwm
%%DATADIR%%/nwm/Chapter2.nwm
@@ -24,23 +51,53 @@ bin/nwn
%%DATADIR%%/nwm/Chapter3.nwm
%%DATADIR%%/nwm/Chapter4.nwm
%%DATADIR%%/nwm/Prelude.nwm
+%%DIAMOND%%%%DATADIR%%/nwm/XP1-Chapter 1.nwm
+%%DIAMOND%%%%DATADIR%%/nwm/XP1-Chapter 2.nwm
+%%DIAMOND%%%%DATADIR%%/nwm/XP1-Interlude.nwm
+%%DIAMOND%%%%DATADIR%%/nwm/XP2_Chapter1.nwm
+%%DIAMOND%%%%DATADIR%%/nwm/XP2_Chapter2.nwm
+%%DIAMOND%%%%DATADIR%%/nwm/XP2_Chapter3.nwm
%%DATADIR%%/nwmain
+%%NWMOVIES%%%%DATADIR%%/nwmovies.pl
+%%NWMOVIES%%%%DATADIR%%/nwmovies/BinkPlayer
+%%NWMOVIES%%%%DATADIR%%/nwmovies/binklib.so
+%%NWMOVIES%%%%DATADIR%%/nwmovies/libX11.so
+%%NWMOVIES%%%%DATADIR%%/nwmovies/libdis/libdisasm.so
+%%NWMOVIES%%%%DATADIR%%/nwmovies/nwmovies.so
%%DATADIR%%/nwn.ini
+%%DIAMOND%%%%DATADIR%%/nwncdkey.ini
%%DATADIR%%/nwserver
-%%DATADIR%%/override/._iit_medkit_001.tga
-%%DATADIR%%/override/iit_medkit_001.tga
+%%ORIGINAL%%%%DATADIR%%/override/._iit_medkit_001.tga
+%%ORIGINAL%%%%DATADIR%%/override/iit_medkit_001.tga
+%%DIAMOND%%%%DATADIR%%/override/iit_midmisc_029.tga
%%DATADIR%%/override/load_legal.tga
%%DATADIR%%/override/load_legal2.tga
+%%DIAMOND%%%%DATADIR%%/override/ls_car_01.dds
+%%DIAMOND%%%%DATADIR%%/override/ls_car_01.tga
+%%DIAMOND%%%%DATADIR%%/override/ls_car_01s.dds
+%%DIAMOND%%%%DATADIR%%/override/ls_car_01s.tga
+%%DIAMOND%%%%DATADIR%%/override/ls_car_03.dds
+%%DIAMOND%%%%DATADIR%%/override/ls_car_03.tga
+%%DIAMOND%%%%DATADIR%%/override/ls_car_03s.dds
+%%DIAMOND%%%%DATADIR%%/override/ls_car_03s.tga
%%DATADIR%%/override/soundprovider.2da
-%%DATADIR%%/patch.key
+%%ORIGINAL%%%%DATADIR%%/patch.key
+%%DIAMOND%%%%DATADIR%%/readme-GOLD.txt
%%DATADIR%%/readme-SDL.txt
%%DATADIR%%/readme.linuxclientupdate.txt
%%DATADIR%%/readme.linuxserver.txt
%%DATADIR%%/readme.txt
+%%DIAMOND%%%%DATADIR%%/texturepacks/xp2_tex_tpa.erf
+%%DIAMOND%%%%DATADIR%%/xp2patch.key
+%%DIAMOND%%%%DATADIR%%/xp3.key
+%%DIAMOND%%@dirrm %%DATADIR%%/texturepacks
@dirrm %%DATADIR%%/override
+%%NWMOVIES%%@dirrm %%DATADIR%%/nwmovies/libdis
+%%NWMOVIES%%@dirrm %%DATADIR%%/nwmovies
@dirrm %%DATADIR%%/nwm
@dirrm %%DATADIR%%/music
@dirrm %%DATADIR%%/miles
@dirrm %%DATADIR%%/lib
@dirrm %%DATADIR%%/data
+%%DIAMOND%%@dirrm %%DATADIR%%/ambient
@dirrm %%DATADIR%%