aboutsummaryrefslogtreecommitdiff
path: root/games/linwarrior/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-12-31 21:00:08 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-12-31 21:00:08 +0000
commit0150d18de9657c78477ccb7095749c75e277bebf (patch)
treef7ec4acd0604d8e96fe488803dbb9232df1c04a8 /games/linwarrior/Makefile
parentf51c6c6181d690bf4a5ca7e5438958427240bf4e (diff)
downloadports-0150d18de9657c78477ccb7095749c75e277bebf.tar.gz
ports-0150d18de9657c78477ccb7095749c75e277bebf.zip
LinWarrior 3D targets to be a somewhat classical open source
Mech-Sim/Game. LinWarrior 3D is not exclusively bound to any specific classic title. Feel-of-control should *not* be FPS-like but may still be arcade-like and surrealistic. Classical means that the primary target of development is single player campaigns and not realistic graphics or physics. WWW: http://www.hackcraft.de/games/linwarrior_3d/index.htm --- PS. First commit'2009 (TZ=MSK). Happy new year!
Notes
Notes: svn path=/head/; revision=225071
Diffstat (limited to 'games/linwarrior/Makefile')
-rw-r--r--games/linwarrior/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/games/linwarrior/Makefile b/games/linwarrior/Makefile
new file mode 100644
index 000000000000..b45bbc40b31c
--- /dev/null
+++ b/games/linwarrior/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: linwarrior
+# Date created: 31 Dec 2008
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= linwarrior
+PORTVERSION= 20081224
+CATEGORIES= games
+MASTER_SITES= http://www.hackcraft.de/games/linwarrior_3d/downloads/ \
+ http://mirror.amdmi3.ru/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Navigate a mech through a 3D world and fire at enemies
+
+USE_SDL= sdl mixer
+USE_GL= gl glu
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PLIST_FILES= bin/linwarrior
+
+SRCS= cBackground cBuilding cController cMech cMission cObject \
+ cTree cWeapon cWorld main
+
+do-build:
+.for s in ${SRCS}
+ cd ${WRKSRC}/source && ${CXX} ${CXXFLAGS} `${SDL_CONFIG} --cflags` \
+ -I.. -I../psi3d -c ${s}.cpp -o ${s}.o
+.endfor
+ cd ${WRKSRC}/source && ${CXX} `${SDL_CONFIG} --libs` -lGL -lGLU \
+ ${SRCS:C/$/.o/} -o ${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/source/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>