aboutsummaryrefslogtreecommitdiff
path: root/games/linwarrior/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-06-22 21:29:21 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-06-22 21:29:21 +0000
commit3c8db3afa097f6324226443319d3877bce041f84 (patch)
tree94cc15c32b2d63b73c1a8e1c4b88f13ab4fee713 /games/linwarrior/Makefile
parent78fc2389396571897986cf811b109565ee8ef221 (diff)
downloadports-3c8db3afa097f6324226443319d3877bce041f84.tar.gz
ports-3c8db3afa097f6324226443319d3877bce041f84.zip
- Fix build with clang 6
- Pet portlint - Regenerate patches
Notes
Notes: svn path=/head/; revision=473081
Diffstat (limited to 'games/linwarrior/Makefile')
-rw-r--r--games/linwarrior/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/games/linwarrior/Makefile b/games/linwarrior/Makefile
index 593480ba01f5..1369eb54720f 100644
--- a/games/linwarrior/Makefile
+++ b/games/linwarrior/Makefile
@@ -16,6 +16,8 @@ USES= gmake openal:al,alut
USE_GL= gl glu
USE_SDL= sdl
+CFLAGS+= -Wno-c++11-narrowing
+
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= bin/${PORTNAME}
@@ -29,8 +31,8 @@ DESKTOP_ENTRIES="LinWarrior 3D" \
false
post-extract:
- @${FIND} ${WRKSRC} -type d -exec chmod a+rx {} \;
- @${FIND} ${WRKSRC} -type f -exec chmod a+r {} \;
+ @${FIND} ${WRKSRC} -type d -exec ${CHMOD} a+rx {} \;
+ @${FIND} ${WRKSRC} -type f -exec ${CHMOD} a+r {} \;
post-patch:
@${REINPLACE_CMD} -e '/hash_set/ d' ${WRKSRC}/source/cAlert.h