aboutsummaryrefslogtreecommitdiff
path: root/games/linwarrior/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-09 00:36:56 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-09 00:36:56 +0000
commit6ea9720cd456353d7b78bf8db897ef3fe63c7213 (patch)
tree321d83b99957d85495a43fcf5728d0cafe2134c4 /games/linwarrior/Makefile
parenta5e7bdfe237e5d9c6908f1ee475f0e48fa8f5d15 (diff)
downloadports-6ea9720cd456353d7b78bf8db897ef3fe63c7213.tar.gz
ports-6ea9720cd456353d7b78bf8db897ef3fe63c7213.zip
- Update to 20090529
Notes
Notes: svn path=/head/; revision=235463
Diffstat (limited to 'games/linwarrior/Makefile')
-rw-r--r--games/linwarrior/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/games/linwarrior/Makefile b/games/linwarrior/Makefile
index baa8a5bb14e9..4e5cbf2a0697 100644
--- a/games/linwarrior/Makefile
+++ b/games/linwarrior/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= linwarrior
-PORTVERSION= 20090208
-PORTREVISION= 1
+PORTVERSION= 20090529
CATEGORIES= games
MASTER_SITES= http://www.hackcraft.de/games/linwarrior_3d/downloads/ \
http://mirror.amdmi3.ru/
@@ -22,9 +21,17 @@ LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
USE_GMAKE= yes
USE_GL= gl glu
USE_SDL= sdl
+MAKE_JOBS_SAFE= yes
+USE_GCC= 4.2+
WRKSRC= ${WRKDIR}/${PORTNAME}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800007
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-source-cMech.cpp
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|data/|${DATADIR}/|' ${WRKSRC}/source/cMech.cpp \
${WRKSRC}/source/cWeapon.cpp ${WRKSRC}/source/main.cpp
@@ -34,4 +41,4 @@ do-install:
${MKDIR} ${DATADIR}/sound
${INSTALL_DATA} ${WRKSRC}/data/sound/*.wav ${DATADIR}/sound
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>