aboutsummaryrefslogtreecommitdiff
path: root/games/linwarrior/Makefile
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-12-07 10:12:21 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-12-07 10:12:21 +0000
commit7dfdaf260b90d9c69e942558acb8ec1d77478a3b (patch)
tree9b196b448066a568ae75909b4e59104daae1e903 /games/linwarrior/Makefile
parentd0ed9d62f47fbeff3752305512418dbd27ddfc67 (diff)
downloadports-7dfdaf260b90d9c69e942558acb8ec1d77478a3b.tar.gz
ports-7dfdaf260b90d9c69e942558acb8ec1d77478a3b.zip
games/linwarrior: fix build on GCC architectures
OpenAL now needs C++11 compiler: /usr/local/lib/libopenal.so: undefined reference to `std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >::resize(unsigned long, char)@GLIBCXX_3.4.21'
Notes
Notes: svn path=/head/; revision=519193
Diffstat (limited to 'games/linwarrior/Makefile')
-rw-r--r--games/linwarrior/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/linwarrior/Makefile b/games/linwarrior/Makefile
index fc0585d7b5b0..e8c2ebf08093 100644
--- a/games/linwarrior/Makefile
+++ b/games/linwarrior/Makefile
@@ -12,7 +12,7 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Navigate a mech through a 3D world and fire at enemies
-USES= gl gmake openal:al,alut sdl
+USES= compiler:c++11-lang gl gmake openal:al,alut sdl
USE_GL= gl glu
USE_SDL= sdl
LLD_UNSAFE= yes