aboutsummaryrefslogtreecommitdiff
path: root/games/lpairs/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-23 11:54:19 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-23 11:54:19 +0000
commit5ef1cdeb43ef25f07f484834b3e67ef5a35b2eff (patch)
tree54156e9d1a7d343b19ccfa4aba40c184927711f7 /games/lpairs/Makefile
parente263788cf05eea93cdfbfa82470f193e2a3d76b7 (diff)
downloadports-5ef1cdeb43ef25f07f484834b3e67ef5a35b2eff.tar.gz
ports-5ef1cdeb43ef25f07f484834b3e67ef5a35b2eff.zip
LPairs is a classical memory game. This means you have to find pairs
of identical cards which will then be removed. Your time and tries needed will be counted but there is no highscore chart or limit to this. WWW: http://lgames.sourceforge.net/index.php?project=LPairs
Notes
Notes: svn path=/head/; revision=220538
Diffstat (limited to 'games/lpairs/Makefile')
-rw-r--r--games/lpairs/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/games/lpairs/Makefile b/games/lpairs/Makefile
new file mode 100644
index 000000000000..f656d78439f2
--- /dev/null
+++ b/games/lpairs/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: lpairs
+# Date created: 12 Sep 2008
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lpairs
+PORTVERSION= 1.0.4
+CATEGORIES= games
+MASTER_SITES= SF/lgames
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Classical memory game
+
+GNU_CONFIGURE= yes
+USE_SDL= sdl
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
+
+.if !defined(WITHOUT_NLS)
+PLIST_SUB+= NLS=""
+USE_GETTEXT= yes
+CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^LIBS =/ s|$$| $${INTLLIBS}|' \
+ ${WRKSRC}/lpairs/Makefile.in
+ @${REINPLACE_CMD} -e 's|^\(inst_dir=\).*|\1$$datarootdir/lpairs|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>