aboutsummaryrefslogtreecommitdiff
path: root/games/madbomber
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2013-03-14 23:14:38 +0000
committerBeech Rintoul <beech@FreeBSD.org>2013-03-14 23:14:38 +0000
commit07d2feffc8e45bbb0557df1fb216abd848befd25 (patch)
tree9a4ff7b3e64fdc13fc51ad9ce1e1344019eebbb2 /games/madbomber
parent28ee7de003e4b4e112de7669dea76e2cd679e200 (diff)
downloadports-07d2feffc8e45bbb0557df1fb216abd848befd25.tar.gz
ports-07d2feffc8e45bbb0557df1fb216abd848befd25.zip
- Add Desktop entries
- Add icons - Add pkg-plist - Bump portrevision PR: ports/173431 Submitted by: nemysis <nemysis@gmx.ch> (maintainer)
Notes
Notes: svn path=/head/; revision=314191
Diffstat (limited to 'games/madbomber')
-rw-r--r--games/madbomber/Makefile28
-rw-r--r--games/madbomber/pkg-plist141
2 files changed, 150 insertions, 19 deletions
diff --git a/games/madbomber/Makefile b/games/madbomber/Makefile
index 5b03abf91d84..c2d7d553fd1e 100644
--- a/games/madbomber/Makefile
+++ b/games/madbomber/Makefile
@@ -1,19 +1,15 @@
-# New ports collection makefile for: madbomber
-# Date created: 28 September 2000
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
+# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= madbomber
PORTVERSION= 0.2.5
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= games
MASTER_SITES= ftp://ftp.tuxpaint.org/unix/x/madbomber/src/ \
ftp://ftp.billsgames.com/unix/x/madbomber/src/
MAINTAINER= nemysis@gmx.ch
-COMMENT= A clone of Activision's classic Atari 2600 console game "Kaboom!"
+COMMENT= Clone of Activision's classic Atari 2600 console game "Kaboom!"
LICENSE= GPLv2
@@ -22,12 +18,12 @@ USE_SDL= mixer image sdl
CPPFLAGS+= `${SDL_CONFIG} --cflags` -DDATA_PREFIX=\"${DATADIR}/\"
LDFLAGS+= `${SDL_CONFIG} --libs`
-PLIST_FILES= bin/${PORTNAME} \
- share/pixmaps/${PORTNAME}.png
-
-PORTDATA= *
PORTDOCS= AUTHORS.txt CHANGES.txt README.txt TODO.txt
+DESKTOP_ENTRIES="Mad Bomber" "${COMMENT}" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" false
+
.include <bsd.port.options.mk>
do-build:
@@ -35,24 +31,18 @@ do-build:
${PORTNAME}.c ${LDFLAGS} -lSDL_mixer -lSDL_image
do-install:
-# Executable
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
-# Data
${MKDIR} ${DATADIR}
.for d in images music sounds
@(cd ${WRKSRC}/data && ${COPYTREE_SHARE} ${d} ${DATADIR})
.endfor
-# Pixmaps
${INSTALL_DATA} ${WRKSRC}/data/images/icon.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
-# Documentation
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
-. for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-. endfor
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/games/madbomber/pkg-plist b/games/madbomber/pkg-plist
new file mode 100644
index 000000000000..6ede19eebba8
--- /dev/null
+++ b/games/madbomber/pkg-plist
@@ -0,0 +1,141 @@
+bin/madbomber
+%%DATADIR%%/images/bar.png
+%%DATADIR%%/images/game/background.png
+%%DATADIR%%/images/game/bomb/bomb0.png
+%%DATADIR%%/images/game/bomb/bomb1.png
+%%DATADIR%%/images/game/bomb/bomb2.png
+%%DATADIR%%/images/game/bomb/bomb3.png
+%%DATADIR%%/images/game/bomb/explosion1.png
+%%DATADIR%%/images/game/bomb/explosion2.png
+%%DATADIR%%/images/game/bomber/bomber-amazed.png
+%%DATADIR%%/images/game/bomber/bomber-happy.png
+%%DATADIR%%/images/game/bomber/bomber-sad.png
+%%DATADIR%%/images/game/bucket/bucket1.png
+%%DATADIR%%/images/game/bucket/bucket1red.png
+%%DATADIR%%/images/game/bucket/bucket2.png
+%%DATADIR%%/images/game/bucket/bucket2red.png
+%%DATADIR%%/images/game/bucket/bucket3.png
+%%DATADIR%%/images/game/bucket/bucket3red.png
+%%DATADIR%%/images/game/bucket/small-bucket1.png
+%%DATADIR%%/images/game/bucket/small-bucket1red.png
+%%DATADIR%%/images/game/bucket/small-bucket2.png
+%%DATADIR%%/images/game/bucket/small-bucket2red.png
+%%DATADIR%%/images/game/bucket/small-bucket3.png
+%%DATADIR%%/images/game/bucket/small-bucket3red.png
+%%DATADIR%%/images/game/drop/drop-down.png
+%%DATADIR%%/images/game/drop/drop-left-down.png
+%%DATADIR%%/images/game/drop/drop-left-up.png
+%%DATADIR%%/images/game/drop/drop-left.png
+%%DATADIR%%/images/game/drop/drop-right-down.png
+%%DATADIR%%/images/game/drop/drop-right-up.png
+%%DATADIR%%/images/game/drop/drop-right.png
+%%DATADIR%%/images/game/drop/drop-up.png
+%%DATADIR%%/images/game/game-over.png
+%%DATADIR%%/images/game/highscore.png
+%%DATADIR%%/images/game/numbers/0.png
+%%DATADIR%%/images/game/numbers/0red.png
+%%DATADIR%%/images/game/numbers/1.png
+%%DATADIR%%/images/game/numbers/1red.png
+%%DATADIR%%/images/game/numbers/2.png
+%%DATADIR%%/images/game/numbers/2red.png
+%%DATADIR%%/images/game/numbers/3.png
+%%DATADIR%%/images/game/numbers/3red.png
+%%DATADIR%%/images/game/numbers/4.png
+%%DATADIR%%/images/game/numbers/4red.png
+%%DATADIR%%/images/game/numbers/5.png
+%%DATADIR%%/images/game/numbers/5red.png
+%%DATADIR%%/images/game/numbers/6.png
+%%DATADIR%%/images/game/numbers/6red.png
+%%DATADIR%%/images/game/numbers/7.png
+%%DATADIR%%/images/game/numbers/7red.png
+%%DATADIR%%/images/game/numbers/8.png
+%%DATADIR%%/images/game/numbers/8red.png
+%%DATADIR%%/images/game/numbers/9.png
+%%DATADIR%%/images/game/numbers/9red.png
+%%DATADIR%%/images/game/paused.png
+%%DATADIR%%/images/game/press-escape.png
+%%DATADIR%%/images/game/press-fire.png
+%%DATADIR%%/images/highscore/highscore.png
+%%DATADIR%%/images/highscore/letters.png
+%%DATADIR%%/images/icon.png
+%%DATADIR%%/images/loading.png
+%%DATADIR%%/images/make-offs.sh
+%%DATADIR%%/images/options/0percent-off.png
+%%DATADIR%%/images/options/0percent.png
+%%DATADIR%%/images/options/100percent-off.png
+%%DATADIR%%/images/options/100percent.png
+%%DATADIR%%/images/options/25percent-off.png
+%%DATADIR%%/images/options/25percent.png
+%%DATADIR%%/images/options/50percent-off.png
+%%DATADIR%%/images/options/50percent.png
+%%DATADIR%%/images/options/75percent-off.png
+%%DATADIR%%/images/options/75percent.png
+%%DATADIR%%/images/options/detail.png
+%%DATADIR%%/images/options/difficulty.png
+%%DATADIR%%/images/options/effects.png
+%%DATADIR%%/images/options/hard-off.png
+%%DATADIR%%/images/options/hard.png
+%%DATADIR%%/images/options/music.png
+%%DATADIR%%/images/options/normal-off.png
+%%DATADIR%%/images/options/normal.png
+%%DATADIR%%/images/options/ok-off.png
+%%DATADIR%%/images/options/ok.png
+%%DATADIR%%/images/options/options.png
+%%DATADIR%%/images/options/player-one.png
+%%DATADIR%%/images/options/player-two.png
+%%DATADIR%%/images/options/volume.png
+%%DATADIR%%/images/options/zen-off.png
+%%DATADIR%%/images/options/zen.png
+%%DATADIR%%/images/spray-black.png
+%%DATADIR%%/images/spray-blue.png
+%%DATADIR%%/images/spray-cyan.png
+%%DATADIR%%/images/title/exit-off.png
+%%DATADIR%%/images/title/exit.png
+%%DATADIR%%/images/title/highscore-off.png
+%%DATADIR%%/images/title/highscore.png
+%%DATADIR%%/images/title/one-player-off.png
+%%DATADIR%%/images/title/one-player.png
+%%DATADIR%%/images/title/options-off.png
+%%DATADIR%%/images/title/options.png
+%%DATADIR%%/images/title/title.png
+%%DATADIR%%/images/title/two-player-vs-off.png
+%%DATADIR%%/images/title/two-player-vs.png
+%%DATADIR%%/images/title/two-players-off.png
+%%DATADIR%%/images/title/two-players.png
+%%DATADIR%%/music/astraltr.mod
+%%DATADIR%%/music/bizjung.it
+%%DATADIR%%/music/fdn-arab.s3m
+%%DATADIR%%/music/gluppobe.mod
+%%DATADIR%%/music/waterfal.mod
+%%DATADIR%%/sounds/bigexplosion.wav
+%%DATADIR%%/sounds/can-shake.wav
+%%DATADIR%%/sounds/confirm.wav
+%%DATADIR%%/sounds/explosion.wav
+%%DATADIR%%/sounds/fuse.wav
+%%DATADIR%%/sounds/highscore.wav
+%%DATADIR%%/sounds/level8.wav
+%%DATADIR%%/sounds/oneup.wav
+%%DATADIR%%/sounds/select.wav
+%%DATADIR%%/sounds/splash1.wav
+%%DATADIR%%/sounds/splash2.wav
+%%DATADIR%%/sounds/splash3.wav
+%%DATADIR%%/sounds/splash4.wav
+%%DATADIR%%/sounds/splash5.wav
+%%DATADIR%%/sounds/splash6.wav
+%%DATADIR%%/sounds/splash7.wav
+%%DATADIR%%/sounds/splash8.wav
+%%DATADIR%%/sounds/spray.wav
+share/pixmaps/madbomber.png
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/images/title
+@dirrm %%DATADIR%%/images/options
+@dirrm %%DATADIR%%/images/highscore
+@dirrm %%DATADIR%%/images/game/numbers
+@dirrm %%DATADIR%%/images/game/drop
+@dirrm %%DATADIR%%/images/game/bucket
+@dirrm %%DATADIR%%/images/game/bomber
+@dirrm %%DATADIR%%/images/game/bomb
+@dirrm %%DATADIR%%/images/game
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%