aboutsummaryrefslogtreecommitdiff
path: root/games/mangband/Makefile
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>1999-01-01 03:14:08 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>1999-01-01 03:14:08 +0000
commit358320d4efa3f0d5ffdc1fe9ed4fe286514d5482 (patch)
treeb69bd306a5a7908da575dc57b4b62528001440da /games/mangband/Makefile
parent6b1a37e21e27e034154d0080b7306e58396ed5e1 (diff)
downloadports-358320d4efa3f0d5ffdc1fe9ed4fe286514d5482.tar.gz
ports-358320d4efa3f0d5ffdc1fe9ed4fe286514d5482.zip
multi-player Angband
Notes
Notes: svn path=/head/; revision=15746
Diffstat (limited to 'games/mangband/Makefile')
-rw-r--r--games/mangband/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/mangband/Makefile b/games/mangband/Makefile
new file mode 100644
index 000000000000..b8e918f1ef30
--- /dev/null
+++ b/games/mangband/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mangband
+# http://www.umr.edu/~keldon/MAngband/
+# Version required: 0.5.4
+# Date created: 30 Dec 1998
+#
+# $Id: Makefile,v 1.7 1998/08/05 09:30:52 asami Exp $
+#
+
+DISTNAME= mangband-054
+PKGNAME= mangband-0.5.4
+CATEGORIES= games
+MASTER_SITES= http://www.umr.edu/~keldon/MAngband/
+
+WRKSRC= ${WRKDIR}/mangband/src
+ALL_TARGET= install
+
+USE_XLIB= yes
+
+MAINTAINER= ache@freebsd.org
+
+MALIB= ${PREFIX}/lib/mangband
+
+do-install:
+ ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 555 ${MALIB}
+ cd ${WRKSRC}/../lib; cp -R -p * ${MALIB}; \
+ cd ${MALIB}; \
+ touch file/wizards.txt; \
+ chmod 750 *; chown -R games.games *; \
+ chmod 755 user;
+ cd ${WRKSRC}; \
+ ${INSTALL_PROGRAM} -o games -g games -m 4550 \
+ mangband ${PREFIX}/bin; \
+ ${INSTALL_PROGRAM} -o games -g games -m 550 \
+ mangconsole ${PREFIX}/bin; \
+ ${INSTALL_PROGRAM} mangclient ${PREFIX}/bin
+
+.include <bsd.port.mk>