aboutsummaryrefslogtreecommitdiff
path: root/games/mangband/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 15:34:17 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 15:34:17 +0000
commit9f1de9b900c064307cc328ec436f07477dfaa7f0 (patch)
tree5b19e4fae39149280653cc670bc170d039477f8e /games/mangband/Makefile
parent296877462b8b100e9f83f9c6aa6ed4bff34c6def (diff)
downloadports-9f1de9b900c064307cc328ec436f07477dfaa7f0.tar.gz
ports-9f1de9b900c064307cc328ec436f07477dfaa7f0.zip
Convert USE_NCURSES by USES=ncurses
Convert USE_READLINE by USES=readline
Notes
Notes: svn path=/head/; revision=317525
Diffstat (limited to 'games/mangband/Makefile')
-rw-r--r--games/mangband/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/games/mangband/Makefile b/games/mangband/Makefile
index e43ac7ea8e78..e1b2782e31eb 100644
--- a/games/mangband/Makefile
+++ b/games/mangband/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mangband
-# Date created: Thu Jun 11 11:40:54 UTC 2009
-# Whom: driedfruit
-#
+# Created by: driedfruit
# $FreeBSD$
-#
PORTNAME= mangband
PORTVERSION= 1.1.2
@@ -16,31 +12,34 @@ COMMENT= Free online multiplayer real-time roguelike game
ALL_TARGET= mangclient mangband
WRKSRC= ${WRKDIR}/${DISTNAME}/src
GNU_CONFIGURE= yes
+USES= ncurses
USE_GMAKE= yes
USE_NCURSES= yes
MAKE_ARGS= "DATADIR=${DATADIR}"
-OPTIONS= GCU "Display module GCU" On \
- X11 "Display module X11" Off \
- SDL "Display module SDL" Off \
+OPTIONS_DEFINE= GCU X11 SDL
+OPTIONS_DEFAULT= GCU X11 SDL
+GCU_DESC= Display module GCU
+X11_DESC= Display module X11
+SDL_DESC= Display module SDL
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_GCU)
+.if ${PORT_OPTIONS:MGCU}
CONFIGURE_ARGS+= --with-gcu
.else
CONFIGURE_ARGS+= --without-gcu
.endif
-.if defined(WITH_X11)
+.if ${PORT_OPTIONS:MX11}
LIB_DEPENDS+= X11.6:${PORTSDIR}/x11/libX11
CONFIGURE_ARGS+= --with-x11
.else
CONFIGURE_ARGS+= --without-x11
.endif
-.if defined(WITH_SDL)
+.if ${PORT_OPTIONS:MSDL}
LIB_DEPENDS+= SDL-1.2:${PORTSDIR}/devel/sdl12
CONFIGURE_ARGS+= --with-sdl
.else
@@ -70,4 +69,4 @@ do-install:
@${CHOWN} -R root:games ${DATADIR}/*
@${CHOWN} ${SHAREOWN}:${SHAREGRP} ${DATADIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>