aboutsummaryrefslogtreecommitdiff
path: root/games/megaglest/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-04-12 08:32:01 +0000
committerJohn Marino <marino@FreeBSD.org>2015-04-12 08:32:01 +0000
commit33e3be5231074adca69fd58e79fe486031edb74a (patch)
tree10a016b43fbc2111bd894ce082a39f42b3f54d90 /games/megaglest/Makefile
parentbb1b699cc3666521826ca6e9308a98512f5b2462 (diff)
downloadports-33e3be5231074adca69fd58e79fe486031edb74a.tar.gz
ports-33e3be5231074adca69fd58e79fe486031edb74a.zip
games/megaglest: Unbreak on F10+ with an unsavory solution
Megaglest cannot be built under c++11 standard from the latest clang. It catches a narrowing error. The real solution is to fix the c++ code (it wasn't the only problem, but the first to trigger an error over a warning). The c++11 standard is required for wx, so it can't be unspecified. It turns out that gcc48 will not catch the error that clang does so the temporary fix is to require gcc48 for all FreeBSD releases. This may work for gcc49 as well, but it's likely that gcc5 will also catch the bug and break. So the unsavory short-term solution is to require GCC to build megaglest, but the long term fix is either patch the code or hopefully update to new version when upstream fixes the bug (then USE_GCC can be removed). Reported by: amdmi3
Notes
Notes: svn path=/head/; revision=383843
Diffstat (limited to 'games/megaglest/Makefile')
-rw-r--r--games/megaglest/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index 8b3a654d65f8..065867b00f63 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -3,7 +3,7 @@
PORTNAME= megaglest
PORTVERSION= 3.9.0.4
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}_3.9.0/
DISTNAME= ${PORTNAME}-source-${PORTVERSION}
@@ -23,7 +23,11 @@ RUN_DEPENDS= ${DATADIR}/tutorials/2_basic_tutorial/2_basic_tutorial.xml:${PORTSD
SUB_FILES= pkg-message
-USES= cmake compiler:c++11-lib display:build dos2unix lua openal:al,alut pkgconfig tar:xz
+# Clang catches a c++11 violation that older GCC misses, so until the
+# code is fixed, remove USES+=compiler:c++11-lib and set USE_GCC=yes
+USES= cmake display:build dos2unix lua openal:al,alut pkgconfig \
+ tar:xz
+USE_GCC= yes
USE_GL= glew gl glu
USE_SDL= yes
USE_WX= 3.0