aboutsummaryrefslogtreecommitdiff
path: root/games/megamario
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-11-10 20:17:54 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-11-10 20:17:54 +0000
commit1750314688f3fbb5fb781d1a10ace38388696a39 (patch)
tree32e1e14cf5dcfd6fba7cf2353f1fccfae30058c7 /games/megamario
parent4b927f8a7e4a43b0dd1a084ed477ef991c366bc5 (diff)
downloadports-1750314688f3fbb5fb781d1a10ace38388696a39.tar.gz
ports-1750314688f3fbb5fb781d1a10ace38388696a39.zip
- Bump PORTREVISION for pkg-plist change
- Change DOCS, add help and screens, remove from DATADIR
Notes
Notes: svn path=/head/; revision=372411
Diffstat (limited to 'games/megamario')
-rw-r--r--games/megamario/Makefile28
-rw-r--r--games/megamario/pkg-plist9
2 files changed, 22 insertions, 15 deletions
diff --git a/games/megamario/Makefile b/games/megamario/Makefile
index c8659de31c6b..b9c1fc096e2e 100644
--- a/games/megamario/Makefile
+++ b/games/megamario/Makefile
@@ -3,7 +3,7 @@
PORTNAME= megamario
PORTVERSION= 1.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/mmario/Mega%20Mario%20Full%20Game/Mega%20Mario%20v${PORTVERSION}%20%28Full%20Game%2C%20high%20Quality%20music%29/
DISTNAME= MegaMario_v${PORTVERSION}_full
@@ -26,7 +26,19 @@ ALL_TARGET= ${PORTNAME}
pre-extract:
@${MKDIR} ${WRKDIR}/${DISTNAME}
-PORTDOCS= CONTROLS.txt fixes_v1.7.txt readme.txt
+PORTDOCS= *
+
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= CONTROLS.txt fixes_v1.7.txt readme.txt
+
+DOCSRCDIR2= ${WRKSRC}/help
+DOCSDIR2= ${DOCSDIR}/help
+DOC_FILES2= *
+
+DOCSRCDIR3= ${WRKSRC}/screens
+DOCSDIR3= ${DOCSDIR}/screens
+DOC_FILES3= *
+
OPTIONS_DEFINE= DOCS
post-patch:
@@ -41,14 +53,18 @@ post-patch:
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-.for d in help mp3music screens
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${DATADIR})
-.endfor
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} mp3music ${STAGEDIR}${DATADIR})
+
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
+
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR3}
+ ${INSTALL_DATA} ${DOC_FILES3:S|^|${DOCSRCDIR3}/|} ${STAGEDIR}${DOCSDIR3}
.include <bsd.port.mk>
diff --git a/games/megamario/pkg-plist b/games/megamario/pkg-plist
index 5d2159bbf55f..7c5bf6ed96f0 100644
--- a/games/megamario/pkg-plist
+++ b/games/megamario/pkg-plist
@@ -236,9 +236,6 @@ share/applications/megamario.desktop
%%DATADIR%%/gfx/tiles/pipes/up/3.png
%%DATADIR%%/gfx/tiles/pipes/up/4.png
%%DATADIR%%/gfx/tiles/smallcastle.png
-%%DATADIR%%/help/editor.doc
-%%DATADIR%%/help/editor_FAQ.png
-%%DATADIR%%/help/editor_Roehren.png
%%DATADIR%%/levels/1/1
%%DATADIR%%/levels/1/main
%%DATADIR%%/levels/1/text
@@ -321,12 +318,6 @@ share/applications/megamario.desktop
%%DATADIR%%/mp3music/orig.mp3
%%DATADIR%%/mp3music/star2.mp3
%%DATADIR%%/save.sav
-%%DATADIR%%/screens/1.png
-%%DATADIR%%/screens/2.png
-%%DATADIR%%/screens/3.png
-%%DATADIR%%/screens/4.png
-%%DATADIR%%/screens/5.png
-%%DATADIR%%/screens/6.gif
%%DATADIR%%/sfx/1-up.wav
%%DATADIR%%/sfx/bowserfall.wav
%%DATADIR%%/sfx/cannon.wav