aboutsummaryrefslogtreecommitdiff
path: root/games/mvdsv/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2006-07-05 13:00:35 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2006-07-05 13:00:35 +0000
commit230cf4127044da7495bf5713df4e95dcac80a4bb (patch)
treee0e5f7c9cd2cc3db00a686e14e7a028d44e80828 /games/mvdsv/Makefile
parent3406239dfa2188c5e8eec4c588b7170cadacc9e0 (diff)
downloadports-230cf4127044da7495bf5713df4e95dcac80a4bb.tar.gz
ports-230cf4127044da7495bf5713df4e95dcac80a4bb.zip
Update to version 0.20.
Notes
Notes: svn path=/head/; revision=166979
Diffstat (limited to 'games/mvdsv/Makefile')
-rw-r--r--games/mvdsv/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/games/mvdsv/Makefile b/games/mvdsv/Makefile
index eca575a760fe..1b69aa99bdc2 100644
--- a/games/mvdsv/Makefile
+++ b/games/mvdsv/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME?= mvdsv
-PORTVERSION= 0.19
+PORTVERSION= 0.20
PORTEPOCH= 2
CATEGORIES?= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
@@ -25,15 +25,23 @@ ALL_TARGET= ${PORTNAME}
PLIST_FILES= bin/${PORTNAME}
WRKSRC= ${WRKDIR}/mvdsv_${PORTVERSION}/source
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha" || ${ARCH} == "amd64" || ${ARCH} == "i386" || ${ARCH} == "ia64"
+MAKE_ARGS+= BYTE_ORDER=__LITTLE_ENDIAN__
+.else
+MAKE_ARGS+= BYTE_ORDER=__BIG_ENDIAN__
+.endif
+
pre-everything::
.if !defined(WITH_OPTIMIZED_CFLAGS)
@${ECHO_MSG} "Define WITH_OPTIMIZED_CFLAGS to enable extra optimization options"
.endif
-.if ${MACHINE_ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
+.if ${ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
@${ECHO_MSG} "Define WITHOUT_X86_ASM to disable x86 assembly code"
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/../${PORTNAME} ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>