aboutsummaryrefslogtreecommitdiff
path: root/games/mvdsv/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2004-04-29 11:13:35 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2004-04-29 11:13:35 +0000
commit9fc8656bd3cfb3762d0ba15ca6291939604765da (patch)
treee3ed8b95ea3c1d3d0158d05b502761f217714f90 /games/mvdsv/Makefile
parent6e6f0f5a01d424669f087ffe57e3bce805891c55 (diff)
downloadports-9fc8656bd3cfb3762d0ba15ca6291939604765da.tar.gz
ports-9fc8656bd3cfb3762d0ba15ca6291939604765da.zip
Long-awaited update of mvdsv from 0.1723b -> 0.1725b,
after discovery of new "official" development site of MVDSV project. Submitted by: Alexey Dokuchaev <danfe@regency.nsu.ru> (maintainer) PR: 65847
Notes
Notes: svn path=/head/; revision=107963
Diffstat (limited to 'games/mvdsv/Makefile')
-rw-r--r--games/mvdsv/Makefile30
1 files changed, 25 insertions, 5 deletions
diff --git a/games/mvdsv/Makefile b/games/mvdsv/Makefile
index 548fd3c165b0..738d7129f9dc 100644
--- a/games/mvdsv/Makefile
+++ b/games/mvdsv/Makefile
@@ -6,18 +6,38 @@
#
PORTNAME= mvdsv
-PORTVERSION= 0.1723b
+PORTVERSION= 0.1725b
CATEGORIES= games
-MASTER_SITES= http://www.wsb.poznan.pl/~pawel/q/q/ktpro/ \
+MASTER_SITES= http://quakeworld.ru/files/vvd/mvdsv/ \
http://freebsd.nsu.ru/distfiles/
-DISTNAME= ${PORTNAME}_${PORTVERSION}_source
+DISTNAME= ${PORTNAME}${PORTVERSION}-sources
MAINTAINER= danfe@regency.nsu.ru
COMMENT= Enhanced QuakeWorld server with multi-view demos capability
+USE_BZIP2= yes
+
+.include <bsd.port.pre.mk>
+
+.if defined(GCCVERSION)
+. if ${GCCVERSION} < 030000
+GCC_VER= 2
+. else
+GCC_VER= 3
+. endif
+.else
+. if ${OSVERSION} < 500035
+GCC_VER= 2
+. else
+GCC_VER= 3
+. endif
+.endif
+
MAKEFILE= ${FILESDIR}/Makefile
+MAKE_ARGS+= GCC_VER=${GCC_VER}
+
PLIST_FILES= bin/mvdsv
-WRKSRC= ${WRKDIR}/${DISTNAME}/source
+WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}/source
pre-everything::
.if !defined(WITH_OPTIMIZED_CFLAGS)
@@ -30,4 +50,4 @@ pre-everything::
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>