aboutsummaryrefslogtreecommitdiff
path: root/games/mvdsv/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-10-08 15:59:56 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-10-08 15:59:56 +0000
commita8793d3005403468acc3faca04a7559e7d637a70 (patch)
treef46ad5fb15b622277fc12afe265db06b0d665bad /games/mvdsv/Makefile
parent6b795da3dc5813adbcabf20a897aa305e0e7eb89 (diff)
downloadports-a8793d3005403468acc3faca04a7559e7d637a70.tar.gz
ports-a8793d3005403468acc3faca04a7559e7d637a70.zip
- Remove hardcoded "gcc" in configure script to unbreak on -CURRENT
- Stagify; drop no longer needed MAKE_ARGS and post-install target - Touch pkg-descr and slave port's COMMENT while I'm at them Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=329800
Diffstat (limited to 'games/mvdsv/Makefile')
-rw-r--r--games/mvdsv/Makefile13
1 files changed, 2 insertions, 11 deletions
diff --git a/games/mvdsv/Makefile b/games/mvdsv/Makefile
index 91699f815976..77a69da87180 100644
--- a/games/mvdsv/Makefile
+++ b/games/mvdsv/Makefile
@@ -17,7 +17,6 @@ USE_ZIP= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= ${OPSYS} ${ARCH:C/.*(64)/\1/}
-MAKE_ARGS= CC="${CC}"
ALL_TARGET= ${PORTNAME}
WRKSRC= ${WRKDIR}/mvdsv
@@ -35,7 +34,6 @@ OPTIONS_DEFAULT+= KQUEUE
KQUEUE_DESC= Kqueue support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ! ${PORT_OPTIONS:MKQUEUE}
@@ -47,17 +45,10 @@ MAKE_ARGS+= -DWITHOUT_X86_ASM
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's,gcc,${CC},' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's,^inline ,,' ${WRKSRC}/source/sv_sys_unix.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-
-post-install:
-# Checking for presence of ${PKGMESSAGE} explicitly does not work here
-.if exists(${.CURDIR}/pkg-message)
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>