aboutsummaryrefslogtreecommitdiff
path: root/games/mvdsv
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-17 14:55:28 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-17 14:55:28 +0000
commite3f39c752edbc5fc8a5251c4e029ce73aa38c50e (patch)
tree02f5a14a3d32218f4734d298ea72bfb34ad48543 /games/mvdsv
parentc035fb7218d5e63f0feab6b12d5315e7ee5118f1 (diff)
downloadports-e3f39c752edbc5fc8a5251c4e029ce73aa38c50e.tar.gz
ports-e3f39c752edbc5fc8a5251c4e029ce73aa38c50e.zip
- Trim old-school Makefile header per new bylaws
- Convert to modern OPTIONS framework (courtesy of jgh@)
Notes
Notes: svn path=/head/; revision=314450
Diffstat (limited to 'games/mvdsv')
-rw-r--r--games/mvdsv/Makefile25
1 files changed, 14 insertions, 11 deletions
diff --git a/games/mvdsv/Makefile b/games/mvdsv/Makefile
index 16851a666ca6..31989c80881c 100644
--- a/games/mvdsv/Makefile
+++ b/games/mvdsv/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: MVDSV (+ master port for qwdtools)
-# Date created: 03 Jun 2003
-# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
-#
+# Created by: Alexey Dokuchaev <danfe@regency.nsu.ru>
# $FreeBSD$
-#
PORTNAME?= mvdsv
PORTVERSION= 0.29
@@ -27,18 +23,25 @@ MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/${PORTNAME}
-OPTIONS= X86_ASM "Compile with x86 assembly code" on
+OPTIONS_DEFINE_i386= ASM
+OPTIONS_DEFINE_amd64= ASM
+OPTIONS_DEFAULT_i386= ASM
+OPTIONS_DEFAULT_amd64= ASM
+
.if ${PORTNAME} == "mvdsv"
-OPTIONS+= KQUEUE "Enable Kqueue support" on
+OPTIONS_DEFINE+= KQUEUE
+OPTIONS_DEFAULT+= KQUEUE
.endif
-.include <bsd.port.pre.mk>
+KQUEUE_DESC= Kqueue support
+
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_KQUEUE)
+.if ! ${PORT_OPTIONS:MKQUEUE}
MAKE_ARGS+= -DNOKQUEUE
.endif
-.if defined(WITHOUT_X86_ASM)
+.if ! ${PORT_OPTIONS:MASM}
MAKE_ARGS+= -DWITHOUT_X86_ASM
.endif
@@ -53,4 +56,4 @@ post-install:
@${ECHO_MSG}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>