aboutsummaryrefslogtreecommitdiff
path: root/games/nehquake/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-05-27 17:14:10 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-05-27 17:14:10 +0000
commit690c842abc2f0cfdf5d1af039a9218663cf864a0 (patch)
treef83112e8732007f8b7f5ddda7383b7b4f2c79553 /games/nehquake/Makefile
parent21912230929308e3549a6aaf8002d9873cc18e0c (diff)
downloadports-690c842abc2f0cfdf5d1af039a9218663cf864a0.tar.gz
ports-690c842abc2f0cfdf5d1af039a9218663cf864a0.zip
- Fix building on non i386 architectures.
- Add X86_ASM options. Approved by: garga (mentor, implicitly)
Notes
Notes: svn path=/head/; revision=163628
Diffstat (limited to 'games/nehquake/Makefile')
-rw-r--r--games/nehquake/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/games/nehquake/Makefile b/games/nehquake/Makefile
index f0b225c46b6f..69ce3c86c75d 100644
--- a/games/nehquake/Makefile
+++ b/games/nehquake/Makefile
@@ -21,7 +21,8 @@ USE_GL= yes
USE_GMAKE= yes
OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
- SDL "Build SDL client" on
+ SDL "Build SDL client" on \
+ X86_ASM "Enable x86 assembly code" on
ALL_TARGET= release
SUB_FILES= pkg-message
@@ -30,9 +31,13 @@ SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
-MAKE_ENV+= OPTIMIZED_CFLAGS=YES
-.endif
+.for f in OPTIMIZED_CFLAGS X86_ASM
+. if !defined(WITHOUT_${f})
+MAKE_ENV+= USE_${f}=YES
+. else
+MAKE_ENV+= USE_${f}=NO
+. endif
+.endfor
.if !defined(WITHOUT_SDL)
USE_SDL= sdl