aboutsummaryrefslogtreecommitdiff
path: root/games/nethack34-nox11
diff options
context:
space:
mode:
authorSeiichirou Hiraoka <flathill@FreeBSD.org>1999-03-21 09:13:43 +0000
committerSeiichirou Hiraoka <flathill@FreeBSD.org>1999-03-21 09:13:43 +0000
commit03d9e353dbf76214464d0fd6db1ae6fea2abd4c6 (patch)
tree9bb1c78fd4ba1c3a9f7b1e1e6217f3ce590f4e21 /games/nethack34-nox11
parent9fa160ce7c5af29b063eafcfe99eaa4b71c121e9 (diff)
downloadports-03d9e353dbf76214464d0fd6db1ae6fea2abd4c6.tar.gz
ports-03d9e353dbf76214464d0fd6db1ae6fea2abd4c6.zip
Fix 'missing rip.xpm' error.
patch-aa contains patch for some files. So separate to some patch-a? PR: ports/10680 Submitted by: h-nokubi@yyy.or.jp
Notes
Notes: svn path=/head/; revision=17329
Diffstat (limited to 'games/nethack34-nox11')
-rw-r--r--games/nethack34-nox11/files/patch-ab49
-rw-r--r--games/nethack34-nox11/files/patch-ac47
-rw-r--r--games/nethack34-nox11/files/patch-ad12
-rw-r--r--games/nethack34-nox11/files/patch-ae37
4 files changed, 139 insertions, 6 deletions
diff --git a/games/nethack34-nox11/files/patch-ab b/games/nethack34-nox11/files/patch-ab
index 4282a67b7ca9..a22424c84079 100644
--- a/games/nethack34-nox11/files/patch-ab
+++ b/games/nethack34-nox11/files/patch-ab
@@ -1,12 +1,49 @@
-diff -ruN ./sys/unix/Makefile.src ../nethack-3.2.2/sys/unix//Makefile.src
---- ./sys/unix/Makefile.src Sat Nov 21 01:23:57 1998
-+++ ../nethack-3.2.2/sys/unix/Makefile.src Sat Nov 21 01:15:41 1998
-@@ -204,7 +204,7 @@
+--- sys/unix/Makefile.src.orig Wed Dec 11 05:20:09 1996
++++ sys/unix/Makefile.src Sun Mar 21 17:50:08 1999
+@@ -124,8 +124,8 @@
+ # flags for debugging:
+ # CFLAGS = -g -I../include
+
+-CFLAGS = -O -I../include
+-LFLAGS =
++CFLAGS += -O -I../include -I${X11BASE}/include
++LFLAGS = -L${X11BASE}/lib
+
+
+ # Set the WINSRC, WINOBJ, and WINLIB lines to correspond to your desired
+@@ -146,8 +146,8 @@
+ winmisc.o winstat.o wintext.o winval.o tile.o
+ #
+ #
+-WINSRC = $(WINTTYSRC)
+-WINOBJ = $(WINTTYOBJ)
++WINSRC = $(WINTTYSRC) $(WINX11SRC)
++WINOBJ = $(WINTTYOBJ) $(WINX11OBJ)
+
+ # on some systems the termcap library is in -ltermcap or -lcurses
+ # on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
+@@ -167,13 +167,13 @@
+ #
+ # libraries for X11
+ # If USE_XPM is defined in config.h, you will also need -lXpm here.
+-WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
++WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11 -lXpm
+ # WINX11LIB = -lXaw -lXmu -lXt -lX11
+ # WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
+ # WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
#
- # LIBS = -lxpg4
+ #
+-WINLIB = $(WINTTYLIB)
++WINLIB = $(WINTTYLIB) $(WINX11LIB)
+
+ # any other strange libraries your system needs (for Sysunix only -- the more
+ # specialized targets should already be right)
+@@ -197,7 +197,7 @@
+ # IRIX 4.0.x needs -lsun if NIS (YP) is being used for passwd file lookup
+ # LIBS = -lsun
#
-LIBS =
+LIBS = -lSM -lICE
# make NetHack
- #JP by issei(96/5/27)
+ GAME = nethack
diff --git a/games/nethack34-nox11/files/patch-ac b/games/nethack34-nox11/files/patch-ac
new file mode 100644
index 000000000000..ee05125afe6c
--- /dev/null
+++ b/games/nethack34-nox11/files/patch-ac
@@ -0,0 +1,47 @@
+diff -ruN ./include/config.h ../nethack-3.2.2/include/config.h
+--- ./include/config.h Wed Dec 11 05:20:07 1996
++++ ../nethack-3.2.2/include/config.h Sun Mar 21 17:25:02 1999
+@@ -211,7 +211,7 @@
+ * Some combinations make no sense. See the installation document.
+ */
+ #define TTY_GRAPHICS /* good old tty based graphics */
+-/* #define X11_GRAPHICS /* X11 interface */
++#define X11_GRAPHICS /* X11 interface */
+
+ /*
+ * Define the default window system. This should be one that is compiled
+@@ -256,7 +256,7 @@
+ * would allow:
+ * xpmtoppm <x11tiles.xpm | pnmscale 1.25 | ppmquant 90 >x11tiles_big.xpm
+ */
+-/* # define USE_XPM /* Disable if you do not have the XPM library */
++# define USE_XPM /* Disable if you do not have the XPM library */
+ # ifdef USE_XPM
+ # define GRAPHIC_TOMBSTONE /* Use graphical tombstone (rip.xpm) */
+ # endif
+@@ -296,12 +296,12 @@
+
+ #ifdef UNIX
+ /* path and file name extension for compression program */
+-# define COMPRESS "/usr/ucb/compress" /* Lempel-Ziv compression */
+-# define COMPRESS_EXTENSION ".Z" /* compress's extension */
++/* # define COMPRESS "/usr/ucb/compress" /* Lempel-Ziv compression */
++/* # define COMPRESS_EXTENSION ".Z" /* compress's extension */
+
+ /* An example of one alternative you might want to use: */
+-/* # define COMPRESS "/usr/local/bin/gzip" /* FSF gzip compression */
+-/* # define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
++# define COMPRESS "/usr/bin/gzip" /* FSF gzip compression */
++# define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
+ #endif
+ #ifndef COMPRESS
+ # define INTERNAL_COMP /* control use of NetHack's compression routines */
+@@ -331,7 +331,7 @@
+ * otherwise it will be the current directory.
+ */
+ # ifndef HACKDIR
+-# define HACKDIR "/usr/games/lib/nethackdir" /* nethack directory */
++# define HACKDIR "/usr/local/share/nethack" /* nethack directory */
+ # endif
+
+ /*
diff --git a/games/nethack34-nox11/files/patch-ad b/games/nethack34-nox11/files/patch-ad
new file mode 100644
index 000000000000..a14729508f45
--- /dev/null
+++ b/games/nethack34-nox11/files/patch-ad
@@ -0,0 +1,12 @@
+diff -ruN ./include/system.h ../nethack-3.2.2/include/system.h
+--- ./include/system.h Mon Nov 4 23:01:25 1996
++++ ../nethack-3.2.2/include/system.h Sun Mar 21 17:25:02 1999
+@@ -80,7 +80,7 @@
+ # if !defined(SUNOS4) || defined(RANDOM)
+ E void FDECL(srandom, (unsigned int));
+ # else
+-# ifndef bsdi
++# if !defined(bsdi) && !defined(__FreeBSD__)
+ E int FDECL(srandom, (unsigned int));
+ # endif
+ # endif
diff --git a/games/nethack34-nox11/files/patch-ae b/games/nethack34-nox11/files/patch-ae
new file mode 100644
index 000000000000..b5c24ee2719d
--- /dev/null
+++ b/games/nethack34-nox11/files/patch-ae
@@ -0,0 +1,37 @@
+diff -ruN ./include/unixconf.h ../nethack-3.2.2/include/unixconf.h
+--- ./include/unixconf.h Wed Dec 11 05:20:08 1996
++++ ../nethack-3.2.2/include/unixconf.h Sun Mar 21 17:25:02 1999
+@@ -31,7 +31,7 @@
+
+ /* define any of the following that are appropriate */
+ /* #define SVR4 /* use in addition to SYSV for System V Release 4 */
+-#define NETWORK /* if running on a networked system */
++/* #define NETWORK /* if running on a networked system */
+ /* e.g. Suns sharing a playground through NFS */
+ #define SUNOS4 /* SunOS 4.x */
+ /* #define LINUX /* Another Unix clone */
+@@ -42,12 +42,12 @@
+ /* #define AIX_31 /* In AIX 3.1 (IBM RS/6000) use BSD ioctl's to gain
+ * job control (note that AIX is SYSV otherwise)
+ * Also define this for AIX 3.2 */
+-/* #define TEXTCOLOR /* Use System V r3.2 terminfo color support */
++#define TEXTCOLOR /* Use System V r3.2 terminfo color support */
+ /* and/or ANSI color support on termcap systems */
+ /* and/or X11 color */
+-/* #define POSIX_JOB_CONTROL /* use System V / POSIX job control
++#define POSIX_JOB_CONTROL /* use System V / POSIX job control
+ * (e.g., VSUSP) */
+-/* #define POSIX_TYPES /* use POSIX types for system calls and termios */
++#define POSIX_TYPES /* use POSIX types for system calls and termios */
+ /* define for many recent OS releases, including
+ * those with specific defines (since types are
+ * changing toward the standard from earlier chaos).
+@@ -125,7 +125,7 @@
+ * A stat system call is done on the mailbox every MAILCKFREQ moves.
+ */
+
+-#define MAIL /* Deliver mail during the game */
++/* #define MAIL /* Deliver mail during the game */
+
+ /* The Andrew Message System does mail a little differently from normal
+ * UNIX. Mail is deposited in the user's own directory in ~/Mailbox