aboutsummaryrefslogtreecommitdiff
path: root/games/netherearth/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-06-21 22:02:46 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-06-21 22:02:46 +0000
commit1ba6e3c1f783877c79b14f5041347a9fb5f31b0e (patch)
treeade1aef6184a01980b8f2a3e433ea9cb069c7294 /games/netherearth/Makefile
parenta5c2784e2d86417a7645231eea69f60f1126999f (diff)
downloadports-1ba6e3c1f783877c79b14f5041347a9fb5f31b0e.tar.gz
ports-1ba6e3c1f783877c79b14f5041347a9fb5f31b0e.zip
- Support staging.
- Apply local patch to avoid a complaint from the compiler: "Function <glutStrokeWidth> called without first calling 'glutInit'." PR: 190833 Submitted by: olevole@olevole.ru (maintainer)
Notes
Notes: svn path=/head/; revision=358753
Diffstat (limited to 'games/netherearth/Makefile')
-rw-r--r--games/netherearth/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/games/netherearth/Makefile b/games/netherearth/Makefile
index 0c4111cbfb91..b38dd6164962 100644
--- a/games/netherearth/Makefile
+++ b/games/netherearth/Makefile
@@ -3,7 +3,7 @@
PORTNAME= netherearth
PORTVERSION= 0.51
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= http://move.kirishi.ru/soft/netherearth/
@@ -15,14 +15,13 @@ GNU_CONFIGURE= yes
USE_GL= glut
USE_SDL= sdl mixer
-NO_STAGE= yes
pre-install:
- if [ ! -d ${PREFIX}/share/netherearth ] ; then \
- ${MKDIR} ${PREFIX}/share/netherearth ;\
+ if [ ! -d ${STAGEDIR}${PREFIX}/share/netherearth ] ; then \
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/netherearth ;\
fi
- ${CP} -R ${WRKSRC}/maps ${PREFIX}/share/netherearth/
- ${CP} -R ${WRKSRC}/models ${PREFIX}/share/netherearth/
- ${CP} -R ${WRKSRC}/sound ${PREFIX}/share/netherearth/
- ${CP} -R ${WRKSRC}/textures ${PREFIX}/share/netherearth/
+ ${CP} -R ${WRKSRC}/maps ${STAGEDIR}${PREFIX}/share/netherearth/
+ ${CP} -R ${WRKSRC}/models ${STAGEDIR}${PREFIX}/share/netherearth/
+ ${CP} -R ${WRKSRC}/sound ${STAGEDIR}${PREFIX}/share/netherearth/
+ ${CP} -R ${WRKSRC}/textures ${STAGEDIR}${PREFIX}/share/netherearth/
.include <bsd.port.mk>