aboutsummaryrefslogtreecommitdiff
path: root/games/netradiant
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-04-22 21:50:33 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-04-22 21:50:33 +0000
commit766a4d08383000149066d2ae993b52bd82a975d4 (patch)
treec9c670c29cbd31c65f33225598e1879788f11161 /games/netradiant
parente7ac27ee6a425407bf762320a4cddb500f79c3de (diff)
downloadports-766a4d08383000149066d2ae993b52bd82a975d4.tar.gz
ports-766a4d08383000149066d2ae993b52bd82a975d4.zip
- Fix build on 64 bit architectures (cast from pointer to int loses precision)
- Drop @dirrm* from plist Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=384522
Diffstat (limited to 'games/netradiant')
-rw-r--r--games/netradiant/files/patch-radiant_treemodel.cpp10
-rw-r--r--games/netradiant/pkg-plist22
2 files changed, 5 insertions, 27 deletions
diff --git a/games/netradiant/files/patch-radiant_treemodel.cpp b/games/netradiant/files/patch-radiant_treemodel.cpp
index a2d0329bf284..3961e471de0a 100644
--- a/games/netradiant/files/patch-radiant_treemodel.cpp
+++ b/games/netradiant/files/patch-radiant_treemodel.cpp
@@ -9,7 +9,7 @@
+ // well-defined C++ code, and Clang will assume that comparison
+ // below always evaluates to true, resulting in segmentation
+ // fault. Use a dirty hack to force Clang to check for null.
-+ volatile int n = (int)&node;
++ volatile intptr_t n = (intptr_t)&node;
+ if ( n != 0 ) {
Nameable* nameable = Node_getNameable( node );
if ( nameable != 0 ) {
@@ -19,7 +19,7 @@
}
void node_detach_name_changed_callback( scene::Node& node, const NameCallback& callback ){
- if ( &node != 0 ) {
-+ volatile int n = (int)&node; // see the comment on line 650
++ volatile intptr_t n = (intptr_t)&node; // see the comment on line 650
+ if ( n != 0 ) {
Nameable* nameable = Node_getNameable( node );
if ( nameable != 0 ) {
@@ -29,7 +29,7 @@
const char* node_get_name_safe( scene::Node& node ){
- if ( &node == 0 ) {
-+ volatile int n = (int)&node; // see the comment on line 650
++ volatile intptr_t n = (intptr_t)&node; // see the comment on line 650
+ if ( n == 0 ) {
return "";
}
@@ -39,7 +39,7 @@
void node_attach_name_changed_callback( scene::Node& node, const NameCallback& callback ){
- if ( &node != 0 ) {
-+ volatile int n = (int)&node; // see the comment on line 650
++ volatile intptr_t n = (intptr_t)&node; // see the comment on line 650
+ if ( n != 0 ) {
Nameable* nameable = Node_getNameable( node );
if ( nameable != 0 ) {
@@ -49,7 +49,7 @@
}
void node_detach_name_changed_callback( scene::Node& node, const NameCallback& callback ){
- if ( &node != 0 ) {
-+ volatile int n = (int)&node; // see the comment on line 650
++ volatile intptr_t n = (intptr_t)&node; // see the comment on line 650
+ if ( n != 0 ) {
Nameable* nameable = Node_getNameable( node );
if ( nameable != 0 ) {
diff --git a/games/netradiant/pkg-plist b/games/netradiant/pkg-plist
index 5f8a90dfb0ab..ed37ad94f1d5 100644
--- a/games/netradiant/pkg-plist
+++ b/games/netradiant/pkg-plist
@@ -171,25 +171,3 @@ man/man6/q3map2.6.gz
%%DATADIR%%/xonotic.game/data/entities.ent
%%DATADIR%%/xonotic.game/default_build_menu.xml
%%DATADIR%%/xonotic.game/game.xlink
-@dirrm %%DATADIR%%/xonotic.game/data
-@dirrm %%DATADIR%%/xonotic.game
-@dirrm %%DATADIR%%/warsow.game/basewsw
-@dirrm %%DATADIR%%/warsow.game
-@dirrm %%DATADIR%%/q1.game/id1
-@dirrm %%DATADIR%%/q1.game
-@dirrm %%DATADIR%%/plugins/bt
-@dirrm %%DATADIR%%/plugins/bitmaps
-@dirrm %%DATADIR%%/plugins
-@dirrm %%DATADIR%%/osirion.game/base
-@dirrm %%DATADIR%%/osirion.game
-@dirrm %%DATADIR%%/nexuiz.game/data
-@dirrm %%DATADIR%%/nexuiz.game
-@dirrm %%DATADIR%%/modules
-@dirrm %%DATADIR%%/heretic2
-@dirrm %%DATADIR%%/gl
-@dirrm %%DATADIR%%/games
-@dirrm %%DATADIR%%/docs
-@dirrm %%DATADIR%%/darkplaces.game/id1
-@dirrm %%DATADIR%%/darkplaces.game
-@dirrm %%DATADIR%%/bitmaps
-@dirrm %%DATADIR%%