aboutsummaryrefslogtreecommitdiff
path: root/games/nlarn
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2019-01-29 15:01:03 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2019-01-29 15:01:03 +0000
commitd4f5a60cd45fe038d7ebb270ac903343da7bb1ce (patch)
tree540f8fe0604394609bd4a03ef75d2f034cd0a5d6 /games/nlarn
parent451275d649e0536cb91589af021cdaa51a8493f2 (diff)
downloadports-d4f5a60cd45fe038d7ebb270ac903343da7bb1ce.tar.gz
ports-d4f5a60cd45fe038d7ebb270ac903343da7bb1ce.zip
games/nlarn: update 0.7.2_1 to 0.7.3
Makefile - adopt this port; portlint OK; - it now uses GitHub (following upstream's announce); - lua:51 changed to lua:53; - USES now has gnome (USE_GNOME= glib20); - unsilent patching and reinplaces. files/* - all patches removed after comparing with upstream code; - ran game locally on workstation, after building with new patch (OK). pkg-descr - updated WWW. https://nlarn.github.io/news/2018/09/08/release-0.7.3 Approved by: araujo (mentor) Differential Revision: https://reviews.freebsd.org/D18857
Notes
Notes: svn path=/head/; revision=491569
Diffstat (limited to 'games/nlarn')
-rw-r--r--games/nlarn/Makefile22
-rw-r--r--games/nlarn/distinfo5
-rw-r--r--games/nlarn/files/patch-Makefile27
-rw-r--r--games/nlarn/files/patch-src-game.c11
-rw-r--r--games/nlarn/files/patch-src-monsters.c14
-rw-r--r--games/nlarn/files/patch-src-player.c14
-rw-r--r--games/nlarn/pkg-descr2
-rw-r--r--games/nlarn/pkg-plist3
8 files changed, 18 insertions, 80 deletions
diff --git a/games/nlarn/Makefile b/games/nlarn/Makefile
index 479c2fa3646a..2fb74108e1f6 100644
--- a/games/nlarn/Makefile
+++ b/games/nlarn/Makefile
@@ -2,26 +2,28 @@
# $FreeBSD$
PORTNAME= nlarn
-PORTVERSION= 0.7.2
-PORTREVISION= 1
+DISTVERSIONPREFIX= NLarn-
+DISTVERSION= 0.7.3
CATEGORIES= games
-MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= egypcio@FreeBSD.org
COMMENT= Roguelike game and as such a remake of the classic game Larn
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= gmake lua:51 ncurses pkgconfig
-USE_GNOME= glib20
+USES= gmake gnome lua:53 ncurses pkgconfig
+USE_GNOME= glib20 introspection:build
+USE_GITHUB= yes
post-configure:
- @${REINPLACE_CMD} 's|/usr/share/nlarn|${DATADIR}|' \
+ ${REINPLACE_CMD} 's|/usr/share/nlarn|${DATADIR}|' \
${WRKSRC}/src/game.c
do-install:
- @${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/nlarn ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_DATA} ${WRKSRC}/README.txt ${WRKSRC}/nlarn.ini-sample ${WRKSRC}/lib/* ${STAGEDIR}${DATADIR}/
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/nlarn ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/nlarn.ini-sample ${WRKSRC}/lib/* ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>
diff --git a/games/nlarn/distinfo b/games/nlarn/distinfo
index f9e7a5946ef4..869df82a87b6 100644
--- a/games/nlarn/distinfo
+++ b/games/nlarn/distinfo
@@ -1,2 +1,3 @@
-SHA256 (nlarn-0.7.2.tar.gz) = 291fed77cb80261c5dfd375c702482f4d38415e3ce769b237ac22957d42dfbc8
-SIZE (nlarn-0.7.2.tar.gz) = 813829
+TIMESTAMP = 1547652196
+SHA256 (nlarn-nlarn-NLarn-0.7.3_GH0.tar.gz) = f604286374774d48cb96baa6fa09902e1d190e0f9ae47d80a7494a90a1eba7db
+SIZE (nlarn-nlarn-NLarn-0.7.3_GH0.tar.gz) = 912955
diff --git a/games/nlarn/files/patch-Makefile b/games/nlarn/files/patch-Makefile
deleted file mode 100644
index 54a82d9916f0..000000000000
--- a/games/nlarn/files/patch-Makefile
+++ /dev/null
@@ -1,27 +0,0 @@
---- Makefile.orig 2012-07-06 17:29:35 UTC
-+++ Makefile
-@@ -102,13 +102,13 @@ else
- LDFLAGS += $(shell pkg-config --libs glib-2.0)
-
- # Configuration for ncurses
-- ifeq ($(filter Darwin DragonFly OpenBSD,$(OS)),)
-+ ifeq ($(filter Darwin DragonFly FreeBSD OpenBSD,$(OS)),)
- CFLAGS += $(shell ncurses5-config --cflags)
- LDFLAGS += $(shell ncurses5-config --libs) -lpanel
- else
- # OS X is handled separately
- ifneq ($(OS), Darwin)
-- # DragonFly and OpenBSD have ncurses in base (and no config tool)
-+ # DragonFly, FreeBSD and OpenBSD have ncurses in base (and no config tool)
- LDFLAGS += -lncurses -lpanel
- endif
- endif
-@@ -117,6 +117,8 @@ else
- # Debian and derivates use lua5.1, the rest of the world lua
- ifneq ($(wildcard /etc/debian_version),)
- lua = lua5.1
-+ else ifeq ($(OS), FreeBSD)
-+ lua = lua-5.1
- else
- lua = lua
- endif
diff --git a/games/nlarn/files/patch-src-game.c b/games/nlarn/files/patch-src-game.c
deleted file mode 100644
index 01103f8331ac..000000000000
--- a/games/nlarn/files/patch-src-game.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/game.c.orig 2012-07-06 17:29:35 UTC
-+++ src/game.c
-@@ -1353,7 +1353,7 @@ static void game_scores_save(game *g, GL
- if (sb == NULL)
- {
- /* opening the file failed */
-- log_add_entry(g->log, "Error opening scoreboard file \"%s\".");
-+ log_add_entry(g->log, "Error opening scoreboard file.");
- free(uscores);
- return;
- }
diff --git a/games/nlarn/files/patch-src-monsters.c b/games/nlarn/files/patch-src-monsters.c
deleted file mode 100644
index 2429c25f8a68..000000000000
--- a/games/nlarn/files/patch-src-monsters.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/monsters.c.orig 2012-07-06 17:29:35 UTC
-+++ src/monsters.c
-@@ -2725,6 +2725,11 @@ static position monster_move_serve(monst
- map_path_element *pe = g_queue_pop_head(path->path);
- npos = pe->pos;
- }
-+ else
-+ {
-+ /* ensure npos is initialized */
-+ npos = m->pos;
-+ }
-
- if (path != NULL)
- map_path_destroy(path);
diff --git a/games/nlarn/files/patch-src-player.c b/games/nlarn/files/patch-src-player.c
deleted file mode 100644
index a511c9f18afd..000000000000
--- a/games/nlarn/files/patch-src-player.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/player.c.orig 2012-07-06 17:29:35 UTC
-+++ src/player.c
-@@ -1605,6 +1605,11 @@ int player_map_enter(player *p, map *l,
- else
- pos = map_find_sobject(l, LS_STAIRSUP);
- }
-+ /* doing nothing? */
-+ else
-+ {
-+ pos = p->pos;
-+ }
-
- if (l->nlevel == 0)
- {
diff --git a/games/nlarn/pkg-descr b/games/nlarn/pkg-descr
index 97a987700178..891eb3e3f7a5 100644
--- a/games/nlarn/pkg-descr
+++ b/games/nlarn/pkg-descr
@@ -8,4 +8,4 @@ Very noticeable differences to the original so far include:
- a real town
- colour
-WWW: http://nlarn.sourceforge.net/
+WWW: https://nlarn.github.io/
diff --git a/games/nlarn/pkg-plist b/games/nlarn/pkg-plist
index 09dbcd2e2ebe..1137c58c62ba 100644
--- a/games/nlarn/pkg-plist
+++ b/games/nlarn/pkg-plist
@@ -1,5 +1,6 @@
bin/nlarn
-%%DATADIR%%/README.txt
+%%DATADIR%%/FiraMono-Medium.otf
+%%DATADIR%%/README.md
%%DATADIR%%/fortune
%%DATADIR%%/maze
%%DATADIR%%/maze_doc.txt