aboutsummaryrefslogtreecommitdiff
path: root/games/noegnud-addons
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-18 13:12:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-18 13:12:51 +0000
commitb3ed5741b5d32dc811948b52ea4001b32cd15dfe (patch)
tree6946455509f2fc81f0992b53cffcc970a9fe6993 /games/noegnud-addons
parent29d2859d47c14b8f298b90b87c3cde0e0b664020 (diff)
downloadports-b3ed5741b5d32dc811948b52ea4001b32cd15dfe.tar.gz
ports-b3ed5741b5d32dc811948b52ea4001b32cd15dfe.zip
noeGNUd aims to be the ultimate User Interface ( UI ) for nethack. comibining
character mode, 2D tilesets and 3d graphics, all interchangeable at runtime to allow the serious nethack player ultimate freedom of interface to the game that allows ultimate freedom of gameplay and imagination. noegnud-data is the foundamental data for noeGNUd which all noeGNUd games depend on it. noegnud-nethack, noegnud-nethack-deet, noegnud-slashem, and noegnud-littlehack are the four variant games that noeGNUd support. noegnud-addons installs tilesets and sound themes. PR: ports/65318 Submitted by: Leland Wang <llwang@infor.org>
Notes
Notes: svn path=/head/; revision=129166
Diffstat (limited to 'games/noegnud-addons')
-rw-r--r--games/noegnud-addons/Makefile74
-rw-r--r--games/noegnud-addons/distinfo20
-rw-r--r--games/noegnud-addons/pkg-descr10
3 files changed, 104 insertions, 0 deletions
diff --git a/games/noegnud-addons/Makefile b/games/noegnud-addons/Makefile
new file mode 100644
index 000000000000..c7b366ebf842
--- /dev/null
+++ b/games/noegnud-addons/Makefile
@@ -0,0 +1,74 @@
+# New ports collection makefile for: noegnud-addons
+# Date created: 7 April 2004
+# Whom: Leland Wang <llwang@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= noegnud
+PORTVERSION= 0.8.0
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMESUFFIX= -addons
+DISTFILES= ${DISTNAME}_data-tileset-absurd${EXTRACT_SUFX}
+
+MAINTAINER= llwang@infor.org
+COMMENT= The addons (tilesets and sound themes) for noeGNUd
+
+PLIST= ${WRKDIR}/pkg-plist
+OPTIONS= TILESET_ABSURD "absurd tileset" on \
+ TILESET_ITAKURA "itakura tileset" off \
+ TILESET_MAZKO "mazko tileset" off \
+ TILESET_ABIGABI "abigabi tileset" off \
+ TILESET_GEODUCK "geoduck tileset" off \
+ TILESET_LAGGED "lagged tileset" off \
+ TILESET_AOKI "aoki tileset" off \
+ TILESET_FALCONSEYE "falcons eye tileset" off \
+ SOUND_NHS "nhs (qt) sound theme" off \
+ SOUND_FALCONSEYE "falcons eye sound theme" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_TILESET_ABSURD)
+DISTFILES=
+.endif
+.if defined(WITH_TILESET_ITAKURA)
+DISTFILES+= ${DISTNAME}_data-tileset-itakura${EXTRACT_SUFX}
+.endif
+.if defined(WITH_TILESET_MAZKO)
+DISTFILES+= ${DISTNAME}_data-tileset-mazko${EXTRACT_SUFX}
+.endif
+.if defined(WITH_TILESET_ABIGABI)
+DISTFILES+= ${DISTNAME}_data-tileset-abigabi${EXTRACT_SUFX}
+.endif
+.if defined(WITH_TILESET_GEODUCK)
+DISTFILES+= ${DISTNAME}_data-tileset-geoduck${EXTRACT_SUFX}
+.endif
+.if defined(WITH_TILESET_LAGGED)
+DISTFILES+= ${DISTNAME}_data-tileset-lagged${EXTRACT_SUFX}
+.endif
+.if defined(WITH_TILESET_AOKI)
+DISTFILES+= ${DISTNAME}_data-tileset-aoki${EXTRACT_SUFX}
+.endif
+.if defined(WITH_TILESET_FALCONSEYE)
+DISTFILES+= ${DISTNAME}_data-tileset-falconseye${EXTRACT_SUFX}
+.endif
+.if defined(WITH_SOUND_NHS)
+DISTFILES+= ${DISTNAME}_data-sound-nhs${EXTRACT_SUFX}
+.endif
+.if defined(WITH_SOUND_FALCONSEYE)
+DISTFILES+= ${DISTNAME}_data-sound-falconseye${EXTRACT_SUFX}
+.endif
+
+NO_BUILD= yes
+
+pre-install:
+ @${TOUCH} ${PLIST}
+ @(cd ${WRKDIR} && ${FIND} ${DISTNAME} \! -type d) | ${SORT} | ${SED} -e 's:^:share/:' > ${PLIST}
+ @(cd ${WRKDIR} && ${FIND} ${DISTNAME} -type d) | ${SORT} -r | ${SED} -e 's:^:@unexec rmdir %D/share/:' | ${SED} -e 's:$$: 2>/dev/null || true:' >> ${PLIST}
+
+do-install:
+ ${CP} -R ${WRKSRC} ${PREFIX}/share
+
+.include <bsd.port.post.mk>
diff --git a/games/noegnud-addons/distinfo b/games/noegnud-addons/distinfo
new file mode 100644
index 000000000000..b978dae1453f
--- /dev/null
+++ b/games/noegnud-addons/distinfo
@@ -0,0 +1,20 @@
+MD5 (noegnud-0.8.0_data-tileset-absurd.tar.gz) = fb0f84ad7d235cf7f98fb23255e19a67
+SIZE (noegnud-0.8.0_data-tileset-absurd.tar.gz) = 27003264
+MD5 (noegnud-0.8.0_data-tileset-itakura.tar.gz) = 506f08e2127ef15331d2dc0f947f8201
+SIZE (noegnud-0.8.0_data-tileset-itakura.tar.gz) = 745845
+MD5 (noegnud-0.8.0_data-tileset-mazko.tar.gz) = 1d61ec2d5af4e8d1eb339280cf038461
+SIZE (noegnud-0.8.0_data-tileset-mazko.tar.gz) = 1334121
+MD5 (noegnud-0.8.0_data-tileset-abigabi.tar.gz) = 3ccb59e21a64e41df973b96a0b777851
+SIZE (noegnud-0.8.0_data-tileset-abigabi.tar.gz) = 1237929
+MD5 (noegnud-0.8.0_data-tileset-geoduck.tar.gz) = 9289cfebfae571f177566c0ed7d43468
+SIZE (noegnud-0.8.0_data-tileset-geoduck.tar.gz) = 235655
+MD5 (noegnud-0.8.0_data-tileset-lagged.tar.gz) = afbb7e225c4ed38bcf844541b3b100b2
+SIZE (noegnud-0.8.0_data-tileset-lagged.tar.gz) = 303888
+MD5 (noegnud-0.8.0_data-tileset-aoki.tar.gz) = ab252a8da49e4d5ccdf0a1e49c9ccd02
+SIZE (noegnud-0.8.0_data-tileset-aoki.tar.gz) = 883545
+MD5 (noegnud-0.8.0_data-tileset-falconseye.tar.gz) = 834ea8a07c4b34547dd3a872c3bf93cd
+SIZE (noegnud-0.8.0_data-tileset-falconseye.tar.gz) = 7271450
+MD5 (noegnud-0.8.0_data-sound-nhs.tar.gz) = fd00e17e481170a682117ef05f7b92e8
+SIZE (noegnud-0.8.0_data-sound-nhs.tar.gz) = 266926
+MD5 (noegnud-0.8.0_data-sound-falconseye.tar.gz) = ee1c4c63ddb47608180f076e3588ab38
+SIZE (noegnud-0.8.0_data-sound-falconseye.tar.gz) = 257568
diff --git a/games/noegnud-addons/pkg-descr b/games/noegnud-addons/pkg-descr
new file mode 100644
index 000000000000..73d0907463f3
--- /dev/null
+++ b/games/noegnud-addons/pkg-descr
@@ -0,0 +1,10 @@
+noeGNUd is an alternate ascii/2D/3D User-Interface for the roguelike
+RPG "Nethack" and its Variants. Its difference to many other Interfaces
+lies in the utilisation of OpenGL to display the whole game. You can
+rotate the scenery as much as you like. It provides dynamic lightning
+and an outstanding 3D-Mode.
+
+This port installs addons (tilesets and sound themes) for noeGNUd.
+
+Author: Clive Crous
+WWW: http://noegnud.sourceforge.net/