aboutsummaryrefslogtreecommitdiff
path: root/games/noegnud-slashem
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-18 13:12:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-18 13:12:51 +0000
commitb3ed5741b5d32dc811948b52ea4001b32cd15dfe (patch)
tree6946455509f2fc81f0992b53cffcc970a9fe6993 /games/noegnud-slashem
parent29d2859d47c14b8f298b90b87c3cde0e0b664020 (diff)
downloadports-b3ed5741b5d32dc811948b52ea4001b32cd15dfe.tar.gz
ports-b3ed5741b5d32dc811948b52ea4001b32cd15dfe.zip
noeGNUd aims to be the ultimate User Interface ( UI ) for nethack. comibining
character mode, 2D tilesets and 3d graphics, all interchangeable at runtime to allow the serious nethack player ultimate freedom of interface to the game that allows ultimate freedom of gameplay and imagination. noegnud-data is the foundamental data for noeGNUd which all noeGNUd games depend on it. noegnud-nethack, noegnud-nethack-deet, noegnud-slashem, and noegnud-littlehack are the four variant games that noeGNUd support. noegnud-addons installs tilesets and sound themes. PR: ports/65318 Submitted by: Leland Wang <llwang@infor.org>
Notes
Notes: svn path=/head/; revision=129166
Diffstat (limited to 'games/noegnud-slashem')
-rw-r--r--games/noegnud-slashem/Makefile65
-rw-r--r--games/noegnud-slashem/distinfo4
-rw-r--r--games/noegnud-slashem/files/noegnud-slashem.patch114
-rw-r--r--games/noegnud-slashem/files/patch-noegnud::noegnud_glfuncs.h13
-rw-r--r--games/noegnud-slashem/files/patch-noegnud::noegnud_interface.h13
-rw-r--r--games/noegnud-slashem/files/patch-variants::Makefile51
-rw-r--r--games/noegnud-slashem/pkg-descr10
-rw-r--r--games/noegnud-slashem/pkg-plist186
8 files changed, 456 insertions, 0 deletions
diff --git a/games/noegnud-slashem/Makefile b/games/noegnud-slashem/Makefile
new file mode 100644
index 000000000000..19cbf0054cdf
--- /dev/null
+++ b/games/noegnud-slashem/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: noegnud-slashem
+# Date created: 7 April 2004
+# Whom: Leland Wang <llwang@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= noegnud
+PORTVERSION= 0.8.3
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}:noegnud,slashem
+MASTER_SITE_SUBDIR= ${PORTNAME}/:noegnud \
+ slashem/:slashem
+PKGNAMESUFFIX= -slashem
+DISTFILES= ${DISTNAME}_linux_src-minimal${EXTRACT_SUFX}:noegnud \
+ se006e4f8${EXTRACT_SUFX}:slashem
+EXTRACT_ONLY= ${DISTNAME}_linux_src-minimal${EXTRACT_SUFX}
+
+MAINTAINER= llwang@infor.org
+COMMENT= The noeGNUd UI for the SLASH'EM variant of Nethack
+
+RUN_DEPENDS= ${LOCALBASE}/share/${NOEGNUDVERSION}/data/gui:${PORTSDIR}/games/noegnud-data
+
+NOEGNUDVERSION= ${PORTNAME}-0.8.0
+USE_BISON= yes
+USE_GL= yes
+WANT_SDL= yes
+USE_SDL= sdl image mixer
+WRKSRC= ${WRKDIR}/${DISTNAME}/variants
+PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
+ALL_TARGET= se006e4f8
+INSTALL_TARGET= install_se006e4f8
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 502103
+USE_REINPLACE= yes
+.endif
+
+pre-everything::
+.if ${HAVE_SDL}
+ @${ECHO_MSG} "This port depends on SDL with OpenGL support."
+ @${ECHO_MSG} "If your SDL does not support OpenGL, hit ^C now and reinstall SDL"
+ @${ECHO_MSG} "with OpenGL support turned on."
+.endif
+
+post-extract:
+ @${CP} ${DISTDIR}/se006e4f8${EXTRACT_SUFX} ${WRKSRC}/tarballs
+ (cd ${WRKSRC} && ${MAKE} slashem-0.0.6E4F8)
+
+post-patch:
+ (cd ${WRKSRC} && ${MAKE} ${NOEGNUDVERSION}-slashem-0.0.6E4F8)
+ @(${PATCH} ${PATCH_ARGS} < ${FILESDIR}/noegnud-slashem.patch)
+.if ${OSVERSION} < 502103
+ @${REINPLACE_CMD} -e 's/regex\.h/gnuregex\.h/' \
+ ${WRKSRC}/slashem-0.0.6E4F8/src/sounds.c \
+ ${PATCH_WRKSRC}/noegnud/noegnud_textcolour.c \
+ ${PATCH_WRKSRC}/noegnud/noegnud_textcolour.h \
+ ${PATCH_WRKSRC}/noegnud/noegnud_textcolouring.c
+.endif
+
+do-configure:
+ (cd ${WRKSRC} && ${MAKE} ${NOEGNUDVERSION}-slashem-0.0.6E4F8/Makefile)
+
+.include <bsd.port.post.mk>
diff --git a/games/noegnud-slashem/distinfo b/games/noegnud-slashem/distinfo
new file mode 100644
index 000000000000..93b6d354c16e
--- /dev/null
+++ b/games/noegnud-slashem/distinfo
@@ -0,0 +1,4 @@
+MD5 (noegnud-0.8.3_linux_src-minimal.tar.gz) = d89827082e11059a5cdbef39314ca623
+SIZE (noegnud-0.8.3_linux_src-minimal.tar.gz) = 4882014
+MD5 (se006e4f8.tar.gz) = 2abd847d4f5fc426d6c7ed5a97b0de99
+SIZE (se006e4f8.tar.gz) = 4331015
diff --git a/games/noegnud-slashem/files/noegnud-slashem.patch b/games/noegnud-slashem/files/noegnud-slashem.patch
new file mode 100644
index 000000000000..591cd4a0d64e
--- /dev/null
+++ b/games/noegnud-slashem/files/noegnud-slashem.patch
@@ -0,0 +1,114 @@
+diff -urN variants/slashem-0.0.6E4F8.orig/sys/unix/Makefile.src variants/slashem-0.0.6E4F8/sys/unix/Makefile.src
+--- variants/slashem-0.0.6E4F8.orig/sys/unix/Makefile.src Sat Nov 20 21:50:19 2004
++++ variants/slashem-0.0.6E4F8/sys/unix/Makefile.src Sat Nov 20 21:53:09 2004
+@@ -31,7 +31,7 @@
+ # For Systos users compiling on the ST, you'll either need a bourne shell
+ # clone or you'll need to do make depend, etc. by hand. In either case,
+ # the line below probably needs changing
+-SHELL=/bin/sh
++# SHELL=/bin/sh
+ # for Atari
+ # SHELL=E:/GEMINI2/MUPFEL.TTP
+
+@@ -58,7 +58,7 @@
+ # if you get setcgtty() warnings during execution, you are feeding gcc
+ # a non-ANSI <sys/ioctl.h> -- either run fixincludes on it or use
+ # -traditional in CFLAGS
+-CC = gcc
++# CC = gcc
+ #
+ # For Bull DPX/2 systems at B.O.S. 2.0 or higher use the following:
+ #
+@@ -118,12 +118,12 @@
+ # flags for Linux
+ # compile normally
+
+-COMMON_CFLAGS = -DSLASHEM_0_0_6E4F8 -fomit-frame-pointer -I../include `sdl-config --cflags`
++COMMON_CFLAGS = -DSLASHEM_0_0_6E4F8 -fomit-frame-pointer -I../include -I/usr/include/gnu `${SDL_CONFIG} --cflags` -I/usr/X11R6/include
+
+ STD_CFLAGS = -O2 -ffast-math $(COMMON_CFLAGS)
+ DBG_CFLAGS = -g -Wall -DNOEGNUDDEBUG $(COMMON_CFLAGS)
+
+-CFLAGS = $(STD_CFLAGS)
++CFLAGS += $(STD_CFLAGS)
+
+ LFLAGS = -L/usr/X11R6/lib
+ # OR compile backwards compatible a.out format
+@@ -176,9 +176,9 @@
+ # The Qt and Be window systems are written in C++, while the rest of
+ # NetHack is standard C. If using Qt, uncomment the LD line here to get
+ # the C++ libraries linked in.
+-CXXFLAGS = $(CFLAGS) -I. -I$(QTINCDIR)
++CXXFLAGS += $(CFLAGS) -I. -I$(QTINCDIR)
+ # Qt is C++, so define the compiler and linker thus required:
+-CXX=g++
++#CXX=g++
+ #LD=g++
+
+ # GTK windowing system
+@@ -243,7 +243,10 @@
+ # Files for Entro-P's OpenGL 3D interface :: slashem-noegnud
+
+ WINNOEGNUDCFLAGS =
+-WINNOEGNUDLIB = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU
++WINNOEGNUDLIB = `${SDL_CONFIG} --libs` -lSDL_image -lSDL_mixer -lGL -lGLU -lgnuregex
++
++.c.o:
++ ${CC} ${CFLAGS} -c $< -o $@
+
+ NOEGNUD = ../win/noegnud/noegnud
+
+diff -urN variants/slashem-0.0.6E4F8.orig/sys/unix/Makefile.top variants/slashem-0.0.6E4F8/sys/unix/Makefile.top
+--- variants/slashem-0.0.6E4F8.orig/sys/unix/Makefile.top Sat Nov 20 21:50:19 2004
++++ variants/slashem-0.0.6E4F8/sys/unix/Makefile.top Sat Nov 20 21:53:30 2004
+@@ -14,7 +14,7 @@
+ # MAKE = make
+
+ # make NetHack
+-PREFIX = /usr/local/
++# PREFIX = /usr/local/
+ GAMEUI = noegnud-0.8.0
+ GAMEVARIANT = slashem-0.0.6E4F8
+ GAMESHORT = noegnud-$(GAMEVARIANT)
+@@ -41,7 +41,7 @@
+ # These must agree with the definitions in unixconf.h
+
+ # Defs. for non file areas support.
+-GAMEDIR = $(PREFIX)/lib/$(GAMEUI)/$(GAMEVARIANT)
++GAMEDIR = $(PREFIX)/share/$(GAMEUI)/$(GAMEVARIANT)
+ VARDIR = $(GAMEDIR)
+ FILE_AREA_VAR = $(VARDIR)
+ FILE_AREA_SAVE = $(VARDIR)/save
+diff -urN variants/slashem-0.0.6E4F8.orig/sys/unix/Makefile.utl variants/slashem-0.0.6E4F8/sys/unix/Makefile.utl
+--- variants/slashem-0.0.6E4F8.orig/sys/unix/Makefile.utl Sat Nov 20 21:50:19 2004
++++ variants/slashem-0.0.6E4F8/sys/unix/Makefile.utl Sat Nov 20 21:54:19 2004
+@@ -15,7 +15,7 @@
+
+ # if you are using gcc as your compiler,
+ # uncomment the CC definition below if it's not in your environment
+-CC = gcc
++# CC = gcc
+ #
+ # For Bull DPX/2 systems at B.O.S. 2.0 or higher use the following:
+ #
+@@ -72,7 +72,7 @@
+
+ # flags for Linux
+ # compile normally
+-CFLAGS = -O2 -fomit-frame-pointer -I../include -I/usr/X11R6/include
++CFLAGS += -O2 -fomit-frame-pointer -I../include -I/usr/X11R6/include
+ LFLAGS = -L/usr/X11R6/lib
+ # OR compile backwards compatible a.out format
+ # CFLAGS = -O2 -b i486-linuxaout -fomit-frame-pointer -I../include -I/usr/X11/include
+diff -urN variants/slashem-0.0.6E4F8.orig/win/tty/termcap.c variants/slashem-0.0.6E4F8/win/tty/termcap.c
+--- variants/slashem-0.0.6E4F8.orig/win/tty/termcap.c Sat Nov 20 23:11:00 2004
++++ variants/slashem-0.0.6E4F8/win/tty/termcap.c Sat Nov 20 23:11:19 2004
+@@ -835,7 +835,7 @@
+
+ #include <curses.h>
+
+-#ifndef LINUX
++#if 0
+ extern char *tparm();
+ #endif
+
diff --git a/games/noegnud-slashem/files/patch-noegnud::noegnud_glfuncs.h b/games/noegnud-slashem/files/patch-noegnud::noegnud_glfuncs.h
new file mode 100644
index 000000000000..147e9b0736e1
--- /dev/null
+++ b/games/noegnud-slashem/files/patch-noegnud::noegnud_glfuncs.h
@@ -0,0 +1,13 @@
+--- noegnud/noegnud_glfuncs.h.orig Wed Apr 7 13:46:11 2004
++++ noegnud/noegnud_glfuncs.h Wed Apr 7 13:46:27 2004
+@@ -2,8 +2,8 @@
+ #define _GLFUNCS_H_
+
+ #include <GL/gl.h>
+-#include <SDL/SDL.h>
+-#include <SDL/SDL_image.h>
++#include <SDL.h>
++#include <SDL_image.h>
+
+ typedef struct {
+ int width,height;
diff --git a/games/noegnud-slashem/files/patch-noegnud::noegnud_interface.h b/games/noegnud-slashem/files/patch-noegnud::noegnud_interface.h
new file mode 100644
index 000000000000..05b1a944199a
--- /dev/null
+++ b/games/noegnud-slashem/files/patch-noegnud::noegnud_interface.h
@@ -0,0 +1,13 @@
+--- noegnud/noegnud_interface.h.orig Wed Apr 7 13:47:53 2004
++++ noegnud/noegnud_interface.h Wed Apr 7 13:48:07 2004
+@@ -1,8 +1,8 @@
+ #ifndef _NOEGNUD_INTERFACE_H_
+ #define _NOEGNUD_INTERFACE_H_
+
+-#include <SDL/SDL.h>
+-#include <SDL/SDL_image.h>
++#include <SDL.h>
++#include <SDL_image.h>
+ #include <GL/gl.h>
+ #include <GL/glu.h>
+
diff --git a/games/noegnud-slashem/files/patch-variants::Makefile b/games/noegnud-slashem/files/patch-variants::Makefile
new file mode 100644
index 000000000000..64a0919d8c0d
--- /dev/null
+++ b/games/noegnud-slashem/files/patch-variants::Makefile
@@ -0,0 +1,51 @@
+--- variants/Makefile.orig Mon Nov 15 03:02:30 2004
++++ variants/Makefile Mon Nov 15 03:03:25 2004
+@@ -1,7 +1,6 @@
+ NOEGNUDVERSION=noegnud-0.8.0
+ # you __MUST__ change this if you change the prefix for any variants' install !!!!!!!!!!!!!
+ # although ..... " make -e foo " also works :O ;)
+-PREFIX = /usr/local
+ GAMEUID = games
+ GAMEGRP = bin
+ CHOWN = chown
+@@ -62,31 +61,31 @@
+ install: install_all
+
+ install_nh342: nh342
+- make -e -C $(NOEGNUDVERSION)-nethack-3.4.2 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-nethack-3.4.2 install
+
+ install_nh343: nh343
+- make -e -C $(NOEGNUDVERSION)-nethack-3.4.3 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-nethack-3.4.3 install
+
+ install_se006e4f8: se006e4f8
+- make -e -C $(NOEGNUDVERSION)-slashem-0.0.6E4F8 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.6E4F8 install
+
+ install_se007e2: se007e2
+- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E2 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E2 install
+
+ install_se007e5: se007e5
+- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E5 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E5 install
+
+ install_se007e6: se007e6
+- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E6 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E6 install
+
+ install_se007e6f2: se007e6f2
+- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E6F2 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E6F2 install
+
+ install_lh001: lh001
+- make -e -C $(NOEGNUDVERSION)-littlehack-0.0.1 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-littlehack-0.0.1 install
+
+ install_nh342-dt: nh342-dt
+- make -e -C $(NOEGNUDVERSION)-nethack-3.4.2-deet install
++ make -EPREFIX -C $(NOEGNUDVERSION)-nethack-3.4.2-deet install
+
+ # data
+
diff --git a/games/noegnud-slashem/pkg-descr b/games/noegnud-slashem/pkg-descr
new file mode 100644
index 000000000000..995cda3bf5cd
--- /dev/null
+++ b/games/noegnud-slashem/pkg-descr
@@ -0,0 +1,10 @@
+noeGNUd is an alternate ascii/2D/3D User-Interface for the roguelike
+RPG "Nethack" and its Variants. Its difference to many other Interfaces
+lies in the utilisation of OpenGL to display the whole game. You can
+rotate the scenery as much as you like. It provides dynamic lightning
+and an outstanding 3D-Mode.
+
+This port installs noeGNUd for the SLASH'EM variant of Nethack.
+
+Author: Clive Crous
+WWW: http://noegnud.sourceforge.net/
diff --git a/games/noegnud-slashem/pkg-plist b/games/noegnud-slashem/pkg-plist
new file mode 100644
index 000000000000..07dc6230f237
--- /dev/null
+++ b/games/noegnud-slashem/pkg-plist
@@ -0,0 +1,186 @@
+bin/noegnud-0.8.0-slashem-0.0.6E4F8
+bin/noegnud-slashem-0.0.6E4F8
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Arc-fila.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Arc-filb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Arc-goal.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Arc-loca.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Arc-strt.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Bar-fila.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Bar-filb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Bar-goal.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Bar-loca.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Bar-strt.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Cav-fila.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Cav-filb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Cav-goal.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Cav-loca.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Cav-strt.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Fla-fila.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Fla-filb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Fla-goal.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Fla-loca.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Fla-strt.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Guidebook.txt
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Hea-fila.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Hea-filb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Hea-goal.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Hea-loca.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Hea-strt.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Ice-fila.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Ice-filb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Ice-goal.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Ice-loca.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Ice-strt.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Kni-fila.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Kni-filb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Kni-goal.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Kni-loca.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Kni-strt.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Mon-fila.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Mon-filb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Mon-goal.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Mon-loca.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Mon-strt.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Nec-fila.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Nec-filb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Nec-goal.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Nec-loca.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Nec-strt.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Pri-fila.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Pri-filb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Pri-goal.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Pri-loca.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Pri-strt.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Ran-fila.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Ran-filb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Ran-goal.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Ran-loca.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Ran-strt.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Rog-fila.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Rog-filb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Rog-goal.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Rog-loca.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Rog-strt.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Sam-fila.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Sam-filb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Sam-goal.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Sam-loca.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Sam-strt.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Tou-fila.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Tou-filb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Tou-goal.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Tou-loca.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Tou-strt.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Und-fila.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Und-filb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Und-goal.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Und-loca.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Und-strt.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Val-fila.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Val-filb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Val-goal.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Val-loca.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Val-strt.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Wiz-fila.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Wiz-filb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Wiz-goal.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Wiz-loca.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Wiz-strt.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Yeo-fila.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Yeo-filb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Yeo-goal.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Yeo-loca.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/Yeo-strt.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/air.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/asmodeus.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/astral.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/baalz.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/beholder.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/bigrm-1.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/bigrm-2.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/bigrm-3.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/bigrm-4.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/bigrm-5.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/blkmar.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/castle.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/cav2fill.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/cavefill.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/cmdhelp
+share/noegnud-0.8.0/slashem-0.0.6E4F8/data
+share/noegnud-0.8.0/slashem-0.0.6E4F8/demogorg.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/dispater.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/dragons.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/dungeon
+share/noegnud-0.8.0/slashem-0.0.6E4F8/earth.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/fakewiz1.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/fakewiz2.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/fire.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/frnknstn.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/geryon.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/guild.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/gypsy.txt
+share/noegnud-0.8.0/slashem-0.0.6E4F8/help
+share/noegnud-0.8.0/slashem-0.0.6E4F8/hh
+share/noegnud-0.8.0/slashem-0.0.6E4F8/history
+share/noegnud-0.8.0/slashem-0.0.6E4F8/juiblex.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/knox.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/kobold-1.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/kobold-2.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/license
+share/noegnud-0.8.0/slashem-0.0.6E4F8/lich.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/logfile
+share/noegnud-0.8.0/slashem-0.0.6E4F8/mall-1.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/mall-2.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/mall.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/medusa-1.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/medusa-2.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/minefill.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/mineking.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/minend-1.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/minend-2.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/minetn-1.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/minetn-2.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/mtemple.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/nightmar.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/noegnud-0.8.0-slashem-0.0.6E4F8
+share/noegnud-0.8.0/slashem-0.0.6E4F8/nymph.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/opthelp
+share/noegnud-0.8.0/slashem-0.0.6E4F8/options
+share/noegnud-0.8.0/slashem-0.0.6E4F8/oracle.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/oracles
+share/noegnud-0.8.0/slashem-0.0.6E4F8/orcus.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/perm
+share/noegnud-0.8.0/slashem-0.0.6E4F8/quest.dat
+share/noegnud-0.8.0/slashem-0.0.6E4F8/rats.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/record
+share/noegnud-0.8.0/slashem-0.0.6E4F8/rumors
+share/noegnud-0.8.0/slashem-0.0.6E4F8/sanctum.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/sea.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/soko1-1.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/soko1-2.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/soko2-1.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/soko2-2.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/soko3-1.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/soko3-2.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/soko4-1.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/soko4-2.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/spiders.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/stor-1.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/stor-2.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/stor-3.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/tomb.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/tower1.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/tower2.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/tower3.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/valley.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/water.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/wizard1.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/wizard2.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/wizard3.lev
+share/noegnud-0.8.0/slashem-0.0.6E4F8/wizhelp
+share/noegnud-0.8.0/slashem-0.0.6E4F8/yeenoghu.lev
+@exec chown games:bin %D/share/noegnud-0.8.0/slashem-0.0.6E4F8
+@exec chmod 775 %D/share/noegnud-0.8.0/slashem-0.0.6E4F8
+@unexec rmdir %D/share/noegnud-0.8.0/slashem-0.0.6E4F8/save 2>/dev/null || true
+@unexec rmdir %D/share/noegnud-0.8.0/slashem-0.0.6E4F8 2>/dev/null || true
+@unexec rmdir %D/share/noegnud-0.8.0 2>/dev/null || true