aboutsummaryrefslogtreecommitdiff
path: root/games/nxengine
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-04-04 17:38:10 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-04-04 17:38:10 +0000
commitc1a541e10b6da4e977a1c56303ca18763254bc5e (patch)
treebd99c1f9fd4d9ff682c82dc5739770a4ca386b18 /games/nxengine
parentf390ea6077c7f2203c80030dda537ba49703381a (diff)
downloadports-c1a541e10b6da4e977a1c56303ca18763254bc5e.tar.gz
ports-c1a541e10b6da4e977a1c56303ca18763254bc5e.zip
Conditionalize compiler flags that are specific to clang to fix errors
of the following forms on GCC-based architectures: cc1plus: error: unrecognized command line option "-Wno-c++11-narrowing" cc1plus: error: unrecognized command line option "-Wno-reserved-user-defined-literal" cc1plus: warning: unrecognized command line option '-Wno-error-narrowing' Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=497858
Diffstat (limited to 'games/nxengine')
-rw-r--r--games/nxengine/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/games/nxengine/Makefile b/games/nxengine/Makefile
index d6de72579219..daa9d5653247 100644
--- a/games/nxengine/Makefile
+++ b/games/nxengine/Makefile
@@ -29,7 +29,8 @@ USES= cmake compiler:c++11-lang
USE_SDL= mixer2 sdl2
SUB_FILES= ${PORTNAME}
-CXXFLAGS+= -Wno-error-narrowing
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-error-narrowing
USE_GITHUB= yes
GH_PROJECT= ${PORTNAME}-evo