aboutsummaryrefslogtreecommitdiff
path: root/games/openage/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-11-30 08:29:54 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-11-30 08:29:54 +0000
commit54aafbe1992cd05d62fbb689c8e3a4c6abdeee61 (patch)
tree7a597b97cf392ee87da1983199592c6006c9d828 /games/openage/Makefile
parent4f2dcbf0a4c47b9898ea121a6b2751d10dac953e (diff)
downloadports-54aafbe1992cd05d62fbb689c8e3a4c6abdeee61.tar.gz
ports-54aafbe1992cd05d62fbb689c8e3a4c6abdeee61.zip
games/openage: try to unbreak and undeprecate the port
Earlier fix (see PR) was briefly helpful against Pygments v2.9, but had to be extended for version 2.10 and beyond. While here, remove rather useless `pre-configure' target. PR: 257471
Diffstat (limited to 'games/openage/Makefile')
-rw-r--r--games/openage/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/games/openage/Makefile b/games/openage/Makefile
index bf2d9a4fd8db..b1a622aabe49 100644
--- a/games/openage/Makefile
+++ b/games/openage/Makefile
@@ -11,10 +11,6 @@ WWW= https://openage.sft.mx/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/legal/GPLv3
-BROKEN= fails to build
-DEPRECATED= Outdated, fails to build and marked broken several months ago
-EXPIRATION_DATE=2023-11-30
-
BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR} \
${PY_PILLOW} \
@@ -48,8 +44,9 @@ CMAKE_ARGS= -DGLOBAL_CONFIG_DIR:STRING=${ETCDIR}
BINARY_ALIAS= python3=${PYTHON_CMD}
-pre-configure:
- ${REINPLACE_CMD} -e 's|python3|${PYTHON_CMD}|' ${WRKSRC}/openage/codegen/main.py
+post-patch:
+ @${REINPLACE_CMD} -e '/^#include <algorithm>/ { x; s/^/#include <array>/; H; x; }' \
+ ${WRKSRC}/libopenage/renderer/vulkan/render_target.h
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/openage