aboutsummaryrefslogtreecommitdiff
path: root/games/opencity/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-12 16:26:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-12 16:26:10 +0000
commit095a642be25cd37f70edfa851c758f5a2e4d02b4 (patch)
tree325c25357c2b7f92f21796614e6c7148534b6b24 /games/opencity/Makefile
parent2e0a20d9be7ed7888b7f6110b4fa35a0594990af (diff)
downloadports-095a642be25cd37f70edfa851c758f5a2e4d02b4.tar.gz
ports-095a642be25cd37f70edfa851c758f5a2e4d02b4.zip
OpenCity is a full 3D city simulator game project. It is written
in standard C++ with OpenGL and SDL from scratch. It is not intended to be a clone of any famous city simulator from Max*s. So, if you are looking to download a free SimCity 4 like, please forget OpenCity. WWW: http://opencity.sourceforge.net PR: ports/119492 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
Notes
Notes: svn path=/head/; revision=205536
Diffstat (limited to 'games/opencity/Makefile')
-rw-r--r--games/opencity/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/opencity/Makefile b/games/opencity/Makefile
new file mode 100644
index 000000000000..adecd65ac025
--- /dev/null
+++ b/games/opencity/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: opencity
+# Date created: 07 Jan 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= opencity
+PORTVERSION= 0.0.5.1
+CATEGORIES= games
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}stable
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Free 3D city simulator
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_SDL= sdl mixer image net
+USE_GL= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.0.5stable
+
+PORTDOCS= *
+
+MAN6= opencity.6
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|\(defined(__WIN32__) && \)\(!defined(log2)\)|\2|' \
+ ${WRKSRC}/src/mapgen/mapmaker.cpp
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|docs||' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>