aboutsummaryrefslogtreecommitdiff
path: root/games/openjk
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-04-30 18:51:53 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-04-30 18:51:53 +0000
commitb87081fe090e84e45c395ca3a5444dde6268f1e0 (patch)
tree72cf384bb31a9ec3f30102b53e282513a1fd272b /games/openjk
parente13c10e11e3995c835769ed421f411ced1b42be1 (diff)
downloadports-b87081fe090e84e45c395ca3a5444dde6268f1e0.tar.gz
ports-b87081fe090e84e45c395ca3a5444dde6268f1e0.zip
games/openjk: Community effort to maintain Jedi Academy + Jedi Outcast
OpenJK is an effort by the JACoders group to maintain and improve the game engines on which the Jedi Academy (JA) and Jedi Outcast (JO) games run on, while maintaining full backwards compatibility with the existing games. This project does not attempt to rebalance or otherwise modify core gameplay. WWW: https://openjk.org PR: 227265 Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D19955
Notes
Notes: svn path=/head/; revision=500522
Diffstat (limited to 'games/openjk')
-rw-r--r--games/openjk/Makefile32
-rw-r--r--games/openjk/distinfo3
-rw-r--r--games/openjk/files/jamp.in3
-rw-r--r--games/openjk/files/jasp.in3
-rw-r--r--games/openjk/files/patch-CMakeModules_InstallConfig.cmake13
-rw-r--r--games/openjk/pkg-descr6
-rw-r--r--games/openjk/pkg-message28
-rw-r--r--games/openjk/pkg-plist14
8 files changed, 102 insertions, 0 deletions
diff --git a/games/openjk/Makefile b/games/openjk/Makefile
new file mode 100644
index 000000000000..5f819b7f6ff6
--- /dev/null
+++ b/games/openjk/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= openjk
+PORTVERSION= g20190428
+CATEGORIES= games
+
+MAINTAINER= pkubaj@FreeBSD.org
+COMMENT= Community effort to maintain Jedi Academy + Jedi Outcast
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libpng.so:graphics/png
+
+USES= compiler:c++11-lang cmake gl jpeg localbase sdl
+USE_GL= gl glu
+USE_GITHUB= yes
+GH_ACCOUNT= JACoders
+GH_PROJECT= OpenJK
+GH_TAGNAME= 911c537
+USE_SDL= sdl2
+USE_XORG= x11
+
+CXXFLAGS+= -DNDEBUG
+PLIST_SUB= ARCH="${ARCH}"
+SUB_FILES= jamp \
+ jasp
+SUB_LIST= ARCH="${ARCH}"
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/jamp ${WRKDIR}/jasp ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/games/openjk/distinfo b/games/openjk/distinfo
new file mode 100644
index 000000000000..2d3e603d0e8e
--- /dev/null
+++ b/games/openjk/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1556633408
+SHA256 (JACoders-OpenJK-g20190428-911c537_GH0.tar.gz) = df142c5557b4ed31da9056d3cdba0ce376612e346024722530f84f05bfabd66b
+SIZE (JACoders-OpenJK-g20190428-911c537_GH0.tar.gz) = 11695891
diff --git a/games/openjk/files/jamp.in b/games/openjk/files/jamp.in
new file mode 100644
index 000000000000..1d454f361420
--- /dev/null
+++ b/games/openjk/files/jamp.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd %%PREFIX%%/share/JediAcademy && ./openjk.%%ARCH%%
diff --git a/games/openjk/files/jasp.in b/games/openjk/files/jasp.in
new file mode 100644
index 000000000000..fa9cb7718602
--- /dev/null
+++ b/games/openjk/files/jasp.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd %%PREFIX%%/share/JediAcademy && ./openjk_sp.%%ARCH%%
diff --git a/games/openjk/files/patch-CMakeModules_InstallConfig.cmake b/games/openjk/files/patch-CMakeModules_InstallConfig.cmake
new file mode 100644
index 000000000000..c0769cf702ef
--- /dev/null
+++ b/games/openjk/files/patch-CMakeModules_InstallConfig.cmake
@@ -0,0 +1,13 @@
+--- CMakeModules/InstallConfig.cmake.orig 2019-04-07 09:22:21 UTC
++++ CMakeModules/InstallConfig.cmake
+@@ -17,8 +17,8 @@
+ #============================================================================
+
+ # Subdirectories to package JK2 and JKA into
+-set(JKAInstallDir "JediAcademy")
+-set(JK2InstallDir "JediOutcast")
++set(JKAInstallDir "share/JediAcademy")
++set(JK2InstallDir "share/JediOutcast")
+
+ # Install components
+ set(JKAMPCoreComponent "JKAMPCore")
diff --git a/games/openjk/pkg-descr b/games/openjk/pkg-descr
new file mode 100644
index 000000000000..0b52ee5f1b2b
--- /dev/null
+++ b/games/openjk/pkg-descr
@@ -0,0 +1,6 @@
+OpenJK is an effort by the JACoders group to maintain and improve the game
+engines on which the Jedi Academy (JA) and Jedi Outcast (JO) games run on,
+while maintaining full backwards compatibility with the existing games.
+This project does not attempt to rebalance or otherwise modify core gameplay.
+
+WWW: https://openjk.org
diff --git a/games/openjk/pkg-message b/games/openjk/pkg-message
new file mode 100644
index 000000000000..ba8c4f2096ec
--- /dev/null
+++ b/games/openjk/pkg-message
@@ -0,0 +1,28 @@
+OpenJK requires the original game files from Star Wars: Jedi Knight:
+Jedi Academy to work properly. These can come from an original CD or
+from GOG.com.
+
+If using the GOG.com version, you must extract the files from
+setup_star_wars_jedi_knight_-_jedi_academy_1.01_(a)_(10331)_(g).exe
+using the innoextract package.
+
+The files will be in a directory named app. Inside the app directory,
+there is a GameData directory. Inside the GameData directory, there is
+a directory named base. This base directory must be moved to
+~/.local/share/openjk
+
+The easiest way to do this is to follow these steps:
+$ mkdir -p ~/.local/share/openjk
+$ innoextract setup_star_wars_jedi_knight_-_jedi_academy_1.01_(a)_(10331)_(g).exe
+$ cd app/GameData
+$ cp -R base ~/.local/share/openjk
+
+You can then delete everything else that is extracted from the exe,
+such as the tmp directory.
+
+The multiplayer game binary is jamp and the single player game binary
+is jasp.
+
+If you own a copy of Star Wars: Jedi Knight: Jedi Outcast, its game
+files may be used to play that game, though upstream makes no
+guarantees on your success in playing this game.
diff --git a/games/openjk/pkg-plist b/games/openjk/pkg-plist
new file mode 100644
index 000000000000..325d51ec93cf
--- /dev/null
+++ b/games/openjk/pkg-plist
@@ -0,0 +1,14 @@
+bin/jamp
+bin/jasp
+share/JediAcademy/OpenJK/cgame%%ARCH%%.so
+share/JediAcademy/OpenJK/jagame%%ARCH%%.so
+share/JediAcademy/OpenJK/jampgame%%ARCH%%.so
+share/JediAcademy/OpenJK/ui%%ARCH%%.so
+share/JediAcademy/base/cgame%%ARCH%%.so
+share/JediAcademy/base/jampgame%%ARCH%%.so
+share/JediAcademy/base/ui%%ARCH%%.so
+share/JediAcademy/openjk.%%ARCH%%
+share/JediAcademy/openjk_sp.%%ARCH%%
+share/JediAcademy/openjkded.%%ARCH%%
+share/JediAcademy/rd-vanilla_%%ARCH%%.so
+share/JediAcademy/rdsp-vanilla_%%ARCH%%.so