aboutsummaryrefslogtreecommitdiff
path: root/games/openlierox/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-03-10 04:24:37 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-03-10 04:24:37 +0000
commit928ac34ec2d6067aef734966aa12b34d97bc080b (patch)
treee598dc0c354ff04cbcfb1ab41fdaabc9f9af93a8 /games/openlierox/Makefile
parentd676e8607f49fd9aa3b9d85cea53338346085aa5 (diff)
downloadports-928ac34ec2d6067aef734966aa12b34d97bc080b.tar.gz
ports-928ac34ec2d6067aef734966aa12b34d97bc080b.zip
- Update to 0.59_beta10
Notes
Notes: svn path=/head/; revision=313801
Diffstat (limited to 'games/openlierox/Makefile')
-rw-r--r--games/openlierox/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/games/openlierox/Makefile b/games/openlierox/Makefile
index 72a12fcebaa3..414cdc72365e 100644
--- a/games/openlierox/Makefile
+++ b/games/openlierox/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= openlierox
-DISTVERSION= 0.59_beta9
-PORTREVISION= 3
+DISTVERSION= 0.59_beta10
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/OpenLieroX%20${DISTVERSION:C/_/%20/}
DISTNAME= OpenLieroX_${DISTVERSION}.src
@@ -21,6 +20,7 @@ USE_SDL= sdl image
USE_GNOME= libxml2
MAKE_JOBS_SAFE= yes
USE_OPENAL= yes
+USE_GCC= 4.6+
CFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include
@@ -30,7 +30,8 @@ USE_CMAKE= yes
CMAKE_ARGS= -DHAWKNL_BUILTIN=YES \
-DLIBZIP_BUILTIN=YES \
-DBREAKPAD=NO \
- -DSYSTEM_DATA_DIR="${DATADIR}"
+ -DSYSTEM_DATA_DIR="${DATADIR}" \
+ -DHASBFD=NO
WRKSRC= ${WRKDIR}/OpenLieroX
@@ -42,11 +43,16 @@ PLIST_FILES= bin/openlierox \
share/pixmaps/OpenLieroX.svg
PLIST_DIRSTRY= share/applications
-OPTIONS= DEDICATED_ONLY "Build dedicated server only" off
+OPTIONS_DEFINE= DEDICATED_ONLY DOCS
+DEDICATED_ONLY_DESC=Build dedicated server only
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_DEDICATED_ONLY)
+.if ${OSVERSION} < 700000
+IGNORE= does not build on 7.x
+.endif
+
+.if ${PORT_OPTIONS:MDEDICATED_ONLY}
BROKEN= does not build
CMAKE_ARGS+= -DDEDICATED_ONLY=YES
.else
@@ -55,7 +61,8 @@ USE_SDL+= mixer
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-mt||; s|EXEC_PROGRAM.*OLXVER)|SET(OLXVER "${DISTVERSION}")|; \
+ @${REINPLACE_CMD} -e 's|boost_signals-mt|boost_signals boost_system|; \
+ s|EXEC_PROGRAM.*OLXVER)|SET(OLXVER "${DISTVERSION}")|; \
s|/usr/local|${LOCALBASE}|' ${WRKSRC}/CMakeOlxCommon.cmake
@${FIND} ${WRKSRC} \( -name "*.cpp" -o -name "*.h" -o -name "*.cc" \) -print0 | ${XARGS} -0 -n1 \
${REINPLACE_CMD} -e '/include.*curl\/types.h/ d'
@@ -71,9 +78,9 @@ do-install:
${MKDIR} ${DATADIR}
cd ${WRKSRC}/share/gamedir && ${COPYTREE_SHARE} . ${DATADIR}/
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR}/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>