aboutsummaryrefslogtreecommitdiff
path: root/games/openra/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-06-11 20:33:55 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-06-11 20:33:55 +0000
commitc7365d53d1160cb7270b0c8a4e969872d8225a1b (patch)
tree3ac7f2c79a5e2587181acd4b78e627b96012afca /games/openra/Makefile
parent807b5357dd8a92cd01a60e4639c989f71e21f057 (diff)
downloadports-c7365d53d1160cb7270b0c8a4e969872d8225a1b.tar.gz
ports-c7365d53d1160cb7270b0c8a4e969872d8225a1b.zip
games/openra: make GeoLite2 fetch deterministic
PR: 228877
Notes
Notes: svn path=/head/; revision=472204
Diffstat (limited to 'games/openra/Makefile')
-rw-r--r--games/openra/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/games/openra/Makefile b/games/openra/Makefile
index 342ecdf3567a..57d20789f763 100644
--- a/games/openra/Makefile
+++ b/games/openra/Makefile
@@ -14,8 +14,8 @@ DISTFILES= SDL2-CS.dll:SDL2_CS \
OpenAL-CS.dll:OpenAL_CS \
OpenAL-CS.dll.config:OpenAL_CS \
Eluant.dll:Eluant \
- GeoLite2-Country.mmdb.gz:GeoLite2
-EXTRACT_ONLY= ${DISTFILES:C/:.*//:N*.config:N*.dll:N*.mmdb*:N*.nupkg}
+ GeoLite2-Country_20180605${EXTRACT_SUFX}:GeoLite2
+EXTRACT_ONLY= ${DISTFILES:C/:.*//:N*.config:N*.dll:N*.nupkg}
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Multiplayer re-envisioning of early RTS games by Westwood Studios
@@ -59,7 +59,9 @@ TEST_ALL_TARGET=test
post-extract:
${CP} ${DISTFILES:C/:.*//:N*.nupkg:N*.tar*:S,^,${_DISTDIR}/,} \
+ ${WRKDIR}/GeoLite2-Country*/GeoLite2-Country.mmdb \
${NUGET_PACKAGEDIR}
+ ${GZIP_CMD} ${NUGET_PACKAGEDIR}/GeoLite2-Country.mmdb
post-patch:
${REINPLACE_CMD} \