aboutsummaryrefslogtreecommitdiff
path: root/games/openspades
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-10-30 18:08:16 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-12-11 13:50:53 +0000
commit45526ecbeec33dbb87f0b678d4c04988aab9b657 (patch)
treeb77614b463af0ed929512fcc838ff5cb20c96275 /games/openspades
parenta148ebec4e0afe980f949de0dea5ef4931cb7e86 (diff)
downloadports-45526ecbeec33dbb87f0b678d4c04988aab9b657.tar.gz
ports-45526ecbeec33dbb87f0b678d4c04988aab9b657.zip
framework: Add new USES 'magick' for graphics/ImageMagick*
A new USES has been added to depend on ImageMagick. USES=magick adds a LIB_DEPENDS on graphics/ImageMagick${IMAGEMAGICK_DEFAULT}. If a specific version is required, use for example USES=magick:6 resp. USES=magick:7 If only a build, run or test is required, use for example USES=magick:build resp. USES=magick:6,build,test If a dependency on the nox11 flavor is required, use for example USES=magick:nox11 resp. USES=magick:7,nox11,run,test See magick.mk for more details on the available flags. The tree has been completely converted to make use of this. Approved by: bapt Differential Revision: https://reviews.freebsd.org/D32754
Diffstat (limited to 'games/openspades')
-rw-r--r--games/openspades/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/games/openspades/Makefile b/games/openspades/Makefile
index cd5f8606416e..48f79b74fc3f 100644
--- a/games/openspades/Makefile
+++ b/games/openspades/Makefile
@@ -15,7 +15,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= amd64 powerpc64 powerpc64le
ONLY_FOR_ARCHS_REASON= bundles non-portable AngelScript
-BUILD_DEPENDS= convert:graphics/ImageMagick6 # for building icons
LIB_DEPENDS= libcurl.so:ftp/curl \
libopusfile.so:audio/opusfile
@@ -23,7 +22,7 @@ USE_GITHUB= yes
GH_ACCOUNT= yvt
USES= cmake:insource compiler:c++11-lib desktop-file-utils dos2unix \
- gl gnome openal sdl xorg
+ gl gnome magick:6,build openal sdl xorg
CMAKE_ARGS= -DOPENSPADES_RESOURCES=OFF \
-DOPENSPADES_INSTALL_MAN="man/man6" \
-DOPENSPADES_INSTALL_BINARY="bin" \