aboutsummaryrefslogtreecommitdiff
path: root/games/openssn/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-05-02 14:16:49 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-05-02 14:16:49 +0000
commitdd6f9aecd223894fd0211f09b7a15f4a3a89bcfc (patch)
tree78e72938e9ae1fafd84cf8b4b69b5d7c261245bd /games/openssn/Makefile
parent504cac19e8af2daa15b41035a8c601571db30990 (diff)
downloadports-dd6f9aecd223894fd0211f09b7a15f4a3a89bcfc.tar.gz
ports-dd6f9aecd223894fd0211f09b7a15f4a3a89bcfc.zip
Convert graphics/sdl_gfx to USES=libtool. Also set USE_AUTOTOOLS because
upstream forgot to regenerate the build scripts. This makes the build use the correct version information and causes a library version bump. Use this opportunity to use USES=libtool instead of USES=libtool:oldver. Bump PORTREVISION on all dependent ports and convert them to USES=libtool where needed. Also use USES=(gmake, pathfix, tar) and new LIB_DEPENDS syntax here and there. games/freedink-engine: - Option helpers. - Staging. - Use dirrmtry for locale directories. games/oolite: - Staging. - Replace ECHO with ECHO_CMD. - Don't use GNUSTEP_PREFIX to install files because it expands to LOCALBASE rather than PREFIX. games/openssn: - Remove USES=desktop-file-utils. No MimeType field in desktop file. - Staging. - Install files in standard DATADIR. games/xblast: - Use proper options. - Staging. - Patch configure so normal make install can be used instead of do-install. - Replace TAR | TAR with COPYTREE_SHARE.
Notes
Notes: svn path=/head/; revision=352815
Diffstat (limited to 'games/openssn/Makefile')
-rw-r--r--games/openssn/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/games/openssn/Makefile b/games/openssn/Makefile
index 0cf2bed1e1e5..48d8131b216c 100644
--- a/games/openssn/Makefile
+++ b/games/openssn/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openssn
PORTVERSION= 1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -12,16 +12,13 @@ COMMENT= Modern submarine simulator
LICENSE= GPLv2
-MAN6= openssn.6
-MANCOMPRESSED= yes
-
-USES= desktop-file-utils
USE_SDL= sdl gfx image mixer
USE_XORG= x11 xau xdmcp xext xmu xpm xxf86vm
WRKSRC= ${WRKDIR}/${PORTNAME}
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e 's,share/man/man6,man/man6,g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -E \
+ -e '/cp|mkdir/s,\$$\(PREFIX\)|\$$\(DATADIR\),$$(DESTDIR)&,' \
+ -e 's,share/man/man6,man/man6,' ${WRKSRC}/Makefile
.include <bsd.port.mk>