aboutsummaryrefslogtreecommitdiff
path: root/games/p5-Games-Bingo
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-09-01 13:34:31 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-09-01 13:34:31 +0000
commit5499179a3439775e65d5f447fa57263f6014f87c (patch)
tree248dcce6986c5d44b2efab7464ab9f041e0a6d20 /games/p5-Games-Bingo
parentc52937521e80ab4dad23b3d75bd8ed9510e95653 (diff)
downloadports-5499179a3439775e65d5f447fa57263f6014f87c.tar.gz
ports-5499179a3439775e65d5f447fa57263f6014f87c.zip
Add p5-Games-Bingo 0.08, a bingo game Perl implementation.
PR: 55813 Submitted by: Lars Thegler <lars@thegler.dk>
Notes
Notes: svn path=/head/; revision=88275
Diffstat (limited to 'games/p5-Games-Bingo')
-rw-r--r--games/p5-Games-Bingo/Makefile32
-rw-r--r--games/p5-Games-Bingo/distinfo1
-rw-r--r--games/p5-Games-Bingo/pkg-descr7
-rw-r--r--games/p5-Games-Bingo/pkg-plist11
4 files changed, 51 insertions, 0 deletions
diff --git a/games/p5-Games-Bingo/Makefile b/games/p5-Games-Bingo/Makefile
new file mode 100644
index 000000000000..91203c20dfe2
--- /dev/null
+++ b/games/p5-Games-Bingo/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Games-Bingo
+# Date created: 14. August 2003
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Games-Bingo
+PORTVERSION= 0.08
+CATEGORIES= games perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Games
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@thegler.dk
+COMMENT= A bingo game Perl implementation
+
+PERL_CONFIGURE= yes
+
+MAN3= Games::Bingo.3 \
+ Games::Bingo::Card.3 \
+ Games::Bingo::Column.3 \
+ Games::Bingo::ColumnCollection.3
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing example for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/bingo.pl ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/p5-Games-Bingo/distinfo b/games/p5-Games-Bingo/distinfo
new file mode 100644
index 000000000000..85494bf4fe7c
--- /dev/null
+++ b/games/p5-Games-Bingo/distinfo
@@ -0,0 +1 @@
+MD5 (Games-Bingo-0.08.tar.gz) = 094ba8e1d8f805f686d35aba17716360
diff --git a/games/p5-Games-Bingo/pkg-descr b/games/p5-Games-Bingo/pkg-descr
new file mode 100644
index 000000000000..d7a2352a50fc
--- /dev/null
+++ b/games/p5-Games-Bingo/pkg-descr
@@ -0,0 +1,7 @@
+Games::Bingo - a bingo game Perl implementation. This is a simple game
+of bingo. The program can randomly call out the numbers.
+
+WWW: http://search.cpan.org/dist/Games-Bingo/
+
+- Lars Thegler
+lars@thegler.dk
diff --git a/games/p5-Games-Bingo/pkg-plist b/games/p5-Games-Bingo/pkg-plist
new file mode 100644
index 000000000000..04d48c5e2903
--- /dev/null
+++ b/games/p5-Games-Bingo/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Games/Bingo.pm
+%%SITE_PERL%%/Games/Bingo/Card.pm
+%%SITE_PERL%%/Games/Bingo/Column.pm
+%%SITE_PERL%%/Games/Bingo/ColumnCollection.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Bingo/.packlist
+%%PORTDOCS%%%%EXAMPLESDIR%%/bingo.pl
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Bingo
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Games/Bingo
+@unexec rmdir %D/%%SITE_PERL%%/Games 2>/dev/null || true