aboutsummaryrefslogtreecommitdiff
path: root/games/penguin-command
diff options
context:
space:
mode:
authorMark Pulford <markp@FreeBSD.org>2003-02-10 13:21:21 +0000
committerMark Pulford <markp@FreeBSD.org>2003-02-10 13:21:21 +0000
commit0adf0c51e2256754e73fadbad3116c79ef0b8e32 (patch)
treeae738bc7c1d19ab153d9fc181261924e69ee7e9f /games/penguin-command
parentc9f3db841dc6a0b31b8ab54f720127ffcdcd776e (diff)
downloadports-0adf0c51e2256754e73fadbad3116c79ef0b8e32.tar.gz
ports-0adf0c51e2256754e73fadbad3116c79ef0b8e32.zip
Changed to use REINPLACE.
Notes
Notes: svn path=/head/; revision=75237
Diffstat (limited to 'games/penguin-command')
-rw-r--r--games/penguin-command/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/penguin-command/Makefile b/games/penguin-command/Makefile
index a345eb3c8569..f512966e5872 100644
--- a/games/penguin-command/Makefile
+++ b/games/penguin-command/Makefile
@@ -19,14 +19,15 @@ LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
MAN6= penguin-command.6
post-patch:
- ${PERL} -pi -e 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g' \
+ ${REINPLACE_CMD} 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g' \
${WRKSRC}/configure ${WRKSRC}/src/*.[ch]
- ${PERL} -pi -e "s/ -lz -lSDL -lm/ -lz -lm/g" ${WRKSRC}/configure
+ ${REINPLACE_CMD} 's/ -lz -lSDL -lm/ -lz -lm/g' ${WRKSRC}/configure
.include <bsd.port.mk>