aboutsummaryrefslogtreecommitdiff
path: root/games/pengupop
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-16 12:06:00 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-16 12:06:00 +0000
commit422b6e5c91ded060fdc2b5eb8818b378812f8534 (patch)
treeb1429a2b9f2af15d820fde5285d69ecc9bdc51d6 /games/pengupop
parentbab0c51054ce8f2d943dcff1832eb7a94a7a43bb (diff)
downloadports-422b6e5c91ded060fdc2b5eb8818b378812f8534.tar.gz
ports-422b6e5c91ded060fdc2b5eb8818b378812f8534.zip
The aim of this game is to shoot colored balls so the form similarily
colored groups, causing them to fall out of the screen. You can either win by clearing your entire field, or lose if any balls attach below the white line near the bottom. The main difference between this game and the classic Bust a Move, is online multiplayer support, with menu options for playing against random opponents, or starting or joining a named (private) game. WWW: http://www.junoplay.com/ PR: ports/98966 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Notes
Notes: svn path=/head/; revision=165566
Diffstat (limited to 'games/pengupop')
-rw-r--r--games/pengupop/Makefile35
-rw-r--r--games/pengupop/distinfo3
-rw-r--r--games/pengupop/files/patch-main.c10
-rw-r--r--games/pengupop/pkg-descr10
4 files changed, 58 insertions, 0 deletions
diff --git a/games/pengupop/Makefile b/games/pengupop/Makefile
new file mode 100644
index 000000000000..b0aa68f73456
--- /dev/null
+++ b/games/pengupop/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: pengupop
+# Date created: 14 Jun 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pengupop
+PORTVERSION= 2.0.2
+CATEGORIES= games
+MASTER_SITES= http://www.junoplay.com/files/
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Online multiplayer clone of Bust a Move
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+USE_GCC= 3.4+
+CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags`" \
+ LDFLAGS="`${SDL_CONFIG} --libs`"
+
+PLIST_FILES= bin/pengupop
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not build on FreeBSD 4.x: lack of swprintf
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/*.c
+ @${REINPLACE_CMD} -e 's|-lSDL||' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.post.mk>
diff --git a/games/pengupop/distinfo b/games/pengupop/distinfo
new file mode 100644
index 000000000000..542c8e7350d8
--- /dev/null
+++ b/games/pengupop/distinfo
@@ -0,0 +1,3 @@
+MD5 (pengupop-2.0.2.tar.gz) = 5c213ecb3cf1bd714dbae771f97ee19a
+SHA256 (pengupop-2.0.2.tar.gz) = 8f8bd11a6f55ba5ad2e45635d109850f1d5c2eb733bb8149ee10f8fc216b20c1
+SIZE (pengupop-2.0.2.tar.gz) = 1936736
diff --git a/games/pengupop/files/patch-main.c b/games/pengupop/files/patch-main.c
new file mode 100644
index 000000000000..f6ac2711329e
--- /dev/null
+++ b/games/pengupop/files/patch-main.c
@@ -0,0 +1,10 @@
+--- main.c.orig Wed Jun 14 15:41:04 2006
++++ main.c Thu Jun 15 03:42:45 2006
+@@ -29,6 +29,7 @@
+ #include <io.h>
+ #endif
+
++#include <sys/time.h>
+ #include <errno.h>
+ #include <limits.h>
+ #include <math.h>
diff --git a/games/pengupop/pkg-descr b/games/pengupop/pkg-descr
new file mode 100644
index 000000000000..e62da77629bc
--- /dev/null
+++ b/games/pengupop/pkg-descr
@@ -0,0 +1,10 @@
+The aim of this game is to shoot colored balls so the form similarily
+colored groups, causing them to fall out of the screen. You can
+either win by clearing your entire field, or lose if any balls
+attach below the white line near the bottom.
+
+The main difference between this game and the classic Bust a Move,
+is online multiplayer support, with menu options for playing against
+random opponents, or starting or joining a named (private) game.
+
+WWW: http://www.junoplay.com/