aboutsummaryrefslogtreecommitdiff
path: root/games/phlipple
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-30 10:36:54 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-30 10:36:54 +0000
commitc9e43954f5a1b21cec57f00145d584d917844c58 (patch)
tree2dd9a7d0f860c4dc11283ef3967617604fb3436f /games/phlipple
parent656ef8030a476deb0c118d4fd3df95d144515cc6 (diff)
downloadports-c9e43954f5a1b21cec57f00145d584d917844c58.tar.gz
ports-c9e43954f5a1b21cec57f00145d584d917844c58.zip
Fix build with -fno-common
While here add license (GPLv3)
Notes
Notes: svn path=/head/; revision=550675
Diffstat (limited to 'games/phlipple')
-rw-r--r--games/phlipple/Makefile11
-rw-r--r--games/phlipple/files/patch-src_engine.h11
2 files changed, 18 insertions, 4 deletions
diff --git a/games/phlipple/Makefile b/games/phlipple/Makefile
index de158fa1076a..0c675572b806 100644
--- a/games/phlipple/Makefile
+++ b/games/phlipple/Makefile
@@ -3,19 +3,22 @@
PORTNAME= phlipple
PORTVERSION= 0.8.5
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Flipping squares will never be the same
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis
-USES= desktop-file-utils gl pkgconfig sdl
-USE_SDL= sdl mixer image
+USES= desktop-file-utils gl pkgconfig sdl dos2unix xorg
USE_GL= gl glew glu
+USE_SDL= sdl mixer image
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -24,8 +27,8 @@ LIBS+= -L${LOCALBASE}/lib -lm
PLIST_FILES= bin/${PORTNAME} \
share/applications/${PORTNAME}.desktop \
share/pixmaps/${PORTNAME}.png
-PORTDOCS= *
PORTDATA= *
+PORTDOCS= *
OPTIONS_DEFINE= DOCS
diff --git a/games/phlipple/files/patch-src_engine.h b/games/phlipple/files/patch-src_engine.h
new file mode 100644
index 000000000000..8011a2a68dc6
--- /dev/null
+++ b/games/phlipple/files/patch-src_engine.h
@@ -0,0 +1,11 @@
+--- src/engine.h.orig 2012-05-19 10:26:56 UTC
++++ src/engine.h
+@@ -44,7 +44,7 @@
+
+ #define VERTEX_DRAW_INNER_OFFSET 0.15f
+
+-char debugOutput[1024];
++extern char debugOutput[1024];
+
+ #include "renderstate.h"
+