aboutsummaryrefslogtreecommitdiff
path: root/games/pinball/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-04-13 20:29:52 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-04-13 20:29:52 +0000
commitc3d86089091f291a26b7e59fcae914cd475c4e19 (patch)
tree59a8c52af202ea8a5aca8d38bfb23c7c8ec52a08 /games/pinball/Makefile
parent2313ccd4433b9d71edfe73f5d532629f69c3ccf9 (diff)
downloadports-c3d86089091f291a26b7e59fcae914cd475c4e19.tar.gz
ports-c3d86089091f291a26b7e59fcae914cd475c4e19.zip
- Support stage and use the new infrastructure;
- Remove MAKE_JOBS_UNSAFE; - Register /var/games/pinball.
Notes
Notes: svn path=/head/; revision=351237
Diffstat (limited to 'games/pinball/Makefile')
-rw-r--r--games/pinball/Makefile46
1 files changed, 20 insertions, 26 deletions
diff --git a/games/pinball/Makefile b/games/pinball/Makefile
index 00804c8004e9..797f41c34176 100644
--- a/games/pinball/Makefile
+++ b/games/pinball/Makefile
@@ -3,54 +3,48 @@
PORTNAME= pinball
PORTVERSION= 0.3.1
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= thierry@FreeBSD.org
COMMENT= Emilia Pinball is a free pinball game
-.if !defined(WITH_ALLEGRO)
-BUILD_DEPENDS= ${SDL_CONFIG}:${PORTSDIR}/devel/sdl12
-.else
-BROKEN= support with Allegro is (temporarily) broken as of version 0.3.1
-BUILD_DEPENDS= ${ALLEGRO_CONFIG}:${PORTSDIR}/devel/allegro
-LIB_DEPENDS= alleg.42:${PORTSDIR}/devel/allegro
-.endif
+LICENSE= GPLv2
-USE_SDL= image mixer sdl
-USE_GMAKE= yes
+USES= gmake libtool
USE_GL= gl
-USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --without-debug
+
.if defined(WITH_ALLEGRO)
+BROKEN= support with Allegro is (temporarily?) broken as of version 0.3.1
+LIB_DEPENDS+= liballeg.so:${PORTSDIR}/devel/allegro
CONFIGURE_ARGS+= --with-allegro
-EXTRA_LIBS= -lGL -lGLU
+USE_GL+= glu
+.else
+USE_SDL= image mixer sdl
.endif
+
CPPFLAGS+= -I${LOCALBASE}/include -DRZR_LIBSTATIC
-LDFLAGS+= -L${LOCALBASE}/lib ${EXTRA_LIBS}
-MAKE_JOBS_UNSAFE= yes
-ALLEGRO_CONFIG= ${LOCALBASE}/bin/allegro-config
+LDFLAGS+= -L${LOCALBASE}/lib
+#MAKE_JOBS_UNSAFE= yes
DOCS= README
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-# For gmake>=3.82
-post-patch:
- @${FIND} ${WRKSRC} -name Makefile.in -print | ${XARGS} \
- ${REINPLACE_CMD} -e 's,^dnl,# dnl,'
+# For gmake>=3.82 + ranlib runs twice
+pre-configure:
+ ${FIND} ${WRKSRC} -name Makefile.in -print | ${XARGS} \
+ ${REINPLACE_CMD} -e 's,^dnl,# dnl,;/echo.*RANLIB/,+1d'
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for FILE in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}
.endfor
- @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>