aboutsummaryrefslogtreecommitdiff
path: root/games/pingus/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-10-07 08:46:30 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-10-07 08:46:30 +0000
commit79a93d0231fbeab73d23e70ea8d9d214f1982b10 (patch)
treeb84198d98fdcd62a864a34ddcc1604dfa3a02f0d /games/pingus/Makefile
parentbdcb9f0e58f826441a8e077b50812580898b5ae1 (diff)
downloadports-79a93d0231fbeab73d23e70ea8d9d214f1982b10.tar.gz
ports-79a93d0231fbeab73d23e70ea8d9d214f1982b10.zip
- Some mezz@ improvements
- Bump PORTREVISION - Remove pkg-message file Submitted by: mezz@ via email
Notes
Notes: svn path=/head/; revision=201036
Diffstat (limited to 'games/pingus/Makefile')
-rw-r--r--games/pingus/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/games/pingus/Makefile b/games/pingus/Makefile
index a8f98322e774..1dc55f00176a 100644
--- a/games/pingus/Makefile
+++ b/games/pingus/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pingus
PORTVERSION= 0.7.1
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://pingus.seul.org/files/
@@ -23,7 +24,10 @@ USE_SCONS= yes
USE_SDL= sdl image mixer
PLIST= ${WRKDIR}/pkg-plist
-SUB_FILES= pkg-message
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|add_path("data")|add_path("${DATADIR}")|g' \
+ ${WRKSRC}/src/pingus_main.cpp
pre-install:
@${RM} -f ${PLIST}
@@ -40,7 +44,4 @@ do-install:
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>